Статьи с тэгом :
Закрыть
История изменений
Закрыть
Статьи с тэгом :
Закрыть

Использование именованных диапазонов

Имена - это осмысленные обозначения, которые можно присвоить ячейке или диапазону ячеек и использовать для упрощения работы с формулами. При создании формул в качестве аргумента можно использовать имя, а не ссылку на диапазон ячеек. Например, если присвоить диапазону ячеек имя Годовой_доход, то можно будет вводить формулу =СУММ(Годовой_доход) вместо =СУММ(B1:B12) и т.д. В таком виде формулы становятся более понятными. Эта возможность также может быть полезна, если большое количество формул ссылается на один и тот же диапазон ячеек. При изменении адреса диапазона можно один раз внести исправление в Диспетчере имен, а не редактировать все формулы по одной.

Есть два типа имен, которые можно использовать:

  • Определенное имя – произвольное имя, которое вы можете задать для некоторого диапазона ячеек. К определенным именам также относятся имена, создаваемые автоматически при установке областей печати.
  • Имя таблицы – стандартное имя, которое автоматически присваивается новой форматированной таблице (Таблица1, Таблица2 и т.д.). Такое имя впоследствии можно отредактировать.

Имена также классифицируются по Области действия, то есть по области, в которой это имя распознается. Областью действия имени может быть вся книга (имя будет распознаваться на любом листе в этой книге) или отдельный лист (имя будет распознаваться только на указанном листе). Каждое имя в пределах одной области должно быть уникальным, одинаковые имена можно использовать внутри разных областей.

Создание новых имен

Чтобы создать новое определенное имя для выделенной области:

  1. Выделите ячейку или диапазон ячеек, которым требуется присвоить имя.
  2. Откройте окно создания нового имени удобным для вас способом:
    • Щелкните по выделенной области правой кнопкой мыши и выберите из контекстного меню пункт Присвоить имя
    • или щелкните по значку Именованные диапазоны Значок Именованные диапазоны на вкладке Главная верхней панели инструментов и выберите из меню опцию Новое имя.

    Откроется окно Новое имя:

    Окно Новое имя

  3. Введите нужное Имя в поле ввода текста.

    Примечание: имя не может начинаться с цифры, содержать пробелы или знаки препинания. Разрешено использовать нижние подчеркивания (_). Регистр не имеет значения.

  4. Укажите Область действия диапазона. По умолчанию выбрана область Книга, но можно указать отдельный лист, выбрав его из списка.
  5. Проверьте адрес выбранного Диапазона данных. В случае необходимости его можно изменить. Нажмите на кнопку Выбор данных - откроется окно Выбор диапазона данных.

    Окно Выбор диапазона данных

    Измените ссылку на диапазон ячеек в поле ввода или мышью выделите новый диапазон на листе и нажмите кнопку OK.

  6. Нажмите кнопку OK, чтобы сохранить новое имя.

Чтобы быстро создать новое имя для выделенного диапазона ячеек, можно также ввести нужное имя в поле "Имя" слева от строки формул и нажать Enter. Областью действия имени, созданного таким способом, является Книга.

Поле Имя

Управление именами

Получить доступ ко всем существующим именам можно через Диспетчер имен. Чтобы его открыть:

  • щелкните по значку Именованные диапазоны Значок Именованные диапазоны на вкладке Главная верхней панели инструментов и выберите из меню опцию Диспетчер имен
  • или щелкните по стрелке в поле "Имя" и выберите опцию Диспетчер имен.

Откроется окно Диспетчер имен:

Окно Диспетчер имен

Для удобства можно фильтровать имена, выбирая ту категорию имен, которую надо показать: Все, Определенные имена, Имена таблиц, Имена на листе или Имена в книге. В списке будут отображены имена, относящиеся к выбранной категории, остальные имена будут скрыты.

Чтобы изменить порядок сортировки для отображенного списка, нажмите в этом окне на заголовок Именованные диапазоны или Область.

Чтобы отредактировать имя, выделите его в списке и нажмите кнопку Изменить. Откроется окно Изменение имени:

Окно Изменение имени

Для определенного имени можно изменить имя и диапазон данных, на который оно ссылается. Для имени таблицы можно изменить только имя. Когда будут сделаны все нужные изменения, нажмите кнопку OK, чтобы применить их. Чтобы сбросить изменения, нажмите кнопку Отмена. Если измененное имя используется в какой-либо формуле, формула будет автоматически изменена соответствующим образом.

Чтобы удалить имя, выделите его в списке и нажмите кнопку Удалить.

Примечание: если удалить имя, которое используется в формуле, формула перестанет работать (она будет возвращать ошибку #ИМЯ?).

В окне Диспетчер имен можно также создать новое имя, нажав кнопку Новое.

Использование имен при работе с электронной таблицей

Для быстрого перемещения между диапазонами ячеек можно нажать на стрелку в поле "Имя" и выбрать нужное имя из списка имен – на листе будет выделен диапазон данных, соответствующий этому имени.

Список имен

Примечание: в списке имен отображены определенные имена и имена таблиц, областью действия которых является текущий лист и вся книга.

Чтобы добавить имя в качестве аргумента формулы:

  1. Установите курсор там, куда надо вставить имя.
  2. Выполните одно из следующих действий:
    • введите имя нужного именованного диапазона вручную с помощью клавиатуры. Как только вы введете начальные буквы, появится список Автозавершения формул. По мере ввода в нем отображаются элементы (формулы и имена), которые соответствуют введенным символам. Можно выбрать нужное имя из списка и вставить его в формулу, дважды щелкнув по нему или нажав клавишу Tab.
    • или щелкните по значку Именованные диапазоны Значок Именованные диапазоны на вкладке Главная верхней панели инструментов, выберите из меню опцию Вставить имя, выберите нужное имя в окне Вставка имени и нажмите кнопку OK:

      Окно Вставка имени

Примечание: в окне Вставка имени отображены определенные имена и имена таблиц, областью действия которых является текущий лист и вся книга.

Вернуться на предыдущую страницу
Try now for free Try and make your decision No need to install anything
to see all the features in action