跳到主要内容

使用 AI 进行趋势预测

ONLYOFFICE 电子表格编辑器允许您使用 AI 助手根据历史数据预测未来趋势。通过将 AI 功能与内置预测函数相结合,您可以生成预测、识别季节性模式,并为业务规划、财务预测和其他分析任务做出基于数据的预估。

备注

默认情况下,出于安全原因,AI 未连接到编辑器。要使用 AI 进行趋势预测,您需要先安装并配置 AI 插件。请参阅 AI 助手:设置和配置指南获取详细说明。

访问 AI 功能​

要在电子表格编辑器中打开 AI 提示框,请使用以下方法之一:

  • 转到顶部工具栏的 AI 工具 选项卡,然后选择 AI 聊天。
  • 右键点击所选数据,然后在上下文菜单中选择 AI 工具 → AI 聊天。
  • 按 Ctrl+/(macOS 上为 ⌘+/)。

使用 AI 进行趋势预测​

分析历史数据中的模式​

在进行预测之前,使用 AI 了解历史数据中的模式:

  1. 选择包含历史数据的单元格区域(例如,日期及对应的值)。
  2. 打开 AI 提示框。
  3. 让 AI 以预测为目的分析数据。例如:
    • “分析这些历史数据并识别任何趋势或模式”
    • “这些数据适合线性预测,还是呈现季节性?”
    • “在进行预测之前,我应该考虑哪些模式?”
    • “描述这些数据的增长率以及任何周期性模式”

获取 AI 对预测方法的建议​

AI 可以帮助您选择合适的预测方法:

  1. 选择您的历史数据。
  2. 打开 AI 提示框。
  3. 请求预测方法建议:
    • “我应该对这些数据使用哪个预测函数?”
    • “对于此次预测,我应该使用线性回归还是指数平滑?”
    • “考虑到这些数据的季节性模式,预测它们的最佳方式是什么?”

使用 AI 生成预测洞察​

使用 AI 解读您的预测结果并提供背景说明:

  1. 使用预测函数计算预测值后,同时选择历史数据和预测值。
  2. 打开 AI 提示框。
  3. 让 AI 解读结果:
    • “解读这些预测结果,并说明它们对规划意味着什么”
    • “这些预测的置信水平是多少?”
    • “哪些因素可能导致实际结果与这些预测不同?”
    • “用业务语言总结这些预测”

内置预测函数​

电子表格编辑器提供了多个用于趋势预测的统计函数。使用 AI 帮助您为数据选择并配置合适的函数。

  • FORECAST.LINEAR — 适用于具有一致线性趋势的数据(稳定增长或下降,无季节性模式)。
  • FORECAST.ETS — 适用于同时具有趋势和季节性模式的数据。此函数使用指数平滑(ETS 算法)。
  • FORECAST.ETS.SEASONALITY — 用于在应用预测之前检测数据中的季节性模式长度。
  • FORECAST.ETS.CONFINT — 用于计算预测的置信区间,为您提供可能值的范围。
  • TREND — 用于一次性沿线性趋势线计算多个预测值(数组公式)。

使用趋势线可视化预测​

您可以通过向图表添加趋势线来可视化预测:

  1. 根据历史数据创建图表(转到 插入 选项卡 → 图表)。
  2. 选择图表并访问图表设置。
  3. 添加趋势线以可视化趋势方向。
  4. 启用 在图表上显示方程式 以查看趋势公式。

趋势线可帮助您直观地验证预测函数的结果与整体数据模式是否一致。

有关创建图表的更多信息,请参阅插入图表。

限制和注意事项​

使用 AI 和预测函数进行趋势预测时,请注意以下几点:

  • 历史模式可能不会延续:预测假设过去的模式会持续。重大的市场变化、新的竞争对手或经济变动不会被考虑在内。
  • AI 解读与计算:AI 提供洞察和建议,但不执行数学预测。请使用内置函数进行精确计算。
  • 数据质量很重要:缺失数据、错误或记录周期不一致会显著影响预测的准确性。
  • 置信度随时间降低:预测的未来越远,预测结果就越不可靠。
  • 外部因素:AI 和数学函数都无法考虑未知的未来事件。请始终运用业务判断。
警告

预测使用内置统计函数处理,并由您选择的 AI 服务解读。ONLYOFFICE 对基于预测值做出的业务决策不承担任何责任。请务必结合业务知识验证预测,并考虑多种情景。