设置 AI 工具
概述
ONLYOFFICE AI Tools 插件将 AI 集成到 ONLYOFFICE 桌面编辑器中。安装并配置该插件后,左侧导航面板中将出现两个选项卡:AI 聊天(上下文助手)和 AI 工具(用于常见文件操作的一组现成工具)。
借助 AI,您可以:
- 生成和重写文本。无需在应用之间切换,即可从头创建内容或改进现有文本。只需用自然语言描述您的需求,即可生成摘要、扩展思路、改写句子或调整语气和风格。
- 更智能地设置文档格式。无需在菜单中查找即可应用格式。您不需要寻找某个按钮或功能的位置——输入您的请求,编辑器就会更新内容。
- 分析和可视化数据。在电子表格中汇总、排序和筛选信息,并根据所选区域或整个工作表生成可视化图表。根据简单的描述为您的幻灯片创建数据驱动的图表和图像。
本文介绍如何安装该插件并配置 AI。要了解如何使用它,请参阅使用 AI 聊天和使用 AI 工具文章。
安装插件
ONLYOFFICE 桌面编辑器分为两个版本:基于 AGPL v.3 的 社区 版和 企业 版。在企业版中,ONLYOFFICE AI Tools 插件随应用程序一同提供,安装后即可使用。
在 社区 版中,安装包不包含该插件。首次启动应用程序时,点击左侧导航面板中的 AI 聊天 或 AI 工具 按钮,或点击文档中 AI 工具 选项卡上的任意图标,将打开一个窗口,您可以:
- 点击 接受并安装 以接受许可协议并安装插件,或点击 稍后再说 关闭窗口,并在下次启动应用程序时再次收到提示,
- 点击 不再显示 ONLYOFFICE AI Tools 关闭窗口并不再显示。启用 AI 功能 选项将被关闭,AI 聊天 和 AI 工具 选项卡将被隐藏。

下载开始,完成后将显示 安装成功 消息。需要重新启动应用程序才能使用该插件:点击 立即重启 立即重启,或点击 稍后再说(我稍后自行重启)以便之后自行重启。

启用 AI 功能
只有在 启用 AI 功能 选项打开时,才会显示 AI 聊天 和 AI 工具 选项卡以及 设置 选项卡中的 AI 部分。要更改此设置,请转到左侧导航面板中的 设置 选项卡,打开或关闭 启用 AI 功能 选项,然后点击 应用。
如果您使用 不再显示 ONLYOFFICE AI Tools 选项关闭了安装窗口,之后又改变了主意,请打开 启用 AI 功能 选项。AI 聊天 和 AI 工具 选项卡将重新显示,您可以安装该插件。
安装插件后,ONLYOFFICE AI Tools 区块显示在 常规 部分的底部。使用 卸载 按钮可删除该插件。

安装插件并启用 AI 功能后,设置 选项卡将显示下文介绍的 AI 模型、模型分配、MCP 服务器 和 网页搜索 部分。
AI 模型
使用 AI 模型 部分连接您自己的 AI 来源,可以通过提供商的 API 密钥连接,也可以连接本地托管的模型,以完全掌控数据隐私。
- 点击 添加模型 按钮。连接新的 AI 模型 表单将打开。
- 从 提供商 下拉列表中选择一个提供商。目前可用的 AI 提供商有 OpenAI、Google AI、Anthropic、xAI、Stability AI、DeepSeek、Mistral、TogetherAI、Groq、OpenRouter、Ollama、LM Studio、Zhipu、GPT4All 和 OpenAI Compatible。
- 输入从您的提供商账户获得的 API 密钥。
- 在 基础 URL 字段中,保留默认端点,或指定您的提供商所要求的端点。
- 从 模型 下拉列表中选择所需的模型。
- 输入 配置文件名称,以便在列表中识别此模型。
- 点击 添加模型 按钮完成设置,或点击 取消 放弃更改。

模型将显示在列表中,其中包含配置文件名称、模型和提供商。点击模型右侧的 ... 图标,可 编辑 其设置或 删除 该模型。

要连接 提供商 列表中没有的提供商,请将其添加为自定义提供商。点击 AI 模型 部分中的 自定义提供商 按钮,打开您已添加的提供商列表,然后点击 添加。您也可以点击 连接新的 AI 模型 表单中的 导入自定义提供商 链接。
在这两种情况下,都需要以 JS 格式输入 AI 模型 API 的配置,提供模型名称、端点 URL 和标头。使用 下载模板 链接获取 custom-provider-template.js 文件作为起点。
要删除自定义提供商,请在 自定义提供商 列表中选择它并点击 删除。点击 关闭 关闭窗口。

模型分配
使用 模型分配 部分将 AI 模型分配给不同的任务,并自定义性能和成本。从 默认模型 下拉列表中选择默认使用的模型。
在 按任务自定义模型 下,您可以为特定任务使用不同于默认模型的模型。提供以下任务:
- AI 聊天
- 代码
- 摘要
- 翻译
- 文本分析
- 图像生成
- OCR
- 视觉
- 表单分析
为某项任务保持选中 默认模型,即可对其使用默认模型。

MCP 服务器
使用 MCP 服务器 部分设置 MCP 服务器,并启用其工具以便在 AI 聊天中使用。MCP 工具将 AI 的能力扩展到您的本地环境之外。
ONLYOFFICE 对任何第三方 MCP 服务的内容、隐私政策或做法不承担任何责任。
添加服务器
桌面编辑器中默认未设置任何 MCP 服务器——请自行添加所需的服务器。例如,添加 ONLYOFFICE Apps MCP 服务器,将桌面编辑器连接到您的 Apps 账户,这样 AI 聊天就可以处理存储在其中的文件、文件夹和房间。
如果尚未设置任何服务器,该部分会显示 编辑配置 框。输入从 MCP 服务器提供商处获得的 JSON 配置,然后点击 保存。点击 取消 放弃更改。
有关 ONLYOFFICE Apps 的配置,请参阅 ONLYOFFICE Apps MCP 服务器文档。任何其他遵循协议规范的 MCP 兼容服务器都以相同方式添加。

管理工具权限
添加服务器后,该部分会显示 编辑配置 按钮和 权限 列表。点击 编辑配置 可更改 JSON 配置。
权限 列表按服务器对可用工具进行分组,并显示配置中指定的服务器名称,例如 onlyoffice-docspace。点击服务器名称可展开或折叠其工具列表。默认情况下,所有工具均被允许。使用工具旁边的开关可允许或禁止该工具,使用服务器名称旁边的开关可一次性允许或禁止其所有工具。

其中一些工具会更改或删除您的数据。请禁止您不希望 AI 聊天使用的工具。
网页搜索
使用 网页搜索 部分关联网络搜索引擎,使 AI 聊天可以访问来自互联网的实时信息。
- 使用 网络搜索引擎 下拉列表选择搜索引擎。目前 Exa 是唯一可用的搜索引擎。
- 点击 获取 API 密钥 链接,或前往 Exa 网站,获取 API 密钥。
- 将密钥粘贴到 API 密钥 字段中。
