在文档中启用 AI
在文档中启用 AI
ONLYOFFICE 允许您连接 AI 模型并直接在编辑器中使用。AI 工具 选项卡提供所有 AI 功能的入口,您可以根据各个模型的能力,将特定任务分配给不同的模型。
AI 工具已内置于编辑器中,因此无需安装任何插件。但出于安全原因,默认情况下不会连接任何 AI 模型。要开始使用 AI 功能,请按照下文所述连接您选择的模型。
如果顶部工具栏中未显示 AI 工具 选项卡,请转到 插件 选项卡,点击 后台插件,并确保 AI 工具 开关已打开。
步骤 1. 连接 AI 模型
您可以使用 API 密钥连接 AI 提供商的模型,或连接本地托管的模型。有两个位置可以执行此操作:AI 设置 窗口和 AI 聊天 面板。
通过 AI 设置窗口
- 转到 AI 工具 选项卡并点击 设置。AI 设置 窗口将在 AI 模型 选项卡上打开。
- 点击 添加模型。
- 选择一个 提供商 并输入您的 API 密钥。
- 再次点击 添加模型 以保存该模型。
通过 AI 聊天面板
- 转到 AI 工具 选项卡并点击 AI 聊天。AI 聊天 面板将在右侧打开。
- 如果尚未连接任何模型,面板将提示您连接一个模型。选择一个 提供商 并输入您的 API 密钥。
- 点击 添加模型。
在这两种情况下,您只需填写两个字段:提供商 和 API 密钥。其他字段会自动填写。
- 提供商 — 从列表中选择一个 AI 提供商。要使用列表中没有的提供商,请点击 导入自定义提供商。
- API 密钥 — 输入您从提供商处获得的 API 密钥。如果没有,请点击 获取 API 密钥 链接,打开所选提供商的密钥创建页面。
- 基础 URL — 选择提供商时自动填写。仅当您使用自定义提供商或本地托管的模型时才需要更改。
- 模型 — 在输入有效的 API 密钥之前,此列表不可用。密钥被接受后,会自动选择一个模型。您可以从列表中选择其他模型。
- 配置文件名称 — 自动填写。您可以将其替换为任何您喜欢的名称。
如果 API 密钥无效,API 密钥 字段下方将显示错误消息,且 添加模型 按钮保持不可用。请检查密钥并重新输入。
步骤 2. 将模型分配给任务
连接模型后,将其分配给任务:
- 转到 AI 工具 选项卡并点击 设置。
- 切换到 模型分配 选项卡。
- 为每个任务选择一个模型。如果您连接了多个模型,可以为每个任务使用不同的模型。
并非所有模型都支持所有任务。如果将模型分配给其不支持的任务,可能会出现错误。
AI 设置 窗口中还有 MCP 服务器 和 网页搜索 选项卡,您可以在其中连接 MCP 服务器,并为 AI 助手设置网页搜索。
步骤 3. 使用 AI
现在,您可以通过选择 AI 工具 选项卡上的相应选项来使用 AI 功能:
- AI 聊天 — 询问有关文档的问题、生成新文本或改进现有内容。
- 创建快速 AI 操作 — 使用自定义提示词创建您自己的操作,并将其添加到工具栏。
- 摘要 — 总结较长的文本段落。
- 翻译 — 将所选文本翻译成您选择的语言。
- 创建 AI 助手 — 为您自己的任务设置一个助手。
- 显示所有结果 — 查看 AI 生成的结果。
- 拼写与语法检查 — 检查您的文本并查看建议的更正。
有关可用 AI 功能的更多详细信息,请参阅 AI 用户指南部分。
在使用宏时使用 AI
代码由您选择的 AI 服务处理。可能会发生数据泄露或代码被意外修改的情况。对于可能包含错误或遗漏的生成结果,以及任何骚扰性和不当内容,ONLYOFFICE 概不负责。生成结果中包含的信息由用户选择的 AI 服务生成,并按“现状”提供,ONLYOFFICE 不会对其进行额外过滤。
AI 可以帮助您创建和转换宏。要访问这些功能:
-
转到 视图 选项卡,点击顶部工具栏上的 宏 按钮。宏 窗口将会打开。
-
点击窗口左上角的 AI 按钮,然后选择其中一个选项:
- 根据描述创建 — 描述宏应执行的操作,您的 AI 助手将生成该宏。
- 从 VBA 转换 — 将您的 VBA 代码粘贴到 从 VBA 转换宏 窗口中,它将被转换为宏。
要了解有关宏的更多信息,请参阅我们的 API 文档。