Draw.io: создание диаграмм
ONLYOFFICE Apps предоставляет плагин draw.io, который позволяет создавать и настраивать диаграммы, блок-схемы, интеллект-карты, бизнес-макеты, диаграммы связей между сущностями, программные блоки и многое другое.
Настройка draw.io
В ONLYOFFICE Apps системные плагины могут включать владелец и администраторы. После включения плагины доступны всем пользователям.
- Перейдите в раздел Настройки -> Интеграция -> Плагины.
- Нажмите на переключатель рядом с плагином draw.io, чтобы активировать его.
Чтобы начать работу с плагином, менять настройки по умолчанию не нужно, но вы можете изменить некоторые параметры плагина:
- Перейдите в раздел Настройки -> Интеграция -> Плагины.
- Нажмите на значок шестеренки рядом с плагином draw.io.
- Вы можете изменить следующие параметры плагина:
- Language — выберите нужный язык из списка. Вариант Auto соответствует языку рабочего пространства.
- Offline mode — когда этот параметр активен, все удаленные операции и функции отключаются в целях безопасности.
- Libraries — включите переключатель, чтобы иметь возможность загружать пользовательские библиотеки фигур (File -> New Library / Open Library from в меню draw.io).
- Нажмите Сохранить, чтобы применить настройки.

Использование draw.io
Создание новой диаграммы
- Плагин доступен через кнопку Новое -> Еще в разделе Файлы или в выбранной комнате.
- При нажатии на значок draw.io появляется всплывающее окно, в котором можно изменить или ввести имя файла.
- Новый файл
.drawioпоявляется в списке файлов.

Чтобы открыть созданную диаграмму, нажмите на имя файла либо воспользуйтесь контекстным меню файла -> Больше опций -> Open diagram. Файл откроется в той же вкладке. Чтобы вернуться к списку файлов, откройте меню File и нажмите Save & Exit или Exit.
Если диаграмма открыта пользователем с правами на просмотр, доступен только пункт меню Exit. Любые изменения, внесенные этим пользователем, не будут сохранены.
Редактирование экспортированной диаграммы
Диаграммы draw.io можно экспортировать как изображения (File -> Export as -> PNG, JPEG, WEBP, SVG в меню draw.io) и скачивать на компьютер. Такие изображения можно загружать в рабочее пространство, повторно открывать и редактировать с помощью плагина.
