Перейти к основному содержимому

Проверка данных

Редактор таблиц ONLYOFFICE предоставляет функцию Проверка данных, которая позволяет настраивать параметры данных, вводимых пользователями в ячейки.

Чтобы получить доступ к функции проверки данных, выберите ячейку, диапазон ячеек или всю электронную таблицу, к которой вы хотите применить эту функцию, перейдите на вкладку Данные и нажмите значок Проверка данных на верхней панели инструментов. Открывшееся окно Проверка данных содержит три вкладки: Настройки, Подсказка по вводу и Сообщение об ошибке.

Настройки​

На вкладке Настройки вы можете указать тип данных, которые можно вводить:

примечание

Установите флажок Распространить изменения на все другие ячейки с тем же условием, чтобы использовать те же настройки для выбранного диапазона ячеек или всего листа.

Проверка данных — окно настроек

  • выберите нужный вариант в выпадающем списке Разрешить:

    • Любое значение: без ограничений по типу данных.

    • Целое число: разрешены только целые числа.

    • Десятичное число: разрешены только числа с десятичной запятой.

    • Список: разрешены только варианты из созданного вами выпадающего списка. Снимите флажок Показывать раскрывающийся список в ячейке, чтобы скрыть стрелку раскрывающегося списка.

      Список — настройки

    • Дата: разрешены только ячейки с форматом даты.

    • Время: разрешены только ячейки с форматом времени.

    • Длина текста: устанавливает лимит символов.

    • Другое: устанавливает нужный параметр проверки, заданный в виде формулы.

    примечание

    Установите флажок Распространить изменения на все другие ячейки с тем же условием, чтобы использовать те же настройки для выбранного диапазона ячеек или всего листа.

  • укажите условие проверки в выпадающем списке Данные:

    • между: данные в ячейках должны быть в пределах диапазона, установленного правилом проверки.
    • не между: данные в ячейках не должны находиться в пределах диапазона, установленного правилом проверки.
    • равно: данные в ячейках должны быть равны значению, установленному правилом проверки.
    • не равно: данные в ячейках не должны быть равны значению, установленному правилом проверки.
    • больше: данные в ячейках должны превышать значения, установленные правилом проверки.
    • меньше: данные в ячейках должны быть меньше значений, установленных правилом проверки.
    • больше или равно: данные в ячейках должны быть больше или равны значению, установленному правилом проверки.
    • меньше или равно: данные в ячейках должны быть меньше или равны значению, установленному правилом проверки.
  • создайте правило проверки в зависимости от разрешенного типа данных:

    Условие проверкиПравило проверкиОписаниеДоступно
    Между / не междуМинимум / МаксимумУстанавливает диапазон значенийЦелое число / Десятичное число / Длина текста
    Между / не междуДата начала / Дата окончанияУстанавливает диапазон датДата
    Между / не междуВремя начала / Время окончанияУстанавливает временной диапазонВремя
    Равно / не равноСравнить сУстанавливает значение для сравненияЦелое число / Десятичное число
    Равно / не равноДатаУстанавливает дату для сравненияДата
    Равно / не равноПрошло времениУстанавливает время для сравненияВремя
    Равно / не равноДлинаУстанавливает значение длины текста для сравненияДлина текста
    Больше / больше или равноМинимумУстанавливает нижний пределЦелое число / Десятичное число / Длина текста
    Больше / больше или равноДата началаУстанавливает дату началаДата
    Больше / больше или равноВремя началаУстанавливает время началаВремя
    Меньше / меньше или равноМаксимумУстанавливает верхний пределЦелое число / Десятичное число / Длина текста
    Меньше / меньше или равноДата окончанияУстанавливает дату окончанияДата
    Меньше / меньше или равноВремя окончанияУстанавливает время окончанияВремя

    А также:

    • Источник: укажите источник данных для типа данных Список.
    • Формула: введите требуемую формулу, чтобы создать настраиваемое правило проверки для типа данных Другое.

Подсказка по вводу​

Вкладка Подсказка по вводу позволяет создать настраиваемое сообщение, которое отображается при наведении указателя мыши на ячейку.

Проверка данных — настройки подсказки по вводу

  • Укажите Заголовок и текст Подсказки по вводу.
  • Снимите флажок Отображать подсказку, если ячейка является текущей, чтобы отключить отображение сообщения. Оставьте его, чтобы сообщение отображалось.

Подсказка по вводу — пример

Сообщение об ошибке​

Вкладка Сообщение об ошибке позволяет указать сообщение, которое отображается, когда введенные пользователями данные не соответствуют правилам проверки.

Проверка данных — настройки сообщения об ошибке

  • Стиль: выберите одну из доступных предустановок: Стоп, Предупреждение или Сообщение.
  • Заголовок: укажите заголовок сообщения об ошибке.
  • Сообщение об ошибке: введите текст сообщения об ошибке.
  • Снимите флажок Выводить сообщение об ошибке, чтобы отключить отображение сообщения об ошибке.

Сообщение об ошибке — пример