Como inserir e editar gráficos no ONLYOFFICE Presentation Editor
Inserir um gráfico
Para inserir um gráfico no Presentation Editor:
-
Coloque o cursor onde deseja adicionar um gráfico.
-
Vá para a aba Inserir na barra de ferramentas superior.
-
Clique no ícone
Gráfico na barra de ferramentas superior.
-
Selecione o tipo de gráfico necessário entre os disponíveis:
Gráficos de Coluna
- Coluna agrupada
- Coluna empilhada
- Coluna 100% empilhada
- Coluna 3-D agrupada
- Coluna 3-D empilhada
- Coluna 3-D 100% empilhada
- Coluna 3-D
Gráficos de Linha
- Linha
- Linha empilhada
- Linha 100% empilhada
- Linha com marcadores
- Linha empilhada com marcadores
- Linha 100% empilhada com marcadores
- Linha 3-D
Gráficos de Pizza
- Pizza
- Rosca
- Pizza 3-D
Gráficos de Barra
- Barra agrupada
- Barra empilhada
- Barra 100% empilhada
- Barra 3-D agrupada
- Barra 3-D empilhada
- Barra 3-D 100% empilhada
Gráficos de Área
- Área
- Área empilhada
- Área 100% empilhada
Gráficos de Ações
Gráficos de Dispersão (XY)
- Dispersão
- Dispersão com linhas suaves e marcadores
- Dispersão com linhas suaves
- Dispersão com linhas retas e marcadores
- Dispersão com linhas retas
Gráficos de Radar
- Radar
- Radar com marcadores
- Radar preenchido
Gráficos Combinados
- Coluna agrupada - linha
- Coluna agrupada - linha no eixo secundário
- Área empilhada - coluna agrupada
- Combinação personalizada
observaçãoO Presentation Editor do ONLYOFFICE suporta os seguintes tipos de gráficos criados com editores de terceiros: Pirâmide, Barra (Pirâmide), Cilindros Horizontais/Verticais, Cones Horizontais/Verticais. Você pode abrir o arquivo contendo tal gráfico e modificá-lo usando as ferramentas de edição de gráficos disponíveis. Os seguintes tipos são suportados apenas para abertura: Histograma, Cascata, Funil, Explosão.
Também é possível inserir dados de gráfico do Spreadsheet Editor. Quando você colar os dados copiados, clique no botão de opções de colagem Ctrl no canto inferior direito do gráfico inserido:
- Manter formatação de origem e Vincular dados (F) - a formatação original é preservada e os dados são vinculados ao arquivo de origem.
- Manter formatação de origem e Incorporar pasta de trabalho (K) - a formatação original é preservada e o gráfico é incorporado ao arquivo atual.
-
Após isso, a janela do Editor de gráfico aparecerá onde você pode inserir os dados necessários nas células usando os seguintes controles:
e
para copiar e colar os dados copiados
e
para desfazer e refazer ações
para inserir uma função
e
para diminuir e aumentar casas decimais
para alterar o formato do número, ou seja, a forma como os números que você insere aparecem nas células
-
Clique no botão Selecionar dados situado na janela do Editor de gráfico. A janela de Dados do Gráfico será aberta.
-
Use o diálogo de Dados do Gráfico para gerenciar Intervalo de dados do gráfico, Entradas de legenda (séries), Rótulos do eixo horizontal (categoria) e Alternar linha/coluna.
-
Intervalo de dados do gráfico - selecione os dados para o seu gráfico.
-
Clique no ícone
à direita da caixa de Intervalo de dados do gráfico para selecionar o intervalo de dados.
-
-
Entradas de legenda (séries) - adicione, edite ou remova entradas de legenda. Digite ou selecione um nome de série para as entradas de legenda.
-
Em Entradas de legenda (séries), clique no botão Adicionar.
-
Em Editar série, digite uma nova entrada de legenda ou clique no ícone
à direita da caixa Selecionar nome.
-
-
Rótulos do eixo horizontal (categoria) - altere o texto para os rótulos de categoria.
-
Em Rótulos do eixo horizontal (categoria), clique em Editar.
-
Em Intervalo de rótulos do eixo, digite os rótulos que deseja adicionar ou clique no ícone
à direita da caixa Intervalo de rótulos do eixo para selecionar o intervalo de dados.
-
-
Alternar linha/coluna - reorganize os dados da planilha que estão configurados no gráfico caso não estejam da maneira que você deseja. Altere linhas para colunas para exibir dados em um eixo diferente.
-
-
Clique no botão OK para aplicar as alterações e fechar a janela.
-
-
Clique no botão Tipo de Gráfico na aba Design de gráfico para escolher o tipo e o estilo do gráfico. Selecione um gráfico nas seções disponíveis: Coluna, Linha, Pizza, Barra, Área, Ações, Dispersão (XY), Radar ou Combinado.

Ao escolher Gráficos Combinados, a janela de Tipo de Gráfico lista as séries de gráficos e permite escolher os tipos de gráficos para combinar, bem como selecionar séries de dados para colocar em um eixo secundário.
-
Altere as configurações do gráfico clicando no botão Configurações avançadas na aba Design de gráfico. A janela Gráfico - Configurações avançadas será aberta.
A aba Geral permite alterar o Nome do gráfico.
A aba Layout permite alterar o layout dos elementos do gráfico.
-
Especifique a posição do Título do Gráfico em relação ao seu gráfico selecionando a opção necessária na lista suspensa:
- Nenhum para não exibir título do gráfico,
- Sobreposição para sobrepor e centralizar o título na área do gráfico,
- Sem sobreposição para exibir o título acima da área do gráfico.
-
Especifique a posição da Legenda em relação ao seu gráfico selecionando a opção necessária na lista suspensa:
- Nenhum para não exibir legenda,
- Inferior para exibir a legenda e alinhá-la na parte inferior da área do gráfico,
- Parte superior para exibir a legenda e alinhá-la na parte superior da área do gráfico,
- Direita para exibir a legenda e alinhá-la à direita da área do gráfico,
- Esquerda para exibir a legenda e alinhá-la à esquerda da área do gráfico,
- Sobreposição esquerda para sobrepor e centralizar a legenda à esquerda da área do gráfico,
- Sobreposição direita para sobrepor e centralizar a legenda à direita da área do gráfico.
-
Especifique os parâmetros de Rótulos de dados (ou seja, rótulos de texto que representam valores exatos de pontos de dados):
-
Especifique a posição dos Rótulos de dados em relação aos pontos de dados, selecionando a opção necessária na lista suspensa. As opções disponíveis variam dependendo do tipo de gráfico selecionado.
- Para gráficos de Coluna/Barra, você pode escolher as seguintes opções: Nenhum, Centro, Fundo interno, Parte superior interna, Fora do topo.
- Para gráficos de Linha/XY (Dispersão)/Ações, você pode escolher as seguintes opções: Nenhum, Centro, Esquerda, Direita, Parte superior, Inferior.
- Para gráficos de Pizza, você pode escolher as seguintes opções: Nenhum, Centro, Ajustar largura, Parte superior interna, Fora do topo.
- Para gráficos de Área, bem como para gráficos 3D de Coluna, Linha, Barra, Radar e Combinado, você pode escolher as seguintes opções: Nenhum, Centro.
-
Selecione os dados que deseja incluir em seus rótulos marcando as caixas correspondentes: Nome da série, Nome da categoria, Valor,
-
Insira um caractere (vírgula, ponto e vírgula, etc.) que deseja usar para separar vários rótulos no campo de entrada Separador de rótulos de dados.
-
-
Linhas - é usado para escolher um estilo de linha para gráficos de Linha/XY (Dispersão). Você pode escolher uma das seguintes opções: Reto para usar linhas retas entre os pontos de dados, Suave para usar curvas suaves entre os pontos de dados, ou Nenhum para não exibir linhas.
-
Marcadores - é usado para especificar se os marcadores devem ser exibidos (se a caixa estiver marcada) ou não (se a caixa estiver desmarcada) para gráficos de Linha/XY (Dispersão).
observaçãoAs opções Linhas e Marcadores estão disponíveis apenas para gráficos de Linha e gráficos de XY (Dispersão).
A aba Eixo vertical permite alterar os parâmetros do eixo vertical, também conhecido como eixo dos valores ou eixo y, que exibe valores numéricos. Note que o eixo vertical será o eixo das categorias que exibe rótulos de texto para os gráficos de Barra, portanto, neste caso, as opções da aba Eixo vertical corresponderão às descritas na próxima seção. Para os gráficos de XY (Dispersão), ambos os eixos são eixos de valores.
observaçãoAs seções Configurações do Eixo e Linhas de grade serão desativadas para gráficos de Pizza, pois gráficos deste tipo não possuem eixos e linhas de grade.
-
Selecione Ocultar eixo para ocultar o eixo vertical no gráfico, ou deixe desmarcado para exibir o eixo vertical.
-
Especifique a orientação do Título selecionando a opção necessária na lista suspensa:
- Nenhum para não exibir título no eixo vertical,
- Rotacionado para exibir o título de baixo para cima à esquerda do eixo vertical,
- Horizontal para exibir o título horizontalmente à esquerda do eixo vertical.
-
Linhas de grade são usadas para especificar as linhas de grade verticais a serem exibidas, selecionando a opção necessária na lista suspensa: Nenhum, Maior, Menor ou Maior e Menor.
-
Eixos cruzam - é usado para especificar um ponto no eixo vertical onde o eixo horizontal deve cruzá-lo. A opção Automático é selecionada por padrão, neste caso, o valor do ponto de interseção dos eixos é calculado automaticamente dependendo do intervalo de dados selecionado. Você pode selecionar a opção Valor na lista suspensa e especificar um valor diferente no campo de entrada à direita, ou definir o ponto de interseção dos eixos no Valor mínimo/máximo no eixo vertical.
-
Posição de eixo - é usado para especificar se você deseja que as etiquetas de texto fiquem sobre marcas de escala ou entre marcas de escala.
-
Valores na ordem reversa - é usado para exibir valores na direção oposta. Quando a caixa está desmarcada, o menor valor está na parte inferior e o maior valor está na parte superior do eixo. Quando a caixa está marcada, os valores são ordenados de cima para baixo.
-
A seção Opções de escala permite ajustar a aparência das marcas de escala na escala vertical. As marcas de escala principais são as divisões maiores da escala, que podem ter rótulos exibindo valores numéricos. As marcas de escala secundárias são as subdivisões da escala que são colocadas entre as marcas de escala principais e não têm rótulos. As marcas de escala também definem onde as linhas de grade podem ser exibidas se a opção correspondente estiver definida na aba Layout. As listas suspensas Tipo principal/menor contêm as seguintes opções de posicionamento:
- Nenhum para não exibir marcas de escala principais/secundárias,
- Intersecção para exibir marcas de escala principais/secundárias em ambos os lados do eixo,
- Em para exibir marcas de escala principais/secundárias dentro do eixo,
- Fora para exibir marcas de escala principais/secundárias fora do eixo.
A configuração Intervalo entre Marcas permite definir a distância entre as marcas de escala manualmente.
-
A seção Opções de etiqueta permite ajustar a aparência das etiquetas das marcas de escala principais, que exibem valores. Para especificar uma Posição da etiqueta em relação ao eixo vertical, selecione a opção necessária na lista suspensa:
-
Nenhum para não exibir etiquetas de marcas de escala,
-
Baixo para exibir etiquetas de marcas de escala à esquerda da área do gráfico,
-
Alto para exibir etiquetas de marcas de escala à direita da área do gráfico,
-
Próximo ao eixo para exibir etiquetas de marcas de escala próximas ao eixo.
-
Defina a Distância da etiqueta de eixos e o Intervalo entre Etiquetas para personalizar ainda mais o posicionamento das etiquetas. Para o intervalo, você pode selecionar a opção Automático ou defini-lo manualmente.
-
Para especificar um Formato da etiqueta, clique no botão Formato da etiqueta e escolha uma categoria conforme apropriado.
Categorias de formato de etiqueta disponíveis:
- Geral
- Número
- Científico
- Contabilidade
- Moeda
- Data
- Hora
- Porcentagem
- Fração
- Texto
- Personalizado
As opções de formato de etiqueta variam dependendo da categoria selecionada. Para mais informações sobre como alterar o formato de número, acesse esta página.
-
Marque Ligado à fonte para manter a formatação numérica da fonte de dados no gráfico.
-
A aba Eixo horizontal permite alterar os parâmetros do eixo horizontal, também conhecido como eixo das categorias ou eixo x, que exibe rótulos de texto. Note que o eixo horizontal será o eixo de valores que exibe valores numéricos para os gráficos de Barra, portanto, neste caso, as opções da aba Eixo horizontal corresponderão às descritas na seção anterior. Para os gráficos de XY (Dispersão), ambos os eixos são eixos de valores.
-
Selecione Ocultar eixo para ocultar o eixo horizontal no gráfico, ou deixe desmarcado para exibir o eixo horizontal.
-
Especifique a orientação do Título selecionando a opção necessária na lista suspensa:
- Nenhum quando você não deseja exibir um título no eixo horizontal,
- Sem sobreposição para exibir o título abaixo do eixo horizontal.
-
Linhas de grade são usadas para especificar as linhas de grade horizontais a serem exibidas, selecionando a opção necessária na lista suspensa: Nenhum, Maior, Menor ou Maior e Menor.
-
Valor mínimo - é usado para especificar o menor valor exibido no início do eixo horizontal. A opção Automático é selecionada por padrão, neste caso, o valor mínimo é calculado automaticamente dependendo do intervalo de dados selecionado. Você pode selecionar a opção Fixo na lista suspensa e especificar um valor diferente no campo de entrada à direita.
-
Valor máximo - é usado para especificar o maior valor exibido no final do eixo horizontal. A opção Automático é selecionada por padrão, neste caso, o valor máximo é calculado automaticamente dependendo do intervalo de dados selecionado. Você pode selecionar a opção Fixo na lista suspensa e especificar um valor diferente no campo de entrada à direita.
-
Eixos cruzam - é usado para especificar um ponto no eixo horizontal onde o eixo horizontal deve cruzá-lo. A opção Automático é selecionada por padrão, neste caso, o valor do ponto de interseção dos eixos é calculado automaticamente dependendo do intervalo de dados selecionado. Você pode selecionar a opção Valor na lista suspensa e especificar um valor diferente no campo de entrada à direita, ou definir o ponto de interseção dos eixos no Valor mínimo/máximo (que corresponde à primeira e última categoria) no eixo horizontal.
-
Posição de eixo - é usado para especificar onde as etiquetas de texto do eixo devem ser colocadas: Sobre marcas de escala ou Entre marcas de escala.
-
Valores na ordem reversa - é usado para exibir categorias na direção oposta. Quando a caixa não está marcada, as categorias são exibidas da esquerda para a direita. Quando a caixa está marcada, as categorias são ordenadas da direita para a esquerda.
-
Escala logarítmica - é usada para habilitar a escala logarítmica para a Base que é determinada pelo usuário.
-
A seção Opções de escala permite ajustar a aparência das marcas de escala na escala horizontal. As marcas de escala principais são as divisões maiores que podem ter etiquetas exibindo valores de categoria. As marcas de escala secundárias são as divisões menores que são colocadas entre as marcas de escala principais e não têm etiquetas. As marcas de escala também definem onde as linhas de grade podem ser exibidas se a opção correspondente estiver configurada na aba Layout. Você pode ajustar os seguintes parâmetros de marca de escala:
- Tipo principal/menor - é usado para especificar as seguintes opções de colocação: Nenhum para não exibir marcas de escala principais/secundárias, Intersecção para exibir marcas de escala principais/secundárias em ambos os lados do eixo, Em para exibir marcas de escala principais/secundárias dentro do eixo, Fora para exibir marcas de escala principais/secundárias fora do eixo.
-
A seção Opções de etiqueta permite ajustar a aparência das etiquetas que exibem categorias.
-
Posição da etiqueta - é usada para especificar onde as etiquetas devem ser colocadas em relação ao eixo horizontal. Selecione a opção necessária na lista suspensa: Nenhum para não exibir etiquetas de categoria, Baixo para exibir etiquetas de categoria na parte inferior da área do gráfico, Alto para exibir etiquetas de categoria na parte superior da área do gráfico, Próximo ao eixo para exibir etiquetas de categoria próximas ao eixo.
-
Para especificar um Formato da etiqueta, clique no botão Formato da etiqueta e escolha uma categoria conforme apropriado.
Categorias de formato de etiqueta disponíveis:
- Geral
- Número
- Científico
- Contabilidade
- Moeda
- Data
- Hora
- Porcentagem
- Fração
- Texto
- Personalizado
As opções de formato de etiqueta variam dependendo da categoria selecionada. Para mais informações sobre como alterar o formato de número, acesse esta página.
-
Marque Ligado à fonte para manter a formatação de números da fonte de dados no gráfico.
-
A aba Posicionamento permite ajustar o tamanho e a posição do gráfico.
-
A seção Tamanho contém as configurações dos parâmetros de largura e altura do gráfico. Insira os valores manualmente ou use as setas. Clique no ícone
Proporções constantes para preservar a proporção.
-
A seção Posição contém as seguintes configurações:
- Horizontal - insira o valor do posicionamento horizontal manualmente ou use as setas. Escolha se deseja que ele comece a partir do Canto superior esquerdo ou do Centro.
- Vertical - insira o valor do posicionamento vertical manualmente ou use as setas. Escolha se deseja que ele comece a partir do Canto superior esquerdo ou do Centro.
A aba Texto alternativo permite especificar o Título e a Descrição que serão lidos para pessoas com deficiências visuais ou cognitivas.
Para ajustar quais elementos do gráfico são exibidos, clique no botão
no canto superior direito do gráfico inserido e marque ou desmarque os elementos que você deseja mostrar ou ocultar.
-
-
Depois que o gráfico for adicionado, você também pode alterar seu tamanho e posição.
Você pode especificar a posição do gráfico no slide arrastando-o vertical ou horizontalmente.
Você também pode adicionar um gráfico em um espaço reservado de texto pressionando o ícone Gráfico dentro dele e selecionando o tipo de gráfico necessário:
Também é possível adicionar um gráfico a um layout de slide. Para saber mais, consulte este artigo.
Editar elementos do gráfico
Para editar o Título do gráfico, selecione o texto padrão com o mouse e digite o seu próprio.
Para alterar a formatação da fonte dentro dos elementos de texto, como o título do gráfico, títulos dos eixos, entradas da legenda, rótulos de dados, etc., selecione o elemento de texto necessário clicando com o botão esquerdo do mouse. Em seguida, use os ícones correspondentes na aba Página Inicial da barra de ferramentas superior para alterar o tipo, estilo, tamanho ou cor da fonte.
Quando o gráfico está selecionado, o ícone Configurações da forma também está disponível à direita, já que a forma é usada como fundo para o gráfico. Você pode clicar neste ícone para abrir a aba Configurações da forma na barra lateral direita e ajustar o Preenchimento e a Linha da forma. Note que você não pode alterar o tipo de forma.
Usando a aba Configurações da forma no painel direito, você pode não apenas ajustar a área do gráfico em si, mas também alterar os elementos do gráfico, como área de plotagem, séries de dados, título do gráfico, legenda, etc., e aplicar diferentes tipos de preenchimento a eles. Selecione o elemento do gráfico clicando nele com o botão esquerdo do mouse e escolha o tipo de preenchimento preferido: cor sólida, gradiente, textura, imagem ou padrão. Especifique os parâmetros de preenchimento e defina o nível de Opacidade se necessário. Quando você seleciona um eixo vertical ou horizontal ou linhas de grade, as configurações de traço estão disponíveis apenas na aba Configurações da forma: cor, largura, tipo e opacidade. Para mais detalhes sobre como trabalhar com cores, preenchimentos e linhas de formas, consulte esta página.
A opção Mostrar sombra também está disponível na aba Configurações da forma, mas está desativada para elementos do gráfico.
Se você precisar redimensionar elementos do gráfico, clique com o botão esquerdo para selecionar o elemento necessário e arraste um dos 8 quadrados brancos localizados ao longo do perímetro do elemento.
Para alterar a posição do elemento, clique com o botão esquerdo sobre ele, certifique-se de que o cursor mudou para , mantenha o botão esquerdo do mouse pressionado e arraste o elemento para a posição desejada.
Para excluir um elemento do gráfico, clique com o botão esquerdo para selecioná-lo e pressione a tecla Delete.
Você também pode girar gráficos 3D usando o mouse. Clique com o botão esquerdo na área de plotagem para selecioná-la, em seguida, mantenha o botão do mouse pressionado. Arraste o cursor sem soltar o botão do mouse para alterar a orientação do gráfico 3D.

Ajustar configurações do gráfico
Quando um gráfico é selecionado, a aba Design de gráfico fica disponível na barra de ferramentas superior. Use-a para ajustar a aparência e as configurações do gráfico.
-
Elementos do gráfico - clique para mostrar ou ocultar elementos individuais do gráfico: Título do Gráfico, Rótulos de dados e Legenda.
-
Editar dados - clique para abrir a janela Editor de gráfico e modificar os dados do gráfico.
-
Designs de gráfico - escolha um design na lista de ícones para aplicar um estilo predefinido ao gráfico. Clique na seta para expandir a lista e ver todos os designs disponíveis.
-
Tipo de Gráfico - clique para alterar o tipo e o estilo do gráfico selecionado.
Ao escolher Gráficos Combinados, a janela Tipo de Gráfico lista as séries do gráfico e permite escolher os tipos de gráficos a combinar e selecionar as séries de dados a serem colocadas em um eixo secundário.
-
Configurações avançadas - clique para abrir a janela Gráfico - Configurações avançadas. Veja a descrição detalhada abaixo.
-
Largura e Altura - use estes campos para definir as dimensões do gráfico manualmente.
-
Bloquear proporção da imagem - ative esta opção para preservar as proporções originais do gráfico ao redimensioná-lo.
Quando um tipo de gráfico 3D é selecionado, o botão Rotação 3D também aparece na aba Design de gráfico:
-
Rotação X - defina o valor necessário para a rotação do eixo X usando o teclado ou através das setas Esquerda e Direita à direita.
-
Rotação Y - defina o valor necessário para a rotação do eixo Y usando o teclado ou através das setas Para cima e Para baixo à direita.
-
Perspectiva - defina o valor necessário para a rotação de profundidade usando o teclado ou através das setas Campo de visão estreito e Ampliar o campo de visão à direita.
-
Eixos em ângulo reto - é usado para definir a visualização dos eixos em ângulo reto.
-
Autoescala - marque esta caixa para escalar automaticamente os valores de profundidade e altura do gráfico, ou desmarque esta caixa para definir os valores de profundidade e altura manualmente.
-
Profundidade (% da base) - defina o valor de profundidade necessário usando o teclado ou através das setas.
-
Altura (% da base) - defina o valor de altura necessário usando o teclado ou através das setas.
-
Rotação padrão - redefina os parâmetros 3D para os valores padrão.
observaçãoObserve que você não pode editar cada elemento do gráfico; as configurações serão aplicadas ao gráfico como um todo.
Para abrir rapidamente a janela Editor de gráfico, você também pode clicar duas vezes no gráfico no slide.
Para excluir o gráfico inserido, clique com o botão esquerdo nele e pressione a tecla Delete.
Para aprender como alinhar um gráfico no slide ou organizar vários objetos, consulte a seção Alinhar e organizar objetos em um slide.