Pular para o conteúdo principal

Como inserir e gerenciar controles de conteúdo no ONLYOFFICE

O Document Editor do ONLYOFFICE permite inserir controles de conteúdo clássicos, ou seja, eles são totalmente compatíveis com versões anteriores de processadores de texto de terceiros, como o Microsoft Word.

O Document Editor do ONLYOFFICE suporta os seguintes controles de conteúdo clássicos: Texto Simples, Texto Rico, Imagem, Caixa de Combinação, Lista Suspensa, Data, Caixa de Seleção.

  • Texto Simples é um objeto que contém texto que não pode ser formatado. Os controles de conteúdo de texto simples não podem conter mais de um parágrafo.
  • Texto Rico é um objeto que contém texto que pode ser formatado. Os controles de conteúdo de texto rico podem conter vários parágrafos, listas e objetos (imagens, formas, tabelas etc.).
  • Imagem é um objeto que contém uma única imagem.
  • Caixa de Combinação é um objeto que contém uma lista suspensa com um conjunto de opções. Permite escolher um dos valores predefinidos da lista e editar o valor selecionado, se necessário.
  • Lista Suspensa é um objeto que contém uma lista suspensa com um conjunto de opções. Permite escolher um dos valores predefinidos da lista. O valor selecionado não pode ser editado.
  • Data é um objeto que contém um calendário que permite escolher uma data.
  • Caixa de Seleção é um objeto que permite exibir dois estados: a caixa de seleção está marcada e a caixa de seleção está desmarcada.

Como adicionar controles de conteúdo​

Criar um novo controle de conteúdo de Texto Simples​

  1. posicione o ponto de inserção na linha de texto onde o controle de conteúdo deve ser adicionado,
    ou selecione um trecho de texto para transformá-lo em um controle de conteúdo.
  2. mude para a guia Inserir da barra de ferramentas superior.
  3. clique na seta ao lado do ícone Controles de Conteúdo Controles de Conteúdo.
  4. escolha a opção Texto Simples no menu.

O controle de conteúdo será inserido no ponto de inserção, dentro da linha de texto existente. Substitua o texto padrão dentro do controle de conteúdo ("Seu texto aqui") pelo seu próprio texto: selecione o texto padrão e digite um novo texto ou copie um trecho de texto de qualquer lugar e cole-o no controle de conteúdo. Os controles de conteúdo de texto simples não permitem adicionar quebras de linha e não podem conter outros objetos, como imagens, tabelas etc.

Novo controle de conteúdo de texto simples

Criar um novo controle de conteúdo de Texto Rico​

  1. posicione o ponto de inserção na linha de texto onde o controle de conteúdo deve ser adicionado,
    ou selecione um ou mais parágrafos existentes que você deseja transformar no conteúdo do controle.
  2. mude para a guia Inserir da barra de ferramentas superior.
  3. clique na seta ao lado do ícone Controles de Conteúdo Controles de Conteúdo.
  4. escolha a opção Texto Rico no menu.

O controle será inserido em um novo parágrafo. Substitua o texto padrão dentro do controle ("Seu texto aqui") pelo seu próprio texto: selecione o texto padrão e digite um novo texto ou copie um trecho de texto de qualquer lugar e cole-o no controle de conteúdo. Os controles de conteúdo de texto rico permitem adicionar quebras de linha, ou seja, podem conter vários parágrafos, bem como alguns objetos, como imagens, tabelas, outros controles de conteúdo etc.

Controle de conteúdo de texto rico

Criar um novo controle de conteúdo de Imagem​

  1. posicione o ponto de inserção na linha de texto onde você deseja adicionar o controle.
  2. mude para a guia Inserir da barra de ferramentas superior.
  3. clique na seta ao lado do ícone Controles de Conteúdo Controles de Conteúdo.
  4. escolha a opção Imagem no menu - o controle de conteúdo será inserido no ponto de inserção.
  5. clique no ícone de imagem Imagem no botão acima da borda do controle de conteúdo - uma janela padrão de seleção de arquivos será aberta. Escolha uma imagem armazenada no seu computador e clique em Abrir.

A imagem selecionada será exibida dentro do controle de conteúdo. Para substituir a imagem, clique no ícone de imagem Imagem no botão acima da borda do controle de conteúdo e selecione outra imagem.

Controle de conteúdo de imagem

Criar um novo controle de conteúdo de Caixa de Combinação ou Lista Suspensa​

Os controles de conteúdo Caixa de Combinação e Lista Suspensa contêm uma lista suspensa com um conjunto de opções. Eles podem ser criados quase da mesma maneira. A principal diferença entre eles é que o valor selecionado na lista suspensa não pode ser editado, enquanto o valor selecionado na caixa de combinação pode ser substituído.

  1. posicione o ponto de inserção na linha de texto onde você deseja adicionar o controle.

  2. mude para a guia Inserir da barra de ferramentas superior.

  3. clique na seta ao lado do ícone Controles de Conteúdo Controles de Conteúdo.

  4. escolha a opção Caixa de Combinação ou Lista Suspensa no menu - o controle será inserido no ponto de inserção.

  5. clique com o botão direito no controle adicionado e escolha a opção Configurações do controle de conteúdo no menu de contexto.

  6. na janela Configurações do Controle de Conteúdo aberta, mude para a guia Caixa de Combinação ou Lista Suspensa, dependendo do tipo de controle de conteúdo selecionado.

    Janela de configurações da caixa de combinação

  7. para adicionar um novo item à lista, clique no botão Adicionar e preencha os campos disponíveis na janela aberta:

    Caixa de combinação - adicionar valor

    1. especifique o texto necessário no campo Nome de exibição, por exemplo, Sim, Não, Outro. Esse texto será exibido no controle de conteúdo dentro do documento.
    2. por padrão, o texto do campo Valor corresponde ao texto inserido no campo Nome de exibição. Se você quiser editar o texto do campo Valor, observe que o valor inserido deve ser único para cada item.
    3. clique no botão OK.
  8. você pode editar ou excluir os itens da lista usando os botões Editar ou Excluir à direita, ou alterar a ordem dos itens usando os botões Para cima e Para baixo.

  9. quando todas as opções necessárias estiverem definidas, clique no botão OK para salvar as configurações e fechar a janela.

Novo controle de conteúdo de caixa de combinação

Você pode clicar no botão de seta na parte direita do controle de conteúdo Caixa de Combinação ou Lista Suspensa adicionado para abrir a lista de itens e escolher o item necessário. Depois que o item necessário for selecionado na Caixa de Combinação, você poderá editar o texto exibido, substituindo-o total ou parcialmente pelo seu texto. A Lista Suspensa não permite editar o item selecionado.

Controle de conteúdo de caixa de combinação

Criar um novo controle de conteúdo de Data​

  1. posicione o ponto de inserção no texto onde o controle de conteúdo deve ser adicionado.

  2. mude para a guia Inserir da barra de ferramentas superior.

  3. clique na seta ao lado do ícone Controles de Conteúdo Controles de Conteúdo.

  4. escolha a opção Data no menu - o controle de conteúdo com a data atual será inserido no ponto de inserção.

  5. clique com o botão direito no controle de conteúdo adicionado e escolha a opção Configurações do controle de conteúdo no menu de contexto.

  6. na janela Configurações do Controle de Conteúdo aberta, mude para a guia Formato de data.

    Janela de configurações de data

  7. escolha o Idioma necessário e selecione o formato de data necessário na lista Exibir a data assim.

  8. clique no botão OK para salvar as configurações e fechar a janela.

Controle de conteúdo de data

Você pode clicar no botão de seta na parte direita do controle de conteúdo Data adicionado para abrir o calendário e escolher a data necessária.

Calendário do controle de conteúdo de data

Criar um novo controle de conteúdo de Caixa de Seleção​

  1. posicione o ponto de inserção na linha de texto onde o controle de conteúdo deve ser adicionado.

  2. mude para a guia Inserir da barra de ferramentas superior.

  3. clique na seta ao lado do ícone Controles de Conteúdo Controles de Conteúdo.

  4. escolha a opção Caixa de Seleção no menu - o controle de conteúdo será inserido no ponto de inserção.

  5. clique com o botão direito no controle de conteúdo adicionado e escolha a opção Configurações do controle de conteúdo no menu de contexto.

  6. na janela Configurações do Controle de Conteúdo aberta, mude para a guia Caixa de seleção.

    Janela de configurações da caixa de seleção

  7. clique no botão Símbolo marcado para especificar o símbolo necessário para a caixa de seleção marcada ou em Símbolo desmarcado para selecionar a aparência da caixa de seleção desmarcada. A janela Símbolo será aberta. Para saber mais sobre como trabalhar com símbolos, consulte este artigo.

  8. quando os símbolos estiverem especificados, clique no botão OK para salvar as configurações e fechar a janela.

A caixa de seleção adicionada é exibida no modo desmarcado.

Controle de conteúdo de caixa de seleção

Se você clicar na caixa de seleção adicionada, ela será marcada com o símbolo selecionado na lista Símbolo marcado.

Controle de conteúdo de caixa de seleção marcada

observação

A borda do controle de conteúdo só fica visível quando o controle está selecionado. As bordas não aparecem na versão impressa.

Mover controles de conteúdo​

Os controles de conteúdo podem ser movidos para outro lugar no documento: clique no botão à esquerda da borda do controle para selecioná-lo e arraste-o, sem soltar o botão do mouse, para outra posição no texto.

Mover um controle de conteúdo

Você também pode copiar e colar controles de conteúdo: selecione o controle necessário e use as combinações de teclas Ctrl+C/Ctrl+V.

Editar controles de conteúdo de texto simples e texto rico​

O texto dentro dos controles de conteúdo de texto simples e texto rico pode ser formatado usando os ícones da barra de ferramentas superior: você pode ajustar o tipo, tamanho e cor da fonte, aplicar estilos de decoração e predefinições de formatação. Também é possível usar a janela Parágrafo - Configurações avançadas, acessível pelo menu de contexto ou pela barra lateral direita, para alterar as propriedades do texto. O texto dentro dos controles de conteúdo de texto rico pode ser formatado como um texto comum, ou seja, você pode definir o espaçamento entre linhas, alterar os recuos de parágrafo, ajustar as paradas de tabulação etc.

Alterar as configurações do controle de conteúdo​

Independentemente do tipo de controle de conteúdo selecionado, você pode alterar as configurações do controle de conteúdo nas seções Geral e Bloqueio da janela Configurações do Controle de Conteúdo.

Para abrir as configurações do controle de conteúdo, você pode proceder das seguintes maneiras:

  • Selecione o controle de conteúdo necessário, clique na seta ao lado do ícone Controles de Conteúdo Controles de Conteúdo na barra de ferramentas superior e selecione a opção Configurações do controle no menu.
  • Clique com o botão direito em qualquer lugar dentro do controle de conteúdo e use a opção Configurações do controle de conteúdo no menu de contexto.

Uma nova janela será aberta. Na guia Geral, você pode ajustar as seguintes configurações:

Janela de configurações do controle de conteúdo - Geral

  • Especifique o Título, o Espaço reservado ou a Tag do controle de conteúdo nos campos correspondentes. O título será exibido quando o controle estiver selecionado. O espaço reservado é o texto principal exibido dentro do elemento de controle de conteúdo. As tags são usadas para identificar os controles de conteúdo, para que você possa fazer referência a eles no seu código.
  • Escolha se deseja exibir o controle de conteúdo com uma Caixa de delimitação ou não. Use a opção Nenhum para exibir o controle sem a caixa de delimitação. Se você selecionar a opção Caixa de delimitação, poderá escolher a Cor dessa caixa usando o campo abaixo. Clique no botão Aplicar a todos para aplicar as configurações de Aparência especificadas a todos os controles de conteúdo do documento.
  • Marque a caixa Remover controle de conteúdo quando o conteúdo for editado para remover o controle e manter o seu conteúdo como texto simples ou objeto gráfico quando o conteúdo do controle for editado.

Na guia Bloqueio, você pode proteger o controle de conteúdo contra exclusão ou edição usando as seguintes configurações:

Janela de configurações do controle de conteúdo - Bloqueio

  • O controle de conteúdo não pode ser excluído - marque esta caixa para proteger o controle de conteúdo contra exclusão.
  • O conteúdo não pode ser editado - marque esta caixa para proteger o conteúdo do controle de conteúdo contra edição.

Para determinados tipos de controles de conteúdo, também está disponível a terceira guia, que contém as configurações específicas do tipo de controle de conteúdo selecionado: Caixa de Combinação, Lista Suspensa, Data, Caixa de Seleção. Essas configurações estão descritas acima, nas seções sobre como adicionar os controles de conteúdo correspondentes.

Clique no botão OK na janela de configurações para aplicar as alterações.

Também é possível realçar os controles de conteúdo com uma determinada cor. Para realçar os controles com uma cor:

  1. Clique no botão à esquerda da borda do controle para selecioná-lo,
  2. Clique na seta ao lado do ícone Controles de Conteúdo Controles de Conteúdo na barra de ferramentas superior,
  3. Selecione a opção Configurações de realce no menu,
  4. Escolha a cor necessária nas paletas disponíveis: Cores do tema, Cores padrão ou especifique uma nova Cor personalizada. Para remover o realce de cor aplicado anteriormente, use a opção Sem realce.

As opções de realce selecionadas serão aplicadas a todos os controles de conteúdo do documento.

Como remover controles de conteúdo​

Para remover um controle de conteúdo e manter todo o seu conteúdo, selecione um controle de conteúdo e proceda de uma das seguintes maneiras:

  • Clique na seta ao lado do ícone Controles de Conteúdo Controles de Conteúdo na barra de ferramentas superior e selecione a opção Remover controle de conteúdo no menu.
  • Clique com o botão direito no controle de conteúdo e use a opção Remover controle de conteúdo no menu de contexto.

Para remover um controle e todo o seu conteúdo, selecione o controle necessário e pressione a tecla Delete no teclado.