Como habilitar IA em documentos
Habilitar a IA no Docs
O ONLYOFFICE permite conectar modelos de IA e usá-los diretamente nos editores. A aba Ferramentas de IA dá acesso a todos os recursos de IA, e você pode atribuir tarefas específicas a diferentes modelos, dependendo do que cada um é capaz de fazer.
As ferramentas de IA são integradas aos editores, portanto você não precisa instalar nenhum plugin. No entanto, por razões de segurança, nenhum modelo de IA é conectado por padrão. Para começar a usar os recursos de IA, conecte um modelo de sua escolha, conforme descrito abaixo.
Se a aba Ferramentas de IA não for exibida na barra de ferramentas superior, vá para a aba Plugins, clique em Plugins em segundo plano e verifique se o interruptor Ferramentas de IA está ativado.
Passo 1. Conectar um modelo de IA
Você pode conectar um modelo de um fornecedor de IA usando uma chave de API, ou um modelo hospedado localmente. Há dois lugares onde isso pode ser feito: a janela Configurações de IA e o painel Chat de IA.
Pela janela Configurações de IA
- Vá para a aba Ferramentas de IA e clique em Configurações. A janela Configurações de IA será aberta na aba Modelos de IA.
- Clique em Adicionar modelo.
- Selecione um Fornecedor e insira sua chave de API.
- Clique em Adicionar modelo novamente para salvar o modelo.
Pelo painel Chat de IA
- Vá para a aba Ferramentas de IA e clique em Chat de IA. O painel Chat de IA será aberto à direita.
- Se nenhum modelo estiver conectado ainda, o painel pedirá que você conecte um. Selecione um Fornecedor e insira sua chave de API.
- Clique em Adicionar modelo.
Em ambos os casos, você só precisa preencher dois campos: Fornecedor e Chave de API. Os demais campos são preenchidos automaticamente.
- Fornecedor — selecione um fornecedor de IA na lista. Para usar um fornecedor que não está na lista, clique em Importar fornecedor personalizado.
- Chave de API — insira a chave de API que você recebeu do seu fornecedor. Se você não tiver uma, clique no link Obter chave de API para abrir a página de criação de chaves do fornecedor selecionado.
- URL base — preenchida automaticamente ao selecionar um fornecedor. Altere-a somente se usar um fornecedor personalizado ou um modelo hospedado localmente.
- Modelo — esta lista fica indisponível até que você insira uma chave de API válida. Depois que a chave é aceita, um modelo é selecionado automaticamente. Você pode escolher outro na lista.
- Nome do perfil — preenchido automaticamente. Você pode substituí-lo por qualquer nome que preferir.
Se a chave de API não for válida, uma mensagem de erro aparece abaixo do campo Chave de API e o botão Adicionar modelo permanece indisponível. Verifique a chave e insira-a novamente.
Passo 2. Atribuir modelos a tarefas
Depois que o modelo estiver conectado, atribua-o a tarefas:
- Vá para a aba Ferramentas de IA e clique em Configurações.
- Mude para a aba Atribuição de modelos.
- Selecione um modelo para cada tarefa. Se você conectou vários modelos, pode usar um modelo diferente para cada tarefa.
Nem todos os modelos oferecem suporte a todas as tarefas. Se você atribuir um modelo a uma tarefa que ele não suporta, podem ocorrer erros.
A janela Configurações de IA também tem as abas Servidores MCP e Pesquisa na web, onde você pode conectar servidores MCP e configurar a pesquisa na web para o seu assistente de IA.
Passo 3. Usar a IA
Agora você pode usar os recursos de IA selecionando as opções correspondentes na aba Ferramentas de IA:
- Chat de IA — faça perguntas sobre o seu documento, gere texto novo ou melhore o conteúdo existente.
- Criar ação rápida de IA — crie sua própria ação com um comando personalizado e adicione-a à barra de ferramentas.
- Sumarização — resuma trechos longos de texto.
- Tradução — traduza o texto selecionado para o idioma de sua escolha.
- Criar assistente de IA — configure um assistente para suas próprias tarefas.
- Mostrar todos os resultados — veja os resultados gerados pela IA.
- Gramática e ortografia — verifique seu texto e revise as correções sugeridas.
Para mais detalhes sobre os recursos de IA disponíveis, consulte a seção Guias do usuário de IA.
Usar a IA ao trabalhar com macros
O código é processado por um serviço de IA de sua escolha. Podem ocorrer vazamentos de dados ou modificações inesperadas no código. O ONLYOFFICE não assume responsabilidade por quaisquer respostas geradas que possam conter erros ou omissões, nem por conteúdo ofensivo ou inadequado. As informações contidas nas respostas são geradas por um serviço de IA escolhido pelo usuário e são fornecidas "no estado em que se encontram", sem filtragem adicional do ONLYOFFICE.
A IA pode ajudar você a criar e converter macros. Para acessar esses recursos:
-
Vá para a aba Visualizar e clique no botão Macros na barra de ferramentas superior. A janela Macros será aberta.
-
Clique no botão IA no canto superior esquerdo da janela e selecione uma das opções:
- Criar a partir de descrição — descreva o que a macro deve fazer e o seu assistente de IA a gerará.
- Converter de VBA — cole o seu código VBA na janela Converter macros de VBA e ele será convertido em uma macro.
Para saber mais sobre macros, consulte nossa documentação da API.