オートシェイプの挿入とフォーマット
オートシェイプを挿入する
スプレッドシートエディターで図形を追加するには:
- 上部ツールバーの挿入タブに切り替えます。
- 上部のツールバーの
図形アイコンをクリックします。
- 図形ギャラリーから利用可能なオートシェイプグループのいずれかを選択します:最近使用した図形、基本図形、ブロック矢印、数式図形、フローチャート、星とリボン、吹き出し、ボタン、四角形、線。
- 選択したグループ内で必要なオートシェイプをクリックします。
- 図形を追加する場所にマウスカーソルを置きます。
- 図形を追加したら、サイズと位置や設定を変更できます。右クリックメニューの画像として保存オプションを使用して、図形を画像としてハードドライブに保存できます。
図形をリンクにするには:
- 図形を選択し、Ctrl+Kキーの組み合わせを使用するか、
- 図形を選択し、挿入タブに切り替えてハイパーリンクボタンをクリックするか、
- 図形を選択し、右クリックしてリンクメニューオプションを選択します。
リンクの操作について詳しくは、次の記事を参照してください。
図形に変換する
このオプションは .svg 形式の画像でのみ利用可能です。
画像を図形に変換するには:
- .svg画像をスプレッドシートに挿入するか、既存の画像を選択します。
- 画像を右クリックしてコンテキストメニューを開きます。
- 図形に変換メニューオプションを選択します。
- 図形と同じように画像を編集します。
オートシェイプのスタイル書式をコピーする
特定の図形のスタイル書式をコピーするには、
- コピーしたい書式の図形を、マウスまたはキーボードを使用して選択します。
- 上部のツールバーのホームタブにある
スタイルのコピーアイコンをクリックします(マウスポインターは次のようになります
)。
- 同じ書式を適用する必要のあるオートシェイプを選択します。
図形の設定を調整する
オートシェイプを整列および配置するには、右クリックメニューを使用します。メニューオプションは次のとおりです:
-
切り取り、コピー、貼り付け — 選択したテキスト/オブジェクトを切り取ったりコピーしたりし、現在のカーソル位置に以前に切り取った/コピーしたテキストやオブジェクトを貼り付けるための標準オプションです。
-
配置は、選択した図形を最前面に移動したり、最背面に移動したり、前面または背面に移動したりするほか、図形をグループ化またはグループ解除して複数の図形をまとめて操作するために使用します。オブジェクトの配置について詳しくは、このページを参照してください。
-
整列は、図形を左揃え、中央揃え、右揃え、上揃え、上下中央揃え、または下揃えにするために使用します。オブジェクトの整列について詳しくは、このページを参照してください。
-
回転 — 図形を90度時計回りまたは反時計回りに回転させたり、図形を水平または垂直に反転させたりするために使用されます。
-
マクロの登録は、任意の図形にマクロを割り当てることで、スプレッドシート内のマクロに素早く簡単にアクセスできるようにするために使用します。マクロを割り当てると、図形はボタンコントロールとして表示され、クリックするたびにマクロを実行できます。詳しくは、このガイドの図形にマクロを割り当てるセクションを参照してください。
-
画像として保存 — 図形をハードドライブに画像として保存するために使用されます。
-
ポイントを編集 — 図形の曲線をカスタマイズまたは変更するために使用されます。
-
図形の編集可能なアンカーポイントを有効にするには、図形を右クリックしてメニューから頂点の編集を選択するか、右パネルの図形の編集 → 頂点の編集オプションをクリックします。有効になる黒い四角は2本の線が交わる点で、赤い線は図形の輪郭を示します。クリックしてドラッグすると、点の位置を変更し、図形の輪郭を変更できます。
-
アンカーポイントをクリックすると、両端に白い四角が付いた2本の青い線が表示されます。これらはベジェハンドルで、カーブを作成したりカーブの滑らかさを変更したりできます。
-
アンカーポイントがアクティブである限り、それらを追加および削除することができます。
図形にポイントを追加するには、Ctrlを押しながらアンカーポイントを追加したい位置をクリックします。
ポイントを削除するには、Ctrlを押しながら不要なポイントをクリックします。
-
-
図形の詳細設定 — 「図形 — 詳細設定」ウィンドウを開くために使用されます。
右側のサイドバーの図形設定タブを使用して、一部の図形設定を変更できます。挿入した図形をマウスで選択し、 図形設定アイコンをクリックするとタブが開きます。次の設定を変更できます。
-
塗りつぶし — 図形の塗りつぶしを選択するためのセクションです。以下のオプションを選択できます:
-
塗りつぶし(単色) — このオプションを選択すると、選択した図形の内側を塗りつぶす単色を指定できます。
下の色のボックスをクリックし、利用可能なカラーセットから必要な色を選択するか、好きな色を指定します。
-
テーマの色 — スプレッドシートで選択されている配色に対応する色です。
-
標準の色 — デフォルトのカラーセットです。
-
2つの異なるオプションを使用してユーザー設定の色を適用することもできます。
-
スポイト — このオプションを使用すると、ドキュメント内の色をクリックして必要な色を選択できます。
-
その他の色 — 利用可能なパレットに必要な色がない場合は、このキャプションをクリックします。縦のカラースライダーを動かして必要な色の範囲を選択し、大きな正方形のカラーフィールド内でカラーピッカーをドラッグして特定の色を設定します。カラーピッカーで色を選択すると、対応するRGBおよびsRGBの色の値が右側のフィールドに表示されます。RGBカラーモデルに基づいて、R、G、B(赤、緑、青)フィールドに対応する数値を入力するか、 # 記号の付いたフィールドにsRGB 16進コードを入力して、色を定義することもできます。選択した色は新規プレビューボックスに表示されます。オブジェクトが以前にユーザー設定の色で塗りつぶされていた場合、その色は現在ボックスに表示されるため、元の色と変更後の色を比較できます。色を定義したら、追加ボタンをクリックします。

ユーザー設定の色が選択した要素に適用され、最近使った色パレットに追加されます。
-
-
-
塗りつぶし(グラデーション) — このオプションを使用すると、2色以上の徐々に変化する色で図形を塗りつぶします。グラデーションの塗りつぶしを制約なしにカスタマイズできます。
図形設定アイコンをクリックして、右側のサイドバーで塗りつぶしメニューを開きます。
利用可能なメニューオプション:
-
スタイル — 線形または放射から選択します。
- 線形は、色を左から右、上から下、または選択した任意の角度の一方向に流したい場合に使用します。方向プレビューウィンドウには選択したグラデーションの色が表示されます。矢印をクリックして、プリセットのグラデーションの方向を選択します。正確なグラデーションの角度を指定するには角度設定を使用します。
- 放射は、1つの点から始まり外側に広がるため、中心から移動する場合に使用します。
-
グラデーションの分岐点は、ある色から別の色に切り替わる特定の点です。
グラデーションの分岐点を追加ボタンまたはスライダーバーを使用して、グラデーションの分岐点を追加します。最大10個のグラデーションの分岐点を追加できます。追加した分岐点が現在のグラデーションの見た目に影響を与えることはありません。
グラデーションの分岐点を削除ボタンを使用すると、特定の分岐点を削除できます。
- スライダーバーを使用してグラデーションの分岐点の位置を変更するか、位置をパーセンテージで指定して正確な位置を指定します。
- グラデーションの分岐点に色を適用するには、スライダーバー上の点をクリックし、色をクリックして目的の色を選択します。
-
-
塗りつぶし(図またはテクスチャ) — このオプションを選択すると、画像または定義済みのテクスチャを図形の背景として使用できます。
-
画像を図形の背景として使用する場合は、画像の選択ボタンをクリックし、コンピューターのハードディスクドライブから選択してファイルから、ONLYOFFICEファイルマネージャーを使用してストレージから、または開いたウィンドウに適切なURLアドレスを挿入してURLから画像を追加できます。
-
テクスチャを図形の背景として使用する場合は、テクスチャからメニューを開き、必要なテクスチャのプリセットを選択します。
現在、次のテクスチャを利用できます:キャンバス、ボール紙、濃い色の布地、粒子、花崗岩、グレーの紙、ニット、革、茶色の紙、パピルス、木材。
-
選択した画像が図形より小さい、または大きい場合は、ドロップダウンリストから拡大/縮小または並べて表示の設定を選択できます。
拡大/縮小オプションを使用すると、画像のサイズを図形に合わせて調整し、スペース全体を完全に埋めることができます。
並べて表示オプションを使用すると、大きい画像の一部のみを元のサイズのまま表示したり、小さい画像を元のサイズのまま図形の表面に繰り返し表示したりして、スペース全体を完全に埋めることができます。
注記選択したどのテクスチャのプリセットもスペース全体を完全に埋めますが、必要に応じて拡大/縮小効果を適用できます。
-
-
塗りつぶし(パターン) — このオプションを選択すると、規則的に繰り返される要素で構成された2色のデザインで図形を塗りつぶします。
- パターン — メニューから定義済みのデザインの1つを選択します。
- 前景色 — この色のボックスをクリックして、パターン要素の色を変更します。
- 背景色 — この色のボックスをクリックして、パターンの背景の色を変更します。
-
塗りつぶしなし — 塗りつぶしを使用しない場合はこのオプションを選択します。
-
-
不透明度 — このセクションでは、スライダーをドラッグするか、パーセンテージの値を手動で入力して不透明度レベルを設定します。デフォルト値は 100% で、完全な不透明を意味します。0% の値は完全な透明を意味します。
-
線 — このセクションでは、図形の線の幅、色、または種類を変更します。
- 線の幅を変更するには、サイズドロップダウンリストから利用可能なオプションの1つを選択します。利用可能なオプションは0.5 pt、1 pt、1.5 pt、2.25 pt、3 pt、4.5 pt、6 ptです。線を使用しない場合は、線なしオプションを選択します。
- 線の色を変更するには、下の色のボックスをクリックして必要な色を選択します。
- 線の種類を変更するには、対応するドロップダウンリストから必要なオプションを選択します(デフォルトでは実線が適用されます。利用可能な破線のいずれかに変更できます)。
- 線の不透明度を変更するには、必要な値を手動で入力するか、対応するスライダーバーを使用します。
-
回転は、図形を時計回りまたは反時計回りに90度回転させたり、図形を水平または垂直に反転させたりするために使用します。次のボタンのいずれかをクリックします:
図形を反時計回りに90度回転します。
図形を時計回りに90度回転します。
図形を水平方向(左から右)に反転します。
図形を垂直方向(上下)に反転します。
-
図形の編集 — 図形の頂点を編集したり、現在の図形をドロップダウンリストから選択した別の図形に置き換えたりするためのセクションです。
-
頂点の編集は、図形の曲線をカスタマイズまたは変更するために使用します。
-
アンカーポイントをクリックすると、両端に白い四角が付いた2本の青い線が表示されます。これらはベジェハンドルで、カーブを作成したりカーブの滑らかさを変更したりできます。
-
アンカーポイントがアクティブである限り、追加や削除が可能です。
図形にポイントを追加するには、Ctrlキーを押しながらアンカーポイントを追加したい位置をクリックします。
ポイントを削除するには、Ctrlキーを押しながら不要なポイントをクリックします。
-
-
図形の変更は、現在の図形を置き換えるために使用します。ドロップダウンリストから別の図形を選択します。
-
-
影の調整 — 次のスライダーを使用してカスタムの影を作成します。
- 透明度 — 影の透明度を調整します。
- サイズ — 影のサイズを調整します。
- 角度 — オブジェクトに対する影の角度を調整します。
- 距離 — オブジェクトからの影の距離を調整します。
オートシェイプの詳細設定を調整する
図形の詳細設定を変更するには、右側のサイドバーの詳細設定の表示リンクを使用します。「図形 - 詳細設定」ウィンドウが開きます。
サイズタブには次のパラメータが含まれています:
- 幅と高さ — これらのオプションを使用して、図形の幅や高さを変更します。比例の定数
ボタンをクリックすると(この場合は次のように表示されます
)、元の図形の縦横比を保ったまま、幅と高さが一緒に変更されます。
回転タブには次のパラメータが含まれています:
- 角度 — 正確に指定された角度で図形を回転させるためにこのオプションを使用します。必要な値を度で入力するか、右の矢印を使用して調整します。
- 反転 — 図形を水平(左から右)に反転させるには水平ボックスをチェックし、図形を垂直(上下)に反転させるには垂直ボックスをチェックします。
線のスタイル & 矢印タブには次のパラメーターが含まれています:
-
線のスタイル — このオプショングループでは、次のパラメーターを指定できます。
-
線端の種類 — このオプションでは線の端のスタイルを設定します。そのため、線、折れ線など、開いた輪郭を持つ図形にのみ適用できます。
- フラット — 終端は平らになります。
- ラウンド — 終端は丸くなります。
- スクエア — 終端は四角になります。
-
結合の種類 — このオプションでは2本の線が交差する部分のスタイルを設定します。たとえば、折れ線や、三角形または四角形の輪郭の角に影響します。
- ラウンド — 角は丸くなります。
- ベベル — 角は斜めにカットされます。
- マイター — 角は尖ります。
注記輪郭の幅を大きくすると、効果がより顕著になります。
-
-
矢印 — このオプショングループは、線図形グループの図形を選択している場合に利用できます。ドロップダウンリストから適切なオプションを選択して、矢印の始点のスタイル、終点のスタイル、サイズを設定できます。
テキストボックスタブでは、テキストに合わせて図形を調整、テキストを図形からはみ出して表示するを設定したり、図形の上、下、左、右の内部余白(つまり、図形内のテキストと図形の境界線との間の距離)を変更したりできます。
このタブは、オートシェイプ内にテキストが追加されている場合にのみ利用可能です。それ以外の場合、タブは無効です。
列タブでは、必要な列数(最大16)と列の間隔を指定して、図形内にテキストの列を追加できます。OKをクリックすると、既存のテキストや図形内に入力した他のテキストが列に表示され、1つの列から次の列へと流れていきます。
セルに合わせるタブには、次のパラメーターがあります。
- セルで移動してサイズを変更する — このオプションでは、図形をその背後のセルに固定します。セルが移動した場合(たとえば、行や列を挿入または削除した場合)、図形もセルと一緒に移動します。セルの幅または高さを増減すると、図形のサイズも変更されます。
- 移動するが、セルでサイズを変更しない — このオプションでは、図形をその背後のセルに固定し、図形のサイズが変更されないようにします。セルが移動した場合、図形もセルと一緒に移動しますが、セルのサイズを変更しても、図形の寸法は変わりません。
- セルで移動したりサイズを変更したりしない — このオプションでは、セルの位置やサイズが変更された場合に、図形が移動またはサイズ変更されないようにします。
代替テキストタブでは、視覚または認知に障害のある方に読み上げられるタイトルと説明を指定できます。
図形内のテキストの挿入と書式設定
図形にテキストを挿入するには、図形をマウスで選択してテキストの入力を開始します。テキストは図形の一部になります(図形を移動または回転すると、テキストも一緒に移動または回転します)。
図形内のテキストに適用できるすべての書式設定オプションは、こちらに記載されています。
コネクタを使用して図形を接続する
接続ポイントのある線を使用して図形を接続し、オブジェクト間の依存関係を示すことができます(たとえば、フローチャートを作成する場合)。これを行うには、
-
上部のツールバーの挿入タブにある
図形アイコンをクリックします。
-
メニューから線グループを選択します。
-
選択したグループ内の必要な図形をクリックします(最後の3つの図形、つまり曲線、フリーハンド、フリーフォームはコネクタではないため除きます)。
-
マウスカーソルを最初の図形の上に置き、図形の輪郭上に表示される接続点
のいずれかをクリックします。
-
マウスカーソルを2番目の図形に向かってドラッグし、その輪郭上の必要な接続点をクリックします。
接続された図形を移動しても、コネクタは図形に接続されたままで、図形と一緒に移動します。
コネクタを図形から切り離して、他の接続ポイントに接続することもできます。
図形にマクロを割り当てる
任意の図形にマクロを割り当てることで、スプレッドシート内のマクロに素早く簡単にアクセスできるようになります。マクロを割り当てると、図形はボタンコントロールとして表示され、クリックするたびにマクロを実行できます。
マクロを割り当てるには:
-
マクロを割り当てる図形を右クリックし、ドロップダウンメニューからマクロの登録オプションを選択します。
-
マクロの登録ダイアログが開きます
-
リストからマクロを選択するか、マクロ名を入力して、OKをクリックして確定します。