メインコンテンツまでスキップ

表の挿入

表の挿入​

Document Editorで表を挿入するには、

  1. 表を追加したい場所にカーソルを置きます。

  2. 上部ツールバーの挿入タブに切り替えます。

  3. 上部ツールバーの表 表アイコンをクリックします。

  4. 表を作成するオプションを選択します。

    • あらかじめ設定されたセル数の表(最大10列×8行)

      素早く表を追加したい場合は、行数(最大8行)と列数(最大10列)を選択します。

    • またはカスタム表

      10列×8行を超える表が必要な場合は、カスタム表の挿入オプションを選択します。必要な行数と列数を入力するウィンドウが開きますので、入力後OKボタンをクリックします。

      カスタム表

    • マウスを使って表を描画したい場合は、表を描くオプションを選択します。異なるサイズの行や列を持つ表を作成したい場合に便利です。マウスカーソルが鉛筆鉛筆に変わります。表を追加したい場所に長方形を描き、表の境界内で水平線を描いて行を、垂直線を描いて列を追加します。

    • 既存のテキストを表に変換したい場合は、テキストを表に変換オプションを選択します。この機能は、既にあるテキストを表に整理したい場合に便利です。テキストを表に変換ウィンドウは3つのセクションで構成されています。

      テキストを表に変換

      • 表のサイズ。テキストを分配する列数/行数を選択します。上下の矢印ボタンを使用するか、キーボードで手動入力します。
      • 自動調整の動作。テキストのフィッティング動作を設定するオプションをチェックします。固定列幅(デフォルトでは自動に設定されています。上下の矢印ボタンを使用するか、キーボードで手動入力します)、内容に合わせて自動調整(列幅はテキストの長さに対応します)、ウィンドウに合わせて自動調整(列幅はページ幅に対応します)。
      • テキストを区切る位置。テキストの区切りタイプを設定するオプションをチェックします。段落、タブ、セミコロン、およびその他(希望の区切り文字を手動で入力します)。
      • テキストを表に変換するには、OKをクリックします。
    • OLEオブジェクトとして表を挿入したい場合:

      1. スプレッドシートを挿入オプションを選択します。

      2. 対応するウィンドウが表示されます。必要なデータを入力し、スプレッドシートエディターの書式設定ツールを使用して書式を設定します。例えば、フォント、タイプ、スタイルの選択、数値形式の設定、関数の挿入、表の書式設定などがあります。

        OLE表

      3. ヘッダーにはウィンドウの右上隅に表示領域 表示領域ボタンがあります。表示領域を編集オプションを選択して、オブジェクトがドキュメントに挿入されるときに表示される領域を選択します。他のデータは失われず、非表示になるだけです。準備ができたら完了をクリックします。

      4. 表示領域を表示ボタンをクリックすると、選択した領域が青い枠で表示されます。

      5. 準備ができたら、保存して終了ボタンをクリックします。

  5. 表が追加されたら、そのプロパティ、サイズ、位置を変更できます。

表のサイズを変更するには、表の右下隅にあるサイズ変更ハンドルハンドルにマウスカーソルを合わせ、必要なサイズになるまでドラッグします。

表のサイズ変更

特定の列の幅や行の高さを手動で変更することもできます。列の右境界にマウスカーソルを合わせ、カーソルが双方向矢印列幅の変更に変わったら、境界を左右にドラッグして必要な幅に設定します。1つの行の高さを手動で変更するには、行の下境界にマウスカーソルを合わせ、カーソルが双方向矢印行の高さの変更に変わったら、境界を上下にドラッグします。

表を移動するには、表の左上隅にある移動ハンドルハンドルを押したまま、ドキュメント内の必要な場所にドラッグします。

表にキャプションを追加することも可能です。表のキャプションの操作方法については、この記事を参照してください。

表またはその一部を選択​

表全体を選択するには、表の左上隅にある移動ハンドルハンドルをクリックします。

特定のセルを選択するには、必要なセルの左側にマウスカーソルを移動し、カーソルが黒い矢印セルの選択に変わったら、左クリックします。

特定の行を選択するには、必要な行の隣にある表の左境界にマウスカーソルを移動し、カーソルが水平の黒い矢印行の選択に変わったら、左クリックします。

特定の列を選択するには、必要な列の上境界にマウスカーソルを移動し、カーソルが下向きの黒い矢印列の選択に変わったら、左クリックします。

コンテキストメニューや右サイドバーの行と列セクションからセル、行、列、または表を選択することも可能です。

注記

表内を移動するには、キーボードショートカットを使用できます。

表の設定を調整​

表のプロパティの一部や構造は、右クリックメニューを使用して変更できます。メニューオプションは次の通りです。

  • 切り取り、コピー、貼り付け - 選択したテキスト/オブジェクトを切り取ったりコピーしたりし、以前に切り取った/コピーしたテキストやオブジェクトを現在のカーソル位置に貼り付けるための標準オプションです。

  • 選択は、行、列、セル、または表を選択するために使用します。

  • 挿入は、カーソルが置かれている行の上または下に行を挿入したり、カーソルが置かれている列の左または右に列を挿入したりするために使用します。

    複数の行や列を挿入することも可能です。複数の行/列オプションを選択すると、複数挿入ウィンドウが表示されます。リストから行または列オプションを選択し、追加したい行数/列数を指定し、追加する場所をカーソルの上またはカーソルの下から選択して、OKをクリックします。

  • 削除は、行、列、表、またはセルを削除するために使用します。セルオプションを選択すると、セルの削除ウィンドウが開き、セルを左にシフト、行全体を削除、または列全体を削除のいずれかを選択できます。

  • セルの結合は、2つ以上のセルが選択されている場合に利用可能で、それらを結合するために使用します。

    消しゴムツールを使用してセル間の境界を消去することでもセルを結合できます。これを行うには、上部ツールバーの表 表アイコンをクリックし、表を消去オプションを選択します。マウスカーソルが消しゴム消しゴムに変わります。結合したいセル間の境界にマウスカーソルを移動し、消去します。

  • セルの分割... は、セルを分割する列数と行数を選択するウィンドウを開くために使用します。

    鉛筆ツールを使用して行や列を描画することでもセルを分割できます。これを行うには、上部ツールバーの表 表アイコンをクリックし、表を描くオプションを選択します。マウスカーソルが鉛筆鉛筆に変わります。行を作成するには水平線を、列を作成するには垂直線を描きます。

  • 行を均等に配分は、表全体の高さを変えずに、選択したセルの高さを揃えるために使用します。

  • 列を均等に配分は、表全体の幅を変えずに、選択したセルの幅を揃えるために使用します。

  • セルの垂直方向の配置は、選択したセル内のテキストを上、中央、または下に配置するために使用します。

  • テキストの方向 - セル内のテキストの向きを変更するために使用します。テキストを水平に配置するか、上から下に垂直に配置する(テキストを下に回転)、または下から上に垂直に配置する(テキストを上に回転)ことができます。

  • テーブルの詳細設定は、「テーブル - 詳細設定」ウィンドウを開くために使用します。

  • ハイパーリンクは、ハイパーリンクを挿入するために使用します。

  • 段落の詳細設定は、「段落 - 詳細設定」ウィンドウを開くために使用します。

右サイドバーで表のプロパティを変更することもできます。

右サイドバー - テーブル設定

  • 行と列は、強調表示したい表の部分を選択するために使用します。

    行の場合:

    • ヘッダー - 最初の行を強調表示
    • 合計 - 最後の行を強調表示
    • 縞模様 - 1行おきに強調表示

    列の場合:

    • 最初 - 最初の列を強調表示
    • 最後 - 最後の列を強調表示
    • 縞模様 - 1列おきに強調表示
  • テンプレートから選択は、利用可能なテンプレートから表のテンプレートを選択するために使用します。

  • 罫線スタイルは、罫線のサイズ、色、スタイル、および背景色を選択するために使用します。

  • 行と列は、表に対して選択、削除、行と列の挿入、セルの結合、セルの分割などの操作を行うために使用します。

  • 行と列のサイズは、現在選択されているセルの幅と高さを調整するために使用します。このセクションでは、行を均等に配分して選択したすべてのセルの高さを揃えたり、列を均等に配分して選択したすべてのセルの幅を揃えたりすることもできます。

  • 数式を追加は、選択した表のセルに数式を挿入するために使用します。

  • 各ページの先頭にヘッダー行を繰り返すは、長い表で各ページの先頭に同じヘッダー行を挿入するために使用します。

  • テーブルをテキストに変換は、表をプレーンテキスト形式に変換するために使用します。テーブルをテキストに変換ウィンドウでは、変換の区切り文字タイプを設定します。段落記号、タブ、セミコロン、およびその他(希望の区切り文字を手動で入力します)。表の各セルのテキストは、変換後のテキストの個別の要素として扱われます。

  • 詳細設定を表示は、「テーブル - 詳細設定」ウィンドウを開くために使用します。

表の詳細設定を調整​

表の詳細プロパティを変更するには、表を右クリックして右クリックメニューからテーブルの詳細設定オプションを選択するか、右サイドバーの詳細設定を表示リンクを使用します。テーブルプロパティウィンドウが開きます。

テーブル - 詳細設定

テーブルタブでは、表全体のプロパティを変更できます。

  • テーブルサイズセクションには、次のパラメータが含まれています。
    • 幅 - デフォルトでは、表の幅はページ幅に合わせて自動的に調整されます。つまり、表は左右のページ余白の間のすべてのスペースを占めます。このボックスをチェックして、必要な表の幅を手動で指定できます。

    • 単位で測定では、表の幅を絶対単位(センチメートル/ポイント/インチ。ファイル -> 詳細設定... タブで指定されたオプションによります)、またはページ全体の幅に対するパーセントで指定できます。

      注記

      行の高さと列の幅を変更して、表のサイズを手動で調整することもできます。行/列の境界にマウスカーソルを移動し、双方向矢印に変わったら境界をドラッグします。また、水平ルーラーの列幅マーカーマーカーを使用して列の幅を変更し、垂直ルーラーの行の高さマーカーマーカーを使用して行の高さを変更することもできます。

    • 内容に合わせて自動的にサイズを変更 - 各列の幅をセル内のテキストに応じて自動的に変更できます。

  • デフォルトのセル余白セクションでは、デフォルトで使用されるセル内のテキストとセル境界の間のスペースを変更できます。
  • オプションセクションでは、次のパラメータを変更できます。
    • セル間のスペース - テーブル背景色で塗りつぶされるセル間のスペース。

テーブル - 詳細設定

セルタブでは、個々のセルのプロパティを変更できます。まず、必要なセルを選択するか、すべてのセルのプロパティを変更する場合は表全体を選択する必要があります。

  • セルサイズセクションには、次のパラメータが含まれています。

    • 希望の幅 - 希望するセルの幅を設定できます。これはセルが合わせようとするサイズですが、場合によってはこの値に正確に合わせられないことがあります。例えば、セル内のテキストが指定された幅を超える場合、希望のセル幅を維持するためにテキストは次の行に折り返されますが、新しい列を挿入すると希望の幅は小さくなります。

    • 単位で測定 - セルの幅を絶対単位(センチメートル/ポイント/インチ。ファイル -> 詳細設定... タブで指定されたオプションによります)、または表全体の幅に対するパーセントで指定できます。

      注記

      セルの幅を手動で調整することもできます。列内の1つのセルを列全体の幅より広くまたは狭くするには、必要なセルを選択し、その右境界にマウスカーソルを移動して、双方向矢印に変わったら境界をドラッグします。列内のすべてのセルの幅を変更するには、水平ルーラーの列幅マーカーマーカーを使用して列の幅を変更します。

  • セル余白では、セル内のテキストとセル境界の間のスペースを調整できます。デフォルトでは標準の値が使用されます(これらのデフォルト値はテーブルタブで変更することもできます)が、デフォルトの余白を使用ボックスのチェックを外して、必要な値を手動で入力することもできます。

  • セルオプションセクションでは、次のパラメータを変更できます。

    • テキストを折り返すオプションはデフォルトで有効になっています。セルの幅を超えるテキストを次の行に折り返し、列の幅を変えずに行の高さを広げます。

テーブル - 詳細設定

罫線と背景タブには、次のパラメータが含まれています。

  • 罫線のパラメータ(サイズ、色、表示の有無) - 罫線のサイズを設定し、その色を選択し、セル内での表示方法を選択します。

    注記

    罫線なしボタンをクリックするか、図上ですべての罫線の選択を手動で解除して表の罫線を表示しないようにした場合、罫線はドキュメント内で点線で示されます。完全に非表示にするには、上部ツールバーのホームタブで非印刷文字非印刷文字アイコンをクリックし、隠しテーブル罫線オプションを選択します。

  • セル背景 - セル内の背景色(1つ以上のセルが選択されている場合、またはテーブルタブでセル間のスペースを許可オプションが選択されている場合にのみ利用可能)。

  • テーブル背景 - 表の背景色、またはテーブルタブでセル間のスペースを許可オプションが選択されている場合はセル間のスペースの背景色。

テーブル位置​

テーブル - 詳細設定

テーブル位置タブは、テキストの折り返しタブでフローテーブルオプションが選択されている場合にのみ利用可能で、次のパラメータが含まれています。

  • 水平パラメータには、余白、ページ、またはテキストを基準にした表の配置(左、中央、右)と、余白、ページ、またはテキストの右側の位置が含まれます。
  • 垂直パラメータには、余白、ページ、またはテキストを基準にした表の配置(上、中央、下)と、余白、ページ、またはテキストの下の位置が含まれます。
  • オプションセクションでは、次のパラメータを変更できます。
    • テキストと一緒にオブジェクトを移動は、表がテキストと一緒に移動するようにします。
    • 重なりを許可は、ページ上で2つの表を互いに近づけてドラッグしたときに、1つの大きな表に結合するか、重ねるかを制御します。

テーブル - 詳細設定

テキストの折り返しタブには、次のパラメータが含まれています。

  • テキストの折り返しスタイル - インラインテーブルまたはフローテーブル。必要なオプションを使用して、テキストに対する表の配置方法を変更します。インラインテーブルを選択した場合は表がテキストの一部になり、フローテーブルを選択した場合はテキストが表の周囲を回り込みます。
  • 折り返しスタイルを選択した後、インラインテーブルとフローテーブルの両方に追加の折り返しパラメータを設定できます。
    • インラインテーブルの場合、表の配置と左からのインデントを指定できます。
    • フローテーブルの場合、テキストからの距離と、テーブル位置タブで表の位置を指定できます。

テーブル - 詳細設定

代替テキストタブでは、視覚や認知に障害のある方が表の内容をよりよく理解できるように読み上げられるタイトルと説明を指定できます。

ページ間で行を分割する​

Document Editorで複数ページにまたがる表を扱う場合、個々の表の行をページの境界で分割できるかどうかを設定できます。

この設定を行うには:

  1. 表の内側をクリックするか、調整したい行を選択します。
  2. 右サイドバーでテーブル設定表アイコンをクリックして、表の設定パネルを開きます。
  3. ページ間で行を分割するオプションをオンまたはオフにします。

このオプションが有効の場合、現在のページの下端を超える行はページの境界で分割されます。行の最初の部分は現在のページの下部に残り、残りの内容は次のページの上部に続きます。

このオプションが無効の場合、行は分割されません。代わりに行全体が次のページの上部に移動するため、前のページの下部に余白が残ることがあります。