Passa al contenuto principale

Registro delle modifiche

Versione 10.0.0​

Data di uscita: 10/10/2026

Nuove funzionalità​

Tutti gli editor​

  • Aggiunto il supporto per l'elemento del grafico Tabella dati con la possibilità di aggiungere e configurare parametri testuali e grafici.
  • Aggiornato il design del marketplace dei plugin: aggiunto un pannello a sinistra per passare da una categoria all'altra.
  • Aggiunta la conversione delle immagini SVG in forme.
  • Aggiunto il pulsante Scarica alla barra degli strumenti superiore.

Editor di documenti​

  • Aggiunta la finestra delle impostazioni della linea orizzontale.
  • Implementato il ritaglio del testo per righe in un paragrafo con interlinea esatta.
  • Aggiunto il supporto per il parametro keepNext per le tabelle, nonché per i paragrafi e le tabelle all'interno dei controlli contenuto di blocco.
  • Migliorato il supporto per le equazioni grafiche e altri oggetti in linea nel testo da destra a sinistra (RTL).
  • Implementata un'opzione per le righe della tabella che impedisce di dividere una riga tra le pagine.
  • Aggiunte al menu Incolla speciale le voci per continuare un elenco o ricominciare la numerazione.
  • Implementata la possibilità di passare al cursore di un altro utente e seguirlo durante la co-modifica.

Editor di fogli di calcolo​

  • Aggiunta l'evidenziazione degli intervalli nella barra della formula.
  • Aggiunto il salvataggio nel formato XLS.
  • Velocizzate alcune operazioni memorizzando separatamente stili e dati.
  • Aggiunta un'opzione per attivare e disattivare il completamento automatico dei valori delle celle.
  • Aggiunti suggerimenti per le costanti negli argomenti delle funzioni (la funzione AGGREGATE).
  • Aggiunto un bordo di selezione animato dopo la copia o il taglio.
  • Implementato il supporto per lo sfondo del foglio all'apertura e al salvataggio dei file.
  • Migliorate le prestazioni delle formule di matrice che fanno riferimento a intere colonne o righe (ROW, COLUMN, SEQUENCE, SUM, SUMPRODUCT, ecc.): i calcoli sono più veloci e usano meno memoria.
  • Ampliate le possibilità di lavorare con righe e colonne nascoste, compresa la visualizzazione delle righe e colonne nascoste ai bordi tramite il menu contestuale.

Editor di presentazioni​

  • Ampliate le impostazioni di stampa: aggiunte le modalità di stampa di note, stampati e struttura, nonché la stampa delle diapositive nascoste, dello sfondo e della cornice della diapositiva, dei commenti, dei numeri di diapositiva negli stampati e l'adattamento alle dimensioni della pagina.
  • Aggiunte le modalità di visualizzazione: Struttura, Note, Schema stampati e Schema note.
  • Aggiunta la modalità Visualizzazione lettura.
  • Aggiunti al menu File i pulsanti Animata e Video per esportare una presentazione scegliendo l'intervallo di diapositive, la risoluzione, la durata delle diapositive e il formato.
  • Impostata una durata predefinita distinta per ogni tipo di transizione.

Moduli​

  • Aggiunta la possibilità di salvare una firma nei campi firma e riutilizzarla dall'elenco delle firme salvate.
  • Aggiunta un'opzione per attivare e disattivare il controllo ortografico durante la compilazione di un determinato modulo.

Editor PDF​

  • Implementata la rimozione delle annotazioni nell'area Redazione.
  • Aggiunta la possibilità di rimuovere i metadati da un documento con la funzione Redazione.
  • Aggiunto il pannello delle impostazioni delle annotazioni.
  • Aggiunta la possibilità di inserire una firma in un documento tramite la scheda Commento.
  • Il pannello Commenti ora mostra tutte le annotazioni indicandone il tipo.
  • Aggiunta la possibilità di modificare le azioni dei moduli PDF tramite le Impostazioni avanzate nel pannello delle impostazioni del modulo.
  • Implementate la creazione e la compilazione dei moduli per ruoli, nonché la raccolta dei dati dai moduli compilati.
  • Aggiunto il riconoscimento delle tabelle con bordi visibili nella modalità Modifica testo.
  • Aggiunto il campo firma alla scheda Moduli nella modalità Modifica PDF.
  • Aggiunte le opzioni di visibilità dei campi al pannello destro delle impostazioni del modulo.

Conversione​

  • Aggiunto il supporto per il formato OFD: i file possono essere aperti per la visualizzazione e convertiti in altri formati come avviene per XPS.

Sicurezza​

  • Corretta una vulnerabilità XSS nei collegamenti ipertestuali dei documenti DOCX.
  • Corrette le vulnerabilità CVE-2022-3602 e CVE-2022-3786 di OpenSSL nell'immagine Docker.
  • Corretta la vulnerabilità CVE-2022-23308 durante la conversione dei documenti.
  • Corretto l'aggiramento della sandbox delle macro.
  • Corretta la scrittura errata in memoria durante la conversione da XLS a XLSX.
  • Corretta una vulnerabilità XSS nel campo Nome durante la creazione di un assistente IA.
  • Corretto l'aggiramento dell'autorizzazione durante la stampa di PDF.
  • Corretto l'arresto anomalo del convertitore durante l'elaborazione di catene circolari di ereditarietà degli stili in DOCX.
  • Corretto un overflow del buffer dello stack durante la lettura dei dati OLE nella conversione di documenti in formati legacy.
  • Corretto un overflow del buffer dell'heap durante il rendering delle maschere di immagine in PDF.
  • Corretto l'aggiramento della sandbox delle macro con accesso ai cookie.
  • Corretto l'accesso ai file del sistema operativo tramite il metodo native.GetFileBinary dell'API di Document Builder.
  • Corretta la possibilità di usare un token dell'editor per accedere a Document Builder.
  • Corretta una vulnerabilità SSRF nell'endpoint /ai-proxy.
  • Corretta una lettura fuori dai limiti durante la conversione da DOC a DOCX.
  • Corretta una lettura fuori dai limiti durante l'elaborazione dei metafile PPT, che causava la divulgazione di memoria nel file PPTX risultante.
  • Corretta una lettura fuori dai limiti durante l'analisi della formattazione dei caratteri nei file DOC.
  • Corretta una lettura fuori dai limiti durante l'analisi della piece table nei file DOC.
  • Corretta l'esecuzione di JavaScript incorporato nei documenti PDF.
  • Corretta una vulnerabilità SSRF negli endpoint WOPI.
  • Corretta una doppia liberazione di memoria durante la conversione di alcuni file DOCX.
  • Corretta una lettura fuori dai limiti durante l'analisi della tabella dei caratteri nei file DOC.
  • Corretta una scrittura fuori dai limiti nell'heap causata da un overflow di interi durante la conversione dei documenti.
  • Corretta una vulnerabilità XSS nella finestra degli argomenti delle funzioni nell'Editor di fogli di calcolo.
  • Corretta l'esecuzione di JavaScript dannoso aggiunto alle azioni dei file PDF.
  • Corretta una vulnerabilità di path traversal durante l'elaborazione dei file HML.
  • Corretta la scrittura arbitraria di file durante l'estrazione degli archivi in fase di conversione.
  • Corretta la lettura di file locali durante la conversione EPUB.
  • Corretta la possibilità di creare il file runtime.json tramite una richiesta a Document Builder (CVE-2026-110385).
  • Corretta una vulnerabilità XSS nell'Editor di documenti tramite il nome di un carattere o di uno stile nel pannello Revisione.
  • Corretta una vulnerabilità XSS riflessa nella pagina /baseurl.
  • Corretta l'emissione di un token per una richiesta WOPI anonima di conversione e modifica che veniva accettato dall'API di Document Builder.
  • Corretta una lettura fuori dai limiti durante la conversione da XLS a XLSX.
  • Corretta la possibilità di specificare un percorso arbitrario del file system nelle impostazioni di registrazione tramite runtime.json.
  • Corretto il dirottamento della sessione di co-modifica durante il lavoro tramite WOPI.
  • Corretta una vulnerabilità di path traversal nel gestore dei modelli per la creazione di nuovi file tramite WOPI, che causava la divulgazione della configurazione del server.
  • Corrette alcune vulnerabilità nell'immagine Docker di DocumentServer.
  • Corretto un overflow del buffer dello stack durante l'elaborazione dei caratteri nei file XPS.
  • Corretta una vulnerabilità XSS nel plugin HTML durante l'incollaggio in un documento.
  • Corretta l'autenticazione dei tenant senza un segreto configurato in modalità multitenant. (Solo edizioni Enterprise e Developer)
  • Corretta l'esecuzione di uno script arbitrario all'apertura del pannello della cronologia delle versioni.
  • Corretta una lettura fuori dai limiti durante l'elaborazione delle bitmap EMF+, che causava la divulgazione di memoria.
  • Corretta una lettura fuori dai limiti durante la conversione di XLSX in PDF sul server.
  • Corretta una lettura fuori dai limiti durante l'elaborazione dei collegamenti ipertestuali in XLS, che causava la divulgazione di memoria.
  • Corretta una lettura fuori dai limiti durante il rendering di WMF, che causava la divulgazione di memoria nel documento risultante.
  • Corretta l'escalation dei privilegi tramite lo script documentserver-flush-cache.
  • Corretta la possibilità di esportare un documento tramite il comando sendForm in modalità di sola visualizzazione con il download disattivato.

Back-end​

  • Aggiornato il design della pagina di benvenuto del server.
  • Nella versione commerciale, il Pannello di amministrazione si avvia insieme al server per impostazione predefinita; la versione Community non include il Pannello di amministrazione. (Solo edizioni Enterprise e Developer)
  • La creazione del primo amministratore è stata spostata dall'interfaccia web all'utilità a riga di comando documentserver-admin (create-admin, reset-admin-password); aggiunto il login fisso admin. (Solo edizioni Enterprise e Developer)
  • Aggiunti al Pannello di amministrazione i blocchi per visualizzare il segreto JWT, nonché i pulsanti per aprire, avviare e arrestare l'esempio di prova. (Solo edizioni Enterprise e Developer)
  • Aggiunti endpoint di conversione con caricamento diretto del file (multipart): POST /converter/from-file e POST /docbuilder/from-file.
  • Aggiunto il parametro aiSettings.enable (true per impostazione predefinita) per disattivare l'IA. Quando è impostato su false, Strumenti IA viene escluso da /plugins.json e le richieste a /ai-proxy vengono rifiutate.
  • I moduli salvati come PDF normale vengono firmati all'invio (Invia). (Solo edizioni Enterprise e Developer)
  • JWT è abilitato per impostazione predefinita in default.json.
  • Rimosso lo script separato changes2forgotten: le modifiche vengono ripristinate in forgotten allo spegnimento del server.
  • Aggiunti i parametri services.CoAuthoring.server.docbuilderEnable e services.CoAuthoring.server.convertServiceEnable per disattivare le API pubbliche di Document Builder e del convertitore (true per impostazione predefinita).
  • Aggiunta la metrica coauth.connections con i tag mode (edit, liveview, view) e replica.
  • Aggiunta la verifica dell'integrità dei file scaricati quando l'integratore fornisce le intestazioni corrispondenti: il parametro services.CoAuthoring.requestDefaults.checksumVerification (true per impostazione predefinita).
  • Modifica del comportamento: /converter, /docbuilder e /command non accettano più un token dalla configurazione dell'editor. Aggiunto al token il campo operation, facoltativo per queste richieste e obbligatorio per /converter/from-file e /docbuilder/from-file.
  • Modifica del comportamento: le regole ipfilter sono ora obbligatorie per WOPI; la regola allow: * non basta, l'host deve essere specificato esplicitamente.
  • Modifica del comportamento: tramite runtime.json è possibile modificare solo il livello di registrazione di log4js.
  • Modifica del comportamento: la porta predefinita di ONLYOFFICE Docs per le installazioni DEB e RPM è ora 8083 invece di 80.
  • Il comando di installazione Docker ora funziona sia su amd64 sia su arm64 senza parametri aggiuntivi.

Personalizzazione​

  • Aggiunto il parametro editorConfig.customization.ai.disabled per disattivare Strumenti IA.
  • Rimossa la gestione dei parametri obsoleti di editorConfig.customization: reviewDisplay, trackChanges e showReviewChanges.

Versione mobile​

  • Implementato il salvataggio di una copia di un file (Salva una copia), anche tramite WOPI. (Solo edizioni Enterprise e Developer)

IA​

  • Ridisegnata l'interfaccia della chat: la scheda IA è stata rinominata in Strumenti IA e Chatbot in Chat IA; gli elementi della scheda sono stati organizzati nei gruppi Azioni rapide e Assistenti IA.
  • Aggiunto il supporto per gli strumenti dell'editor.
  • Aggiunto il supporto per il contesto del documento in tutti gli editor: l'assistente IA ora può eseguire qualsiasi azione disponibile nell'interfaccia dell'editor.
  • Aggiornati i modelli di prompt.
  • Aggiunta la possibilità di creare Azioni rapide (comandi personalizzati una tantum per il testo selezionato) e di scegliere un modello per gli assistenti IA nell'Editor di documenti e nell'Editor di moduli.
  • Aggiunto il supporto per i collegamenti interni nel plugin IA: rispondendo a domande sul contenuto di documenti e fogli di calcolo, l'assistente formatta i riferimenti alle posizioni come collegamenti cliccabili.
  • Migliorato lo strumento di riscrittura del testo nel plugin IA nell'Editor di documenti: è supportata qualsiasi selezione di testo, anche all'interno delle tabelle, mantenendo la formattazione e la posizione degli oggetti in linea.

API​

  • Semplificata la chiamata dei metodi dell'editor dai plugin: aggiunto l'oggetto globale Editor, i cui metodi restituiscono una Promise.
  • Aggiunto il metodo Editor.RunMacro per eseguire codice dell'API dell'editor passando argomenti e ottenendo il risultato tramite await.
  • Aggiunta la classe ApiShadow per lavorare con le ombre.
  • Aggiunti metodi per configurare le frecce delle linee.
  • Aggiunti metodi per configurare il testo delle etichette dati dei grafici.
  • Aggiunta la classe ApiTextRange all'Editor di presentazioni, all'Editor di fogli di calcolo e all'Editor PDF.
  • Aggiunti metodi per lavorare con le filigrane nell'Editor di documenti.
  • Aggiunti la classe ApiWatermarkSettings e i relativi metodi.
  • Aggiunte classi per lavorare con i sommari e gli indici delle figure nell'Editor di documenti.
  • Aggiunti metodi per lavorare con le tabelle nell'Editor di documenti.
  • Aggiunta la classe ApiDropCap per lavorare con i capilettera nell'Editor di documenti.
  • Aggiunto il supporto per la ricerca con espressioni regolari nel metodo ApiDocument.Search.
  • Aggiunto un metodo per selezionare la frase corrente nell'Editor di documenti.
  • Aggiunta la possibilità di impostare uno stile per nome e di rimuovere uno stile o una numerazione usando il valore null nei metodi SetStyle (ApiParagraph, ApiParaPr, ApiRun, ApiTextPr), ApiParagraph.SetNumbering e ApiParaPr.SetNumPr.
  • Aggiunto il parametro comparisonPr ai metodi Api.CompareDocuments e Api.MergeDocuments per configurare il confronto e l'unione dei documenti, compresi i tipi di modifiche da tracciare e l'autore delle modifiche.
  • Aggiunti la classe ApiHyperlink e i metodi per lavorare con i collegamenti ipertestuali nell'Editor di fogli di calcolo.
  • Aggiunte le classi ApiPageSetup, ApiPage e ApiHeaderFooter per lavorare con le impostazioni di pagina e con intestazioni e piè di pagina nell'Editor di fogli di calcolo.
  • Aggiunto il supporto per i caratteri jolly e le espressioni regolari in ApiRange.Find e ApiRange.Replace.
  • Aggiunto il supporto per un numero di intervalli da 2 a 30 in Api.Intersect.
  • Il metodo ApiRange.SetValue ora sposta i riferimenti relativi in una formula per un intervallo di più celle e restituisce false se il valore non viene scritto.
  • Il metodo ApiRange.GetFormula ora restituisce una matrice di formule per più celle.
  • Aggiunti nuovi metodi nell'Editor di fogli di calcolo.
  • Aggiunti metodi per lavorare con la proprietà StopIfTrue delle regole di formattazione condizionale.
  • Aggiunti metodi per raggruppare e separare gli oggetti nell'Editor di fogli di calcolo.
  • Rimossa la classe ApiColor propria dell'Editor di fogli di calcolo; al suo posto si usa la classe comune ApiColor. Il metodo ApiColor.GetRGB ora restituisce un oggetto {r, g, b} invece di un numero.
  • Aggiunti metodi per lavorare con le presentazioni.
  • Aggiunti metodi per percorrere la struttura della presentazione.
  • Aggiunti metodi per lavorare con le tabelle nell'Editor di presentazioni.
  • Aggiunti metodi dei plugin per l'Editor di presentazioni.
  • Aggiunto il metodo dei plugin SearchNext per l'Editor PDF.
  • Aggiunto un metodo per ottenere la selezione su una pagina PDF.
  • Aggiunti la classe ApiSignatureField e i metodi per lavorare con i campi firma nell'API PDF.
  • Aggiunta la classe ApiActionCollection per ottenere, aggiungere, sostituire e rimuovere le azioni dei widget dei moduli PDF.
  • Aggiunti classi e metodi per le azioni dei moduli PDF.

Consulta il registro delle modifiche su GitHub

Versione 9.4.0​

Data di uscita: 20/05/2026

Nuove funzionalità​

Tutti gli editor​

  • Aggiunta la traduzione dell'interfaccia in croato (hr-HR, Hrvatska).
  • Le impostazioni dei grafici sono state spostate dal pannello destro a una scheda separata Progettazione grafico.

Editor di documenti​

  • Implementata la possibilità di aggiungere una linea orizzontale.

Editor di fogli di calcolo​

  • Aggiunto il supporto della modalità scura per il foglio.

Editor di presentazioni​

  • Aggiunti 25 nuovi temi di design per le presentazioni.
  • Aggiunte 20 nuove transizioni tra diapositive, raggruppate per categoria.

Moduli​

  • Implementato il salvataggio dell'immagine della firma in localStorage. Ora, durante la compilazione del campo firma, viene usata per impostazione predefinita l'ultima immagine selezionata.
  • Aggiunti i pannelli "Invia per la firma" e "Stato della compilazione".

Sicurezza​

  • Corrette le vulnerabilità di lettura fuori dai limiti durante la conversione da XLS a XLSX nelle seguenti funzioni: ChartSheetSubstream::recalc, TextPropsStream::readFields, MetroBlob::ReadComplexData, SUPBOOK::serialize_book e ATTACHEDLABEL::serialize_rPr.
  • Corretta una vulnerabilità XSS tramite output non sicuro in Convert-and-edit-wopi.ejs.
  • Corretta una vulnerabilità nella generazione dei GUID che consentiva a un aggressore di calcolare i GUID in base al loro momento di creazione.
  • Corretta una vulnerabilità che consentiva di aggirare le restrizioni della sandbox delle macro e di accedere agli oggetti dell'ambiente tramite this ed eval in modalità non strict.
  • Corretti un possibile arresto anomalo o il danneggiamento del file durante l'elaborazione di PDF con caratteri incorporati.

Back-end​

  • Rimosso il limite di 20 documenti aperti contemporaneamente.
  • Rimossa la minificazione del codice per semplificare il supporto e migliorarne la leggibilità.
  • I componenti sono stati riuniti in un unico processo per ottimizzare il consumo di risorse e semplificare il lavoro con l'applicazione.
  • Rimossa la dipendenza da RabbitMQ grazie all'unificazione dei componenti.
  • Rimossa la dipendenza dai database grazie all'unificazione dei componenti.

Personalizzazione​

  • Aggiunto il parametro disable alla sezione plugins della configurazione degli editor: una matrice di ID di plugin che vengono bloccati al caricamento e nascosti nell'interfaccia.

Versione mobile​

  • Aggiunta la possibilità di disattivare il salvataggio automatico e di gestire il salvataggio in modalità manuale.

API​

  • Aggiunti nuovi metodi dei plugin per spostare il cursore all'interno o all'esterno di un campo.
  • Ampliate le opzioni di GroupActions per controllare lo scorrimento e la posizione del cursore.
  • Aggiunta una nuova classe per il modulo firma.
  • Aggiunti metodi per compilare e recuperare i dati dei moduli.
  • Aggiunto un metodo per creare un modulo.
  • Aggiunto un nuovo metodo per verificare se il modulo è stato compilato.
  • Aggiunto un metodo per recuperare il colore di evidenziazione dei moduli senza ruolo.
  • Aggiunto un metodo per recuperare il colore di evidenziazione di un modulo.
  • Aggiunti metodi per gestire il colore dei controlli contenuto.
  • Aggiunti nuovi metodi per la classe ApiWorksheet.
  • Aggiunti la nuova classe ApiListObject e i relativi metodi.
  • Aggiunti la nuova classe ApiListColumn e i relativi metodi.
  • Aggiunti la nuova classe ApiListRow e i relativi metodi.
  • Aggiunti la nuova classe ApiSort e i relativi metodi.
  • Aggiunti la nuova classe ApiSortFields e i relativi metodi.
  • Aggiunti la nuova classe ApiSortField e i relativi metodi.
  • Aggiunti i metodi mancanti per ottenere le impostazioni di paragrafo.
  • Migliorato il comportamento di diversi metodi Get dell'oggetto ApiTextPr quando appartiene a uno stile o ai parametri di formattazione predefiniti anziché a un paragrafo.
  • Aggiunti metodi per lavorare con il formato dei moduli di testo e con l'elenco dei caratteri consentiti.
  • Aggiunti nuovi metodi.
  • Aggiunti metodi per gestire le dimensioni delle celle.
  • Aggiunto il metodo dei plugin GoToPage per passare a una pagina specifica.

Consulta il registro delle modifiche su GitHub

Versione 9.3.0​

Data di uscita: 25/02/2026

Nuove funzionalità​

Tutti gli editor​

  • Implementata la possibilità di aggiungere collegamenti ipertestuali a immagini, forme o gruppi.
  • Implementate tutte le impostazioni dei riempimenti a trama per le immagini.
  • Aggiornata la registrazione delle macro in documenti, fogli di calcolo e presentazioni.

Editor di documenti​

  • Aggiunta la visualizzazione Più pagine.
  • Aggiunti alla scheda Visualizza i pulsanti Zoom al 100% e Più pagine.
  • Modificato l'aspetto dei commenti. Ora viene usato il colore dell'utente e vengono mostrati l'inizio e la fine del commento.
  • Implementata la possibilità di selezionare parole/paragrafi con un doppio/triplo clic del mouse.
  • Aggiunto il salvataggio nel formato MD.
  • Le impostazioni di intestazione e piè di pagina sono state spostate in una scheda separata Intestazione e piè di pagina.

Editor di fogli di calcolo​

  • Aggiunto il supporto per le nuove funzioni: REGEXTEST, REGEXREPLACE, REGEXEXTRACT.
  • Migliorato il funzionamento della funzione COUNTIF.
  • Aggiunto il supporto per le matrici dinamiche.
  • Aggiunto il Risolutore per risolvere problemi lineari (Simplex LP).
  • Modificato il colore dell'indicatore dei commenti risolti.
  • Aggiunta la possibilità di selezionare più separatori quando si divide il testo in colonne/si incolla dagli appunti.
  • Aggiunto il pulsante Formato, che riunisce diverse funzioni per lavorare con fogli/righe/colonne.
  • Aggiunto il supporto in lettura per i file TSV.

Editor di presentazioni​

  • Aggiunto il supporto per la riproduzione delle animazioni GIF nella modalità presentazione.

Moduli​

  • Aggiunta la finestra delle impostazioni della firma con la possibilità di disegnare e aggiungere testo alle firme.
  • Aggiunta la possibilità di estendere i moduli fissi alle dimensioni della cella della tabella tramite il menu contestuale.
  • Aggiunta la scheda Protezione, che duplica la funzionalità Proteggi del menu File.
  • Aggiunto il salvataggio nel formato MD.

Editor PDF​

  • Aggiunta la cronologia delle versioni.
  • Aggiunta la visualizzazione Più pagine.
  • Aggiunti alla scheda Visualizza i pulsanti Zoom al 100% e Più pagine.
  • Implementata la richiesta della password all'attivazione della modalità Modifica PDF se il file è protetto dalla modifica.
  • Aggiunto il supporto per le annotazioni Collegamento con la possibilità di aggiungerle sia a un'area sia al testo di una pagina.
  • Aggiunta la possibilità di continuare a modificare i PDF usando i caratteri incorporati.
  • Aggiunta la possibilità di redigere il testo tramite la barra degli strumenti ausiliaria a comparsa.
  • Aggiunti parametri per la stampa delle pagine.

Sicurezza​

  • Corrette diverse vulnerabilità di lettura fuori dai limiti nell'elaborazione/conversione di XLS (tramite i record/campi FilePass, HLink, rgXTI.itabLast, cce del record Formula, ShapePropsStream e CRN.colLast) che causavano fughe di informazioni e l'aggiramento di ASLR.
  • Corrette vulnerabilità di dereferenziazione di puntatori non attendibili nell'elaborazione/conversione di XLS (tramite pictFmla.cbBufInCtlStm e altri vettori) che causavano fughe di informazioni e l'aggiramento di ASLR.
  • Corretta una vulnerabilità XSS basata sul DOM durante l'esecuzione di una macro tramite import() dinamico (CVE-2021-43446, CVE-2023-50883, CVE-2024-44085).

Back-end​

  • Aggiunti due gestori aperti per gli integratori: /meta/formats e /meta/config.
  • Aggiunta la memorizzazione nella cache del Service Worker con sostituzione degli ultimi tre documenti aperti.
  • Aggiunte pagine informative per i servizi example e admin-panel non in esecuzione.

Personalizzazione​

  • Modificato il parametro permissions.copy della configurazione. Ora la copia è vietata non solo verso gli appunti esterni, ma anche verso quelli interni.

Versione mobile​

  • Aggiunta l'evidenziazione degli argomenti attivi durante l'inserimento di una formula nell'Editor di fogli di calcolo.

API​

  • Aggiunti metodi per lavorare con le note a piè di pagina e le note di chiusura.
  • Aggiunti metodi dei plugin per lavorare con i campi aggiuntivi.
  • Aggiunta una nuova classe ApiColor per una gestione unificata dei colori e aggiornati i metodi esistenti.
  • Aggiunti nuovi metodi per la convalida dei dati nell'Editor di fogli di calcolo.
  • Aggiunte le nuove classi ApiAutoFilter e ApiFilter per lavorare in modo unificato con i filtri automatici dei fogli e i filtri delle colonne.
  • Aggiunta una nuova classe ApiSlideShowTransition per gestire le transizioni tra diapositive e supportare i collegamenti ipertestuali a forme/immagini.
  • Aggiunti metodi per creare e impostare collegamenti ipertestuali tramite la nuova classe ApiHyperlink.
  • Aggiunti metodi per recuperare le informazioni sul riempimento e sul contorno di una forma.
  • Aggiunti classi e metodi per lavorare con le animazioni.
  • Aggiunti metodi per impedire la modifica del modulo e per verificare se il modulo è firmato.
  • Ampliato l'oggetto FormData con nuovi campi per caselle di controllo, gruppi di pulsanti di opzione, elenchi a discesa, caselle combinate e campi data.
  • Aggiunti nuovi metodi per la classe ApiDrawing, compresi il capovolgimento, il dimensionamento relativo e il controllo della posizione.
  • Aggiunto il metodo GetDrawingsByName per ApiDocument, ApiWorkbook e ApiPresentation.
  • Aggiunti i metodi GetSelectedShapes e GetSelectedDrawings per la classe ApiWorksheet.
  • Aggiunti SetPaddings per ApiShape, SetSize per ApiTable e GetTitle per ApiChart.
  • Aggiunta l'API per le macro nell'Editor PDF con la possibilità di aggiungere, eliminare e modificare pagine, moduli, annotazioni, forme automatiche, tabelle, immagini e grafici.

Consulta il registro delle modifiche su GitHub

Versione 9.2.1​

Data di uscita: 01/12/2025

Correzioni​

Editor di documenti​

  • Corretta l'interruzione di parola in coreano.

Editor di fogli di calcolo​

  • Corretto un problema di sovrapposizione dei dati durante il trasferimento di fogli tra documenti tramite Sposta o copia.

Editor PDF​

  • Corretti diversi errori durante l'apertura, lo scorrimento, la copia, l'incollaggio, l'annullamento e l'eliminazione di pagine nei file PDF.
  • Corretto un errore con le modifiche non salvate nelle risposte ai commenti nei file PDF.

Sicurezza​

  • Corrette le iniezioni XSS nel nome del tema colori, nel campo Carattere delle impostazioni dell'elenco a più livelli e nella textarea del modulo di modifica dei commenti.
  • Corrette vulnerabilità di manipolazione della memoria durante la conversione da XLS a XLSX che potevano causare fughe di informazioni ed RCE.

Consulta il registro delle modifiche su GitHub

Versione 9.2.0​

Data di uscita: 01/12/2025

Nuove funzionalità​

Tutti gli editor​

  • Aggiunta la possibilità di personalizzare le scorciatoie da tastiera.
  • Aggiunta la possibilità di registrare le azioni eseguite come macro in tutti gli editor, tranne il PDF.

Editor di presentazioni​

  • Implementato l'inserimento di equazioni da una risorsa di terze parti.

Moduli​

  • Implementata la possibilità di selezionare il ruolo per il quale verranno aggiunti i nuovi campi.
  • Implementata la possibilità di aggiungere etichette alle caselle di controllo e ai pulsanti di opzione. In modalità di compilazione, un clic sull'etichetta equivale a un clic sulla casella di controllo stessa.

Editor PDF​

  • Aggiunta la possibilità di modificare il colore del testo nascosto (Redazione).
  • Implementato l'inserimento di equazioni da una risorsa di terze parti.

Sicurezza​

  • Redis è stato aggiornato a versioni non interessate dalla vulnerabilità CVE-2025-49844.
  • Corretta la vulnerabilità che consentiva di aggiungere un intervallo denominato nella cartella di lavoro protetta tramite websocket.
  • Corretta la vulnerabilità XSS in denyEditingRights.
  • Corrette le vulnerabilità in linux-libc-dev che consentivano di ottenere privilegi elevati nel sistema e di sottrarre dati dai processi dell'hypervisor (CVE-2025-38352, CVE-2025-40300).

Back-end​

  • Migliorato l'aspetto della barra laterale e aggiunte icone al Pannello di amministrazione.

API​

  • Aggiunti metodi per ottenere e impostare le etichette di testo per le caselle di controllo e i pulsanti di opzione.
  • Aggiunti metodi per lavorare con l'identificatore numerico di un paragrafo.
  • Aggiunto un metodo per eliminare un modulo dal documento con la possibilità di mantenerne il contenuto.
  • Aggiunto un metodo per ottenere tutti i moduli tramite ApiDocument.prototype.GetAllForms.
  • Il metodo GetAllContentControls non restituisce più i moduli.
  • Aggiunto l'evento onParagraphText, che indica che il contenuto del paragrafo è stato modificato.
  • Aggiunti eventi per lavorare con le annotazioni: onClickAnnotation, onFocusAnnotation, onBlurAnnotation.

Plugin​

  • Aggiunto il controllo grammaticale e ortografico nell'Editor di documenti e nell'Editor di moduli nel plugin IA.

Consulta il registro delle modifiche su GitHub

Versione 9.1.0​

Data di uscita: 14/10/2025

Nuove funzionalità​

Tutti gli editor​

  • Aggiunti dati esterni per i grafici. Durante la copia tra editor è possibile scegliere un file incorporato o un collegamento all'origine.
  • Aggiunta la possibilità di attivare/disattivare gli elementi dei grafici.
  • Aggiunto il supporto in apertura per l'opzione Esplosione (separazione di un settore dei grafici a torta e ad anello 2D).
  • Aggiunto il supporto per le immagini HEIF.
  • Aggiunta la possibilità di configurare la visualizzazione dei commenti risolti/aperti nel pannello sinistro.

Editor di documenti​

  • Implementato il supporto per le interruzioni di sezione all'interno dei controlli contenuto di blocco con qualsiasi livello di annidamento.
  • Aggiunto un editor di grafici completo. I file XLSX incorporati ora vengono aperti invece di caricare i valori dalla cache del grafico.
  • Aggiunto il supporto in visualizzazione per il formato di documenti di testo HWPML.
  • Aggiunto il supporto per l'inserimento di formule matematiche dal formato MathML.

Editor di fogli di calcolo​

  • Aggiunta un'impostazione per la direzione generale del testo in una cella.
  • Aggiunto il supporto per i filtri per data nelle tabelle pivot.
  • Aggiunti in apertura alcuni controlli modulo (Casella di controllo, Casella combinata, Casella di riepilogo, Pulsante di selezione, Barra di scorrimento, Pulsante).
  • Migliorata la logica delle formule per i tipi di dati misti.
  • Ridotto il consumo di memoria durante il calcolo delle formule.
  • Ottimizzato il calcolo delle formule VLOOKUP e XLOOKUP.
  • Aggiunta l'evidenziazione degli argomenti attivi durante l'inserimento di una formula.
  • Aggiunta la traduzione delle formule in serbo (cirillico), serbo (latino) e cinese (tradizionale).
  • Aggiunto il supporto per l'inserimento di formule matematiche dal formato MathML.
  • Le impostazioni delle tabelle formattate sono state spostate dal pannello destro alla scheda Progettazione tabella della barra degli strumenti superiore.
  • Aggiunta la possibilità di rinominare un foglio con un doppio clic sul suo nome senza aprire finestre aggiuntive.

Editor di presentazioni​

  • Aggiunto un editor di grafici completo. I file XLSX incorporati ora vengono aperti invece di caricare i valori dalla cache del grafico.
  • Le impostazioni dello schema diapositiva sono state spostate dalla scheda Inserisci a una scheda separata della barra degli strumenti superiore.

Moduli​

  • Migliorata l'esperienza utente nel lavoro con i campi.
  • I pulsanti Visualizza modulo e Gestisci ruoli sono stati rinominati in Anteprima e Gestisci ruoli dei destinatari.
  • Aggiunto il supporto per l'inserimento di formule matematiche dal formato MathML.

Editor PDF​

  • Aggiunta la funzionalità per nascondere le informazioni riservate: Redazione.
  • Aggiunti nuovi tipi di annotazioni alla sezione Commento.
  • Implementato il lavoro con gli Smart Art.
  • Aggiunto il supporto per i grafici.
  • Implementate la copia e l'incollaggio di elementi grafici e moduli.

Sicurezza​

  • Corretta la vulnerabilità XSS durante l'elaborazione dei collegamenti ipertestuali nei documenti.
  • Corretta la vulnerabilità che consentiva di scrivere file arbitrari nel file system durante la conversione tramite x2t.
  • Corretta la vulnerabilità che consentiva di leggere file arbitrari nel file system durante la conversione di EPUB tramite ConvertService.
  • Corretta la vulnerabilità nell'endpoint info/config che consentiva di modificare la configurazione del server.

Conversione​

  • Aggiunta la possibilità di convertire direttamente PDF e PPTX in TXT.

Back-end​

  • Aggiunto il pannello di amministrazione per visualizzare lo stato del server e configurarlo in parte.
  • Aggiunte le impostazioni storage.commandOptions.s3 e storage.commandOptions.az per personalizzare i comandi di archiviazione.
  • Modificato il valore storage.useDirectStorageUrls=false: ora DocServer restituisce per impostazione predefinita collegamenti interni.
  • Aggiunta l'impostazione oracleExtraOptions.thin per connettersi a Oracle in modalità Thick tramite Oracle Instant Client in un cluster.
  • Rimosso lo schema public dal database PostgreSQL. Ora l'amministratore può specificare qualsiasi schema durante la creazione di un database.
  • Aggiunto il parametro DB_SCHEMA per selezionare uno schema nel database (solo PostgreSQL e MSSQL).

WOPI​

  • Aggiunto il supporto per il parametro UserCanOnlyComment in CheckFileInfo per l'apertura in modalità di commento.
  • Aggiunta l'apertura in modalità Visualizzazione con un messaggio di errore se non è stato possibile bloccare il file all'apertura dell'editor.

API​

  • Aggiunti classi e metodi per lavorare con i filtri delle tabelle pivot: ApiPivotField, ApiPivotFilters, ApiPivotItem.
  • Aggiunti metodi comuni di ApiRange: Offset, Resize, GetRange, GetEntireRow, GetEntireColumn.
  • Aggiunti classi e metodi per lavorare con la geometria delle forme: ApiGeometry, ApiPath, ApiPathCommand.

Consulta il registro delle modifiche su GitHub

Versione 9.0.4​

Data di uscita: 05/08/2025

Nuove funzionalità​

  • Aggiunto il supporto per i caratteri woff2.
  • Aggiunta la voce Suggerisci una funzionalità al menu File degli editor.

Editor di documenti​

  • Migliorata l'usabilità nel lavoro con le aree consentite.

Personalizzazione​

  • Aggiunto il parametro customization.suggestFeature.

Plugin​

  • Aggiunti i plugin AI, Photo Editor, MathType, OCR, Typograf, Doc2md, LanguageTool, DeepL, Thesaurus, Speech input e Zotero alla distribuzione della versione server con il marchio ONLYOFFICE.

Correzioni​

Tutti gli editor​

  • Corretti problemi di visualizzazione delle barre di scorrimento, della griglia di creazione delle tabelle e delle finestre di errore nei temi Modern.
  • Corretto l'annullamento errato dopo l'inserimento composito di testo in una forma automatica in modalità di co-modifica Veloce.

Editor di documenti​

  • Corretti diversi problemi di visualizzazione, arresti anomali e problemi di formattazione, tra cui le impostazioni delle tabelle, la lettura dei colori, il ridimensionamento delle forme automatiche e le finestre di protezione con password.

Editor di fogli di calcolo​

  • Corretti diversi problemi di visualizzazione, arresti anomali e problemi di formattazione, tra cui il posizionamento del testo RTL, l'incollaggio di immagini, le barre di scorrimento e la formattazione condizionale.

Editor di presentazioni​

  • Corretto un errore che si verificava facendo clic nell'area di lavoro dopo aver eliminato tutte le diapositive nel file ODP.
  • Corretta la traduzione della scheda "Transizioni" in danese.

Moduli​

  • Corretti problemi di visualizzazione dei nomi dei campi, del testo nel formato password, dell'inserimento su pagine ruotate e dell'elenco Formato quando è attivata l'opzione Multiriga.

Editor PDF​

  • Corretti l'apertura del menu contestuale dopo un'interruzione della connessione, l'aggiunta di commenti ai timbri e l'applicazione dell'opzione Adatta automaticamente.

Conversione​

  • Corretti diversi arresti anomali durante la conversione di file PPTX, XLSM, DOCX, ODT, ODS, DOC e KEY in vari formati.

Back-end​

  • Corretta la sincronizzazione delle impostazioni IA in k8s tra più document server.
  • Corretta l'apertura lenta dei PDF nell'esempio di prova WOPI se JWT è disattivato.

Versione mobile​

  • Corretti la visualizzazione del pulsante Passa alla versione desktop, l'ordine delle diapositive in modalità presentazione e un errore al clic sulle immagini nei file PPTX.

Consulta il registro delle modifiche su GitHub

Versione 9.0.3​

Data di uscita: 08/07/2025

Nuove funzionalità​

Editor di fogli di calcolo​

  • Abilitata la possibilità di inserire un intervallo di celle come immagine tramite navigator.clipboard.

Personalizzazione​

  • Aggiunta la possibilità di nascondere il titolo del documento nella barra degli strumenti tramite il parametro customization.toolbarHideFileName.

Correzioni​

Tutti gli editor​

  • Corretta la visualizzazione del cursore e della selezione del testo limitata dalle dimensioni dell'oggetto/forma.
  • Corretti problemi di icone e di aspetto nei temi Modern con scale elevate dell'interfaccia.

Editor di documenti​

  • Corretti diversi arresti anomali e problemi di conversione, tra cui la modifica del piè di pagina, le operazioni Confronta/Combina, i controlli contenuto, l'esportazione in PDF dei caratteri CJK e la gestione dei segnaposto.

Editor di fogli di calcolo​

  • Corretti diversi problemi, tra cui arresti anomali con i riferimenti nelle formule, l'esportazione delle funzioni personalizzate, l'adattamento automatico dell'altezza delle righe, la visualizzazione dello zoom in RTL e la posizione del segno di percentuale.

Editor di presentazioni​

  • Corretti gli arresti anomali durante l'applicazione di animazioni, l'eliminazione di diapositive e la copia di contenuti in alcuni file PPTX.
  • Corrette traduzioni errate nel menu Disegna della finestra Visualizzazione relatore.

Moduli​

  • Corretti diversi arresti anomali e problemi di visualizzazione, tra cui TextArt nel campo firma, la riconnessione dopo un periodo di inattività, i pulsanti dei controlli contenuto e le icone Cancella campi.

Editor PDF​

  • Corretti diversi problemi, tra cui Taglia/Incolla nel pannello delle miniature, la visualizzazione del testo dopo il ripristino della sessione, il salvataggio dei campi dei moduli e l'inserimento dei commenti di testo.

Diagrammi​

  • Corretta la visualizzazione della diapositiva nell'area di lavoro all'apertura di alcuni file VSTX.

Conversione​

  • Corretti diversi arresti anomali e problemi di conversione per i file DOCX, HWP, DOC, XLS e VSDX.

Back-end​

  • Corretto l'errore di salvataggio della configurazione durante il salvataggio o il ripristino delle impostazioni IA su /info quando si usa un proprio runtime.json.

Versione mobile​

  • Corretta la possibilità di copiare il contenuto quando l'editor viene inizializzato con il parametro permissions.copy: false.

Consulta il registro delle modifiche su GitHub

Versione 9.0.2​

Data di uscita: 26/06/2025

Correzioni​

Tutti gli editor​

  • Per i temi moderni, lo stile predefinito delle schede è stato cambiato in Linea.

Editor di documenti​

  • Corretto il problema con il calcolo di intestazione/piè di pagina.
  • Corretto un problema con il primo calcolo del documento quando il documento aperto contiene modifiche collaborative.

Editor di fogli di calcolo​

  • Corretto l'arresto anomalo dell'editor durante l'esportazione di file XLSX in PDF.

Moduli​

  • Corretta l'apertura dei PDF Forms compilati nelle stanze per moduli e nelle Virtual Data Room su Apps.

Consulta il registro delle modifiche su GitHub

Versione 9.0.0​

Data di uscita: 18/06/2025

Nuove funzionalità​

Tutti gli editor​

  • Aggiunti nuovi temi dell'interfaccia: Modern Light e Modern Dark.
  • Aggiunto il salvataggio delle ultime lingue selezionate negli elenchi del controllo ortografico.
  • Aggiunto il dizionario arabo per il controllo ortografico, usato in sedici dialetti.
  • Aggiunte la generazione di macro basata sull'IA a partire da descrizioni e la conversione da VBA a JavaScript.
  • Aggiunta la traduzione dell'interfaccia in urdu (ur-PK, Urdu (Pakistan)).
  • Aggiunto il supporto per le impostazioni del testo TextArt all'interno delle etichette dei grafici.
  • Aggiunto il supporto per il disegno degli elementi del grafico Barre crescenti/decrescenti.

Editor di documenti​

  • Aggiunta la visualizzazione corretta delle anteprime dei numeri di paragrafo per RTL.
  • Migliorati il posizionamento e le impostazioni di TextArt per RTL.
  • Migliorato il disegno di bordi e riempimento per i paragrafi con direzione RTL.
  • Abilitata una navigazione precisa del cursore con i tasti freccia in base alla direzione del testo del paragrafo.
  • Aggiunta la possibilità di visualizzare i numeri con le cifre hindi.
  • Aggiunta al menu File un'impostazione per selezionare la dimensione del carattere preferita (occidentale/cinese) per la lingua dell'interfaccia cinese.
  • Aggiunto alla barra degli strumenti Home un pulsante Bordi per impostare rapidamente le impostazioni del paragrafo.
  • Aggiunto il supporto in lettura per il formato MD.

Editor di fogli di calcolo​

  • Aggiunto il supporto per la visualizzazione del testo bidirezionale.
  • Aggiunta la possibilità di selezionare dati esterni da un altro foglio di calcolo.

Editor di presentazioni​

  • Aggiunta la possibilità di impostare la direzione del paragrafo (Direzione del testo > RTL) nella barra degli strumenti e nelle impostazioni avanzate.
  • Aggiunta la possibilità di visualizzare le animazioni con il testo.
  • Aggiunta l'opzione "Mantieni" al menu contestuale dello schema diapositiva.

Consulta il registro delle modifiche su GitHub

Versione 8.3.3​

Data di uscita: 16/04/2025

Consulta il registro delle modifiche su GitHub

Versione 8.3.2​

Data di uscita: 19/03/2025

Consulta il registro delle modifiche su GitHub

Versione 8.3.1​

Data di uscita: 27/02/2025

Consulta il registro delle modifiche su GitHub

Versione 8.3.0​

Data di uscita: 05/02/2025

Consulta il registro delle modifiche su GitHub

Versione 8.2.2​

Data di uscita: 28/11/2024

Consulta il registro delle modifiche su GitHub

Versione 8.2.1​

Data di uscita: 12/11/2024

Consulta il registro delle modifiche su GitHub

Versione 8.2.0​

Data di uscita: 17/10/2024

Consulta il registro delle modifiche su GitHub

Versione 8.1.1​

Data di uscita: 15/07/2024

Consulta il registro delle modifiche su GitHub

Versione 8.1.0​

Data di uscita: 19/06/2024

Consulta il registro delle modifiche su GitHub

Versione 8.0.1​

Data di uscita: 26/02/2024

Consulta il registro delle modifiche su GitHub

Versione 8.0.0​

Data di uscita: 30/01/2024

Consulta il registro delle modifiche su GitHub

Versione 7.5.1​

Data di uscita: 11/08/2023

Consulta il registro delle modifiche su GitHub

Versione 7.5.0​

Data di uscita: 17/10/2023

Consulta il registro delle modifiche su GitHub

Versione 7.4.1​

Data di uscita: 31/07/2023

Consulta il registro delle modifiche su GitHub

Versione 7.4.0​

Data di uscita: 13/06/2023

Consulta il registro delle modifiche su GitHub

Versione 7.3.3​

Data di uscita: 15/03/2023

Consulta il registro delle modifiche su GitHub

Versione 7.3.2​

Data di uscita: 14/02/2023

Consulta il registro delle modifiche su GitHub

Versione 7.3.0​

Data di uscita: 31/01/2023

Consulta il registro delle modifiche su GitHub

Versione 7.2.2​

Data di uscita: 20/12/2022

Consulta il registro delle modifiche su GitHub

Versione 7.2.1​

Data di uscita: 21/10/2022

Consulta il registro delle modifiche su GitHub

Versione 7.2.0​

Data di uscita: 22/09/2022

Consulta il registro delle modifiche su GitHub

Versione 7.1.1​

Data di uscita: 02/06/2022

Consulta il registro delle modifiche su GitHub

Versione 7.1.0​

Data di uscita: 12/05/2022

Consulta il registro delle modifiche su GitHub

Versione 7.0.1​

Data di uscita: 22/02/2022

Consulta il registro delle modifiche su GitHub

Versione 7.0.0​

Data di uscita: 18/01/2022

Consulta il registro delle modifiche su GitHub

Versione 6.4.2​

Data di uscita: 14/10/2021

Consulta il registro delle modifiche su GitHub

Versione 6.4.1​

Data di uscita: 28/09/2021

Consulta il registro delle modifiche su GitHub

Versione 6.4.0​

Data di uscita: 26/08/2021

Consulta il registro delle modifiche su GitHub

Versione 6.3.2​

Data di uscita: 10/08/2021

Consulta il registro delle modifiche su GitHub

Versione 6.3.1​

Data di uscita: 08/06/2021

Consulta il registro delle modifiche su GitHub

Versione 6.3.0​

Data di uscita: 20/05/2021

Consulta il registro delle modifiche su GitHub

Versione 6.2.2​

Data di uscita: 19/04/2021

Consulta il registro delle modifiche su GitHub

Versione 6.2.1​

Data di uscita: 31/03/2021

Consulta il registro delle modifiche su GitHub

Versione 6.2.0​

Data di uscita: 01/03/2021

Consulta il registro delle modifiche su GitHub

Versione 6.1.1​

Data di uscita: 28/01/2021

Consulta il registro delle modifiche su GitHub

Versione 6.1.0​

Data di uscita: 02/12/2020

Consulta il registro delle modifiche su GitHub

Versione 6.0.2​

Data di uscita: 12/11/2020

Consulta il registro delle modifiche su GitHub

Versione 6.0.1​

Data di uscita: 28/10/2020

Consulta il registro delle modifiche su GitHub

Versione 6.0.0​

Data di uscita: 14/10/2020

Consulta il registro delle modifiche su GitHub

Versione 5.6.5​

Data di uscita: 21/09/2020

Consulta il registro delle modifiche su GitHub

Versione 5.6.4​

Data di uscita: 08/09/2020

Consulta il registro delle modifiche su GitHub

Versione 5.6.3​

Data di uscita: 17/08/2020

Consulta il registro delle modifiche su GitHub

Versione 5.6.2​

Data di uscita: 07/08/2020

Consulta il registro delle modifiche su GitHub

Versione 5.6.1​

Data di uscita: 05/08/2020

Consulta il registro delle modifiche su GitHub

Versione 5.6.0​

Data di uscita: 29/07/2020

Consulta il registro delle modifiche su GitHub

Versione 5.5.3​

Data di uscita: 22/05/2020

Consulta il registro delle modifiche su GitHub

Versione 5.5.1​

Data di uscita: 09/04/2020

Consulta il registro delle modifiche su GitHub

Versione 5.5.0​

Data di uscita: 05/03/2020

Consulta il registro delle modifiche su GitHub

Versione 5.4.2​

Data di uscita: 27/11/2019

Consulta il registro delle modifiche su GitHub

Versione 5.4.1​

Data di uscita: 02/10/2019

Consulta il registro delle modifiche su GitHub

Versione 5.4.0​

Data di uscita: 03/09/2019

Consulta il registro delle modifiche su GitHub

Versione 5.3.4​

Data di uscita: 16/07/2019

Consulta il registro delle modifiche su GitHub

Versione 5.3.2​

Data di uscita: 24/06/2019

Consulta il registro delle modifiche su GitHub

Versione 5.3.1​

Data di uscita: 06/06/2019

Consulta il registro delle modifiche su GitHub

Versione 5.3.0​

Data di uscita: 28/05/2019

Consulta il registro delle modifiche su GitHub

Versione 5.2.8​

Data di uscita: 05/02/2019

Consulta il registro delle modifiche su GitHub

Versione 5.2.7​

Data di uscita: 16/01/2019

Consulta il registro delle modifiche su GitHub

Versione 5.2.6​

Data di uscita: 25/12/2018

Consulta il registro delle modifiche su GitHub

Versione 5.2.4​

Data di uscita: 12/12/2018

Consulta il registro delle modifiche su GitHub

Versione 5.2.3​

Data di uscita: 31/10/2018

Consulta il registro delle modifiche su GitHub

Versione 5.2.2​

Data di uscita: 05/10/2018

Consulta il registro delle modifiche su GitHub

Versione 5.2.0​

Data di uscita: 28/09/2018

Consulta il registro delle modifiche su GitHub

Versione 5.1.5​

Data di uscita: 18/07/2018

Consulta il registro delle modifiche su GitHub

Versione 5.1.4​

Data di uscita: 24/05/2018

Consulta il registro delle modifiche su GitHub

Versione 5.1.3​

Data di uscita: 27/04/2018

Consulta il registro delle modifiche su GitHub

Versione 5.1.2​

Data di uscita: 11/04/2018

Consulta il registro delle modifiche su GitHub

Versione 5.1.1​

Data di uscita: 05/04/2018

Consulta il registro delle modifiche su GitHub

Versione 5.1.0​

Data di uscita: 28/03/2018

Consulta il registro delle modifiche su GitHub

Versione 5.0.7​

Data di uscita: 16/01/2018

Consulta il registro delle modifiche su GitHub

Versione 5.0.6​

Data di uscita: 11/12/2017

Consulta il registro delle modifiche su GitHub

Versione 5.0.5​

Data di uscita: 28/11/2017

Consulta il registro delle modifiche su GitHub

Versione 5.0.4​

Data di uscita: 14/11/2017

Consulta il registro delle modifiche su GitHub

Versione 5.0.3​

Data di uscita: 02/11/2017

Consulta il registro delle modifiche su GitHub

Versione 5.0.2 (solo SaaS)​

Data di uscita: 13/10/2017

Consulta il registro delle modifiche su GitHub

Versione 5.0.1 (solo SaaS)​

Data di uscita: 05/10/2017

Consulta il registro delle modifiche su GitHub

Versione 5.0.0 (solo SaaS)​

Data di uscita: 23/09/2017

Consulta il registro delle modifiche su GitHub

Versione 4.4.4​

Data di uscita: 13/09/2017

Versione solo per Windows

Consulta il registro delle modifiche su GitHub

Versione 4.4.3​

Data di uscita: 14/08/2017

Consulta il registro delle modifiche su GitHub

Versione 4.4.2​

Data di uscita: 24/07/2017

Consulta il registro delle modifiche su GitHub

Versione 4.4.1​

Data di uscita: 05/07/2017

Consulta il registro delle modifiche su GitHub

Versione 4.3.6​

Data di uscita: 14/06/2017

Consulta il registro delle modifiche su GitHub

Versione 4.3.5​

Data di uscita: 05/06/2017

Consulta il registro delle modifiche su GitHub

Versione 4.3.4​

Data di uscita: 16/05/2017

Consulta il registro delle modifiche su GitHub

Versione 4.3.3​

Data di uscita: 28/04/2017

Consulta il registro delle modifiche su GitHub

Versione 4.3.2​

Data di uscita: 17/04/2017

Consulta il registro delle modifiche su GitHub

Versione 4.3.1​

Data di uscita: 06/04/2017

Consulta il registro delle modifiche su GitHub

Versione 4.3.0​

Data di uscita: 03/04/2017

Consulta il registro delle modifiche su GitHub

Versione 4.2.11​

Data di uscita: 13/03/2017

Consulta il registro delle modifiche su GitHub

Versione 4.2.10​

Data di uscita: 20/02/2017

Consulta il registro delle modifiche su GitHub

Versione 4.2.9​

Data di uscita: 14/02/2017

Consulta il registro delle modifiche su GitHub

Versione 4.2.8​

Data di uscita: 06/02/2017

Consulta il registro delle modifiche su GitHub

Versione 4.2.7​

Data di uscita: 01/02/2017

Consulta il registro delle modifiche su GitHub

Versione 4.2.5​

Data di uscita: 16/01/2017

Consulta il registro delle modifiche su GitHub

Versione 4.2.4​

Data di uscita: 09/01/2017

Consulta il registro delle modifiche su GitHub

Versione 4.2.3​

Data di uscita: 23/12/2016

Consulta il registro delle modifiche su GitHub

Versione 4.2.2​

Data di uscita: 21/12/2016

Consulta il registro delle modifiche su GitHub

Versione 4.2.1​

Data di uscita: 06/12/2016

Consulta il registro delle modifiche su GitHub

Versione 4.2.0​

Data di uscita: 01/12/2016

Consulta il registro delle modifiche su GitHub

Versione 4.1.8​

Data di uscita: 03/11/2016

Consulta il registro delle modifiche su GitHub

Versione 4.1.7​

Data di uscita: 01/11/2016

Consulta il registro delle modifiche su GitHub

Versione 4.1.6​

Data di uscita: 26/10/2016

Consulta il registro delle modifiche su GitHub

Versione 4.1.5​

Data di uscita: 23/10/2016

Consulta il registro delle modifiche su GitHub

Versione 4.1.4​

Data di uscita: 07/10/2016

Consulta il registro delle modifiche su GitHub

Versione 4.1.3​

Data di uscita: 28/09/2016

Consulta il registro delle modifiche su GitHub

Versione 4.1.2​

Data di uscita: 22/09/2016

Consulta il registro delle modifiche su GitHub

Versione 4.0.3​

Data di uscita: 04/08/2016

Consulta il registro delle modifiche su GitHub

Versione 4.0.2​

Data di uscita: 03/08/2016

Consulta il registro delle modifiche su GitHub