Abilitare l'IA su Docs
Abilitare l'IA su Docs
ONLYOFFICE ti consente di collegare modelli AI e di utilizzarli direttamente negli editor. La scheda Strumenti AI dà accesso a tutte le funzionalità AI e puoi assegnare attività specifiche a modelli diversi a seconda di ciò che ciascun modello è in grado di fare.
Gli strumenti AI sono integrati negli editor, quindi non è necessario installare alcun plugin. Tuttavia, per motivi di sicurezza, nessun modello AI è collegato per impostazione predefinita. Per iniziare a utilizzare le funzionalità AI, collega un modello a tua scelta come descritto di seguito.
Se la scheda Strumenti AI non è visualizzata nella barra degli strumenti superiore, passa alla scheda Plugin, fai clic su Plugin in background e assicurati che l'interruttore Strumenti AI sia attivato.
Passaggio 1. Collegare un modello AI
Puoi collegare un modello di un provider AI tramite una chiave API, oppure un modello ospitato localmente. Ci sono due posti in cui puoi farlo: la finestra Impostazioni AI e il pannello Chat AI.
Tramite la finestra Impostazioni AI
- Passa alla scheda Strumenti AI e fai clic su Impostazioni. La finestra Impostazioni AI si aprirà sulla scheda Modelli AI.
- Fai clic su Aggiungi modello.
- Seleziona un Provider e inserisci la tua chiave API.
- Fai di nuovo clic su Aggiungi modello per salvare il modello.
Tramite il pannello Chat AI
- Passa alla scheda Strumenti AI e fai clic su Chat AI. Il pannello Chat AI si aprirà sulla destra.
- Se non è ancora stato collegato alcun modello, il pannello ti chiederà di collegarne uno. Seleziona un Provider e inserisci la tua chiave API.
- Fai clic su Aggiungi modello.
In entrambi i casi devi compilare solo due campi: Provider e Chiave API. Gli altri campi vengono compilati automaticamente.
- Provider — seleziona un provider AI dall'elenco. Per utilizzare un provider che non è presente nell'elenco, fai clic su Importa provider personalizzato.
- Chiave API — inserisci la chiave API ricevuta dal tuo provider. Se non ne hai una, fai clic sul link Ottieni chiave API per aprire la pagina di creazione della chiave del provider selezionato.
- URL di base — compilato automaticamente quando selezioni un provider. Modificalo solo se utilizzi un provider personalizzato o un modello ospitato localmente.
- Modello — questo elenco non è disponibile finché non inserisci una chiave API valida. Una volta accettata la chiave, viene selezionato automaticamente un modello. Puoi sceglierne uno diverso dall'elenco.
- Nome profilo — compilato automaticamente. Puoi sostituirlo con il nome che preferisci.
Se la chiave API non è valida, sotto il campo Chiave API viene visualizzato un messaggio di errore e il pulsante Aggiungi modello rimane non disponibile. Controlla la chiave e inseriscila di nuovo.
Passaggio 2. Assegnare i modelli alle attività
Una volta collegato il modello, assegnalo alle attività:
- Passa alla scheda Strumenti AI e fai clic su Impostazioni.
- Passa alla scheda Assegnazione dei modelli.
- Seleziona un modello per ciascuna attività. Se hai collegato più modelli, puoi utilizzare un modello diverso per ogni attività.
Non tutti i modelli supportano tutte le attività. Se assegni un modello a un'attività che non supporta, potrebbero verificarsi errori.
La finestra Impostazioni AI contiene anche le schede Server MCP e Ricerca web, dove puoi collegare server MCP e configurare la ricerca web per il tuo assistente AI.
Passaggio 3. Usare l'AI
Ora puoi utilizzare le funzionalità AI selezionando le opzioni corrispondenti nella scheda Strumenti AI:
- Chat AI — poni domande sul tuo documento, genera nuovo testo o migliora il contenuto esistente.
- Crea azione AI rapida — crea una tua azione con un prompt personalizzato e aggiungila alla barra degli strumenti.
- Riepilogo — riassumi lunghi brani di testo.
- Traduzione — traduci il testo selezionato nella lingua che preferisci.
- Crea assistente AI — configura un assistente per le tue attività.
- Mostra tutti i risultati — visualizza i risultati generati dall'AI.
- Grammatica e ortografia — controlla il testo e rivedi le correzioni suggerite.
Per ulteriori dettagli sulle funzionalità AI disponibili, consulta la sezione Guide utente AI.
Usare l'AI quando si lavora con le macro
Il codice viene elaborato da un servizio AI di tua scelta. Possono verificarsi fughe di dati o modifiche impreviste del codice. ONLYOFFICE non si assume alcuna responsabilità per eventuali completamenti che possano contenere errori od omissioni, né per contenuti molesti o inappropriati. Le informazioni contenute nei completamenti sono generate da un servizio AI scelto dall'utente e sono fornite "così come sono", senza ulteriori filtri da parte di ONLYOFFICE.
L'AI può aiutarti a creare e convertire macro. Per accedere a queste funzionalità:
-
Passa alla scheda Visualizza e fai clic sul pulsante Macro nella barra degli strumenti superiore. Si aprirà la finestra Macro.
-
Fai clic sul pulsante AI nell'angolo in alto a sinistra della finestra e seleziona una delle opzioni:
- Crea da descrizione — descrivi cosa deve fare la macro e il tuo assistente AI la genererà.
- Converti da VBA — incolla il tuo codice VBA nella finestra Converti macro da VBA e verrà convertito in una macro.
Se non hai ancora configurato il tuo assistente AI, ti verrà chiesto di farlo. Segui il Passaggio 1 e il Passaggio 2 di questa guida per configurarlo.
Per saperne di più sulle macro, consulta la nostra documentazione API.