Aller au contenu principal

Insérer un tableau

Insérer un tableau​

Pour insérer un tableau dans l'éditeur de documents,

  1. placez le curseur à l'endroit où vous voulez insérer le tableau,

  2. passez à l'onglet Insertion de la barre d'outils supérieure,

  3. cliquez sur l'icône Tableau Tableau de la barre d'outils supérieure,

  4. sélectionnez l'option pour créer un tableau :

    • un tableau comprenant un certain nombre de cellules (10x8 cellules au maximum)

      S'il vous faut ajouter rapidement un tableau, sélectionnez le nombre de lignes (8 au maximum) et le nombre de colonnes (10 au maximum).

    • ou un tableau personnalisé

      Si vous avez besoin d'un tableau plus grand que 10x8 cellules, sélectionnez l'option Insérer un tableau personnalisé, et dans la fenêtre qui s'affiche, saisissez le nombre de lignes et de colonnes nécessaires, ensuite cliquez sur OK.

      Tableau personnalisé

    • Si vous souhaitez dessiner un tableau à l'aide de la souris, sélectionnez l'option Dessiner un tableau. Cela peut être utile si vous souhaitez créer un tableau comprenant des lignes et des colonnes de différentes tailles. Le pointeur de la souris se transforme en crayon Crayon. Dessinez une forme rectangulaire à l'endroit où vous souhaitez ajouter un tableau, ensuite dessinez des traits horizontaux pour ajouter des lignes et des traits verticaux pour ajouter des colonnes à l'intérieur du tableau.

    • Si vous souhaitez convertir un texte en tableau, sélectionnez l'option Convertir un texte en tableau. Cette fonctionnalité peut être utile lorsque vous avez déjà du texte que vous souhaitez organiser dans un tableau. La fenêtre Convertir un texte en tableau comprend 3 sections :

      Convertir un texte en tableau

      • Taille du tableau. Choisissez le nombre de colonnes/lignes nécessaires pour répartir le texte. Vous pouvez utiliser les flèches vers le haut/le bas ou saisir le nombre à l'aide du clavier.
      • Comportement de l'ajustement automatique. Cochez l'option nécessaire pour définir la façon dont le texte est ajusté : Largeur de colonne fixe (défini sur Auto par défaut. Vous pouvez utiliser les boutons fléchés vers le haut/le bas ou saisir le nombre manuellement au clavier), Ajuster au contenu (la largeur de la colonne correspond à la longueur du texte), Ajuster à la fenêtre (la largeur de la colonne correspond à la largeur de la page).
      • Séparer le texte au niveau de. Cochez l'option nécessaire pour définir le délimiteur du texte : Paragraphes, Tabulation, Points-virgules et Autre (saisissez manuellement le délimiteur souhaité).
      • Cliquez sur OK pour convertir le texte en tableau.
    • Si vous souhaitez insérer un tableau en tant qu'objet OLE :

      1. Sélectionnez l'option Insérer une feuille de calcul.

      2. Dans la fenêtre qui s'affiche, vous pouvez saisir les données nécessaires et les mettre en forme à l'aide des outils de mise en forme de l'éditeur de classeurs tels que la sélection de la police, du type et du style, la sélection du format de nombre, l'insertion de fonctions, la mise en forme des tableaux, etc.

        Tableau OLE

      3. L'en-tête inclut le bouton Zone visible Zone visible dans le coin supérieur droit de la fenêtre. Sélectionnez l'option Modifier la zone visible pour définir la zone à afficher lors de l'insertion de l'objet dans le document ; les autres données ne sont pas perdues, elles sont simplement masquées. Cliquez sur Terminé pour valider.

      4. Cliquez sur le bouton Afficher la zone visible pour voir la zone sélectionnée, qui sera entourée d'une bordure bleue.

      5. Une fois terminé, cliquez sur le bouton Enregistrer et quitter.

  5. une fois le tableau ajouté, vous pouvez modifier ses propriétés, sa taille et sa position.

Pour redimensionner un tableau, placez le pointeur de la souris sur la poignée Poignée de redimensionnement dans son coin inférieur droit et faites-la glisser jusqu'à ce que le tableau atteigne la taille souhaitée.

Redimensionner un tableau

Vous pouvez également modifier manuellement la largeur d'une colonne ou la hauteur d'une ligne. Placez le pointeur de la souris sur la bordure droite de la colonne jusqu'à ce que le pointeur devienne la flèche bidirectionnelle Modifier la largeur de colonne et faites glisser la bordure vers la gauche ou la droite pour régler la largeur nécessaire. Pour modifier manuellement la hauteur d'une ligne, placez le pointeur de la souris sur la bordure inférieure de la ligne jusqu'à ce que le pointeur devienne la flèche bidirectionnelle Modifier la hauteur de ligne et faites glisser la bordure vers le haut ou vers le bas.

Pour déplacer un tableau, maintenez enfoncée la poignée Poignée de déplacement dans son coin supérieur gauche et faites-la glisser vers l'endroit nécessaire dans le document.

Il est également possible d'ajouter une légende au tableau. Pour en savoir plus sur l'utilisation des légendes avec des tableaux, veuillez consulter cet article.

Sélectionner un tableau ou un fragment du tableau​

Pour sélectionner un tableau entier, cliquez sur la poignée Poignée de déplacement dans son coin supérieur gauche.

Pour sélectionner une cellule, déplacez le pointeur de la souris à gauche de la cellule nécessaire jusqu'à ce que le pointeur devienne la flèche noire Sélectionner la cellule, ensuite faites un clic gauche.

Pour sélectionner une ligne, déplacez le pointeur de la souris vers la bordure gauche du tableau à côté de la ligne nécessaire jusqu'à ce que le pointeur devienne la flèche noire horizontale Sélectionner la ligne, ensuite faites un clic gauche.

Pour sélectionner une colonne, déplacez le pointeur de la souris vers la bordure supérieure de la colonne nécessaire jusqu'à ce que le pointeur devienne la flèche noire vers le bas Sélectionner la colonne, ensuite faites un clic gauche.

Il est également possible de sélectionner une cellule, une ligne, une colonne ou un tableau en utilisant les options du menu contextuel ou à partir de la section Lignes et colonnes de la barre latérale droite.

remarque

Pour vous déplacer dans un tableau, vous pouvez utiliser les raccourcis clavier.

Régler les paramètres du tableau​

Il est possible de modifier certaines propriétés et la structure du tableau à partir du menu contextuel. Les options du menu sont les suivantes :

  • Couper, Copier, Coller - les options standard qui servent à couper ou copier le texte/l'objet sélectionné et à coller un passage de texte ou un objet précédemment coupé/copié à la position actuelle du curseur.

  • Sélectionner permet de sélectionner une ligne, une colonne, une cellule ou un tableau.

  • Insérer permet d'insérer une ligne au-dessus ou en dessous de la ligne où se trouve le curseur ainsi que d'insérer une colonne à gauche ou à droite de la colonne où se trouve le curseur.

    Il est également possible d'insérer plusieurs lignes ou colonnes. Lorsque l'option Plusieurs lignes/colonnes est sélectionnée, la fenêtre Insérer plusieurs apparaît. Sélectionnez Lignes ou Colonnes dans la liste, spécifiez le nombre de lignes/colonnes que vous souhaitez insérer et l'endroit où les insérer : Au-dessus du curseur ou Au-dessous du curseur, et cliquez sur OK.

  • Supprimer sert à supprimer une ligne, une colonne, un tableau ou des cellules. Lorsque l'option Cellules est sélectionnée, la fenêtre Supprimer les cellules s'affiche, dans laquelle vous pouvez choisir parmi les options : Décaler les cellules vers la gauche, Supprimer la ligne entière ou Supprimer la colonne entière.

  • Fusionner les cellules est disponible lorsque deux ou plusieurs cellules sont sélectionnées et sert à les fusionner.

    Il est aussi possible de fusionner des cellules en effaçant la bordure qui les sépare à l'aide de l'outil gomme. Pour ce faire, cliquez sur l'icône Tableau Tableau dans la barre d'outils supérieure et sélectionnez l'option Effacer le tableau. Le pointeur de la souris se transforme en gomme Gomme. Placez le pointeur de la souris sur la bordure séparant les cellules que vous souhaitez fusionner et effacez-la.

  • Fractionner la cellule... sert à ouvrir la fenêtre où vous pouvez sélectionner le nombre de colonnes et de lignes en lesquelles la cellule doit être divisée.

    Il est également possible de fractionner une cellule en dessinant des lignes ou des colonnes à l'aide de l'outil crayon. Pour ce faire, cliquez sur l'icône Tableau Tableau dans la barre d'outils supérieure et sélectionnez l'option Dessiner un tableau. Le pointeur de la souris se transforme en crayon Crayon. Tracez un trait horizontal pour créer une ligne ou un trait vertical pour créer une colonne.

  • Distribuer les lignes sert à ajuster les cellules sélectionnées afin qu'elles aient la même hauteur sans changer la hauteur globale du tableau.

  • Distribuer les colonnes sert à ajuster les cellules sélectionnées afin qu'elles aient la même largeur sans modifier la largeur globale du tableau.

  • Alignement vertical de cellule sert à aligner le texte en haut, au centre ou en bas de la cellule sélectionnée.

  • Orientation du texte sert à modifier l'orientation du texte dans une cellule. Vous pouvez placer le texte horizontalement, verticalement de haut en bas (Rotation du texte vers le bas), ou verticalement de bas en haut (Rotation du texte vers le haut).

  • Paramètres avancés du tableau sert à ouvrir la fenêtre 'Tableau - Paramètres avancés'.

  • Lien hypertexte sert à insérer un lien hypertexte.

  • Paramètres avancés du paragraphe sert à ouvrir la fenêtre 'Paragraphe - Paramètres avancés'.

Vous pouvez également modifier les propriétés du tableau à partir de la barre latérale droite :

Barre latérale droite - Paramètres du tableau

  • Lignes et Colonnes servent à sélectionner les parties du tableau à mettre en surbrillance.

    Pour les lignes :

    • En-tête - pour mettre en surbrillance la première ligne
    • Total - pour mettre en surbrillance la dernière ligne
    • À bandes - pour mettre en surbrillance une ligne sur deux

    Pour les colonnes :

    • Premier - pour mettre en surbrillance la première colonne
    • Dernier - pour mettre en surbrillance la dernière colonne
    • À bandes - pour mettre en surbrillance une colonne sur deux
  • Sélectionner à partir d'un modèle sert à choisir un modèle de tableau parmi ceux qui sont disponibles.

  • Style des bordures sert à sélectionner la taille, la couleur et le style des bordures ainsi que la couleur d'arrière-plan.

  • Lignes et colonnes sert à effectuer certaines opérations avec le tableau : sélectionner, supprimer, insérer des lignes et des colonnes, fusionner des cellules, fractionner une cellule.

  • Taille des lignes et des colonnes sert à ajuster la largeur et la hauteur de la cellule actuellement sélectionnée. Dans cette section, vous pouvez également Distribuer les lignes afin que toutes les cellules sélectionnées aient la même hauteur ou Distribuer les colonnes afin que toutes les cellules sélectionnées aient la même largeur.

  • Ajouter une formule permet d'insérer une formule dans la cellule de tableau sélectionnée.

  • Répéter en haut de chaque page en tant que ligne d'en-tête sert à insérer la même ligne d'en-tête en haut de chaque page dans les tableaux longs.

  • Convertir un tableau en texte sert à organiser le tableau sous forme de texte brut. La fenêtre Convertir un tableau en texte permet de définir le délimiteur pour la conversion : Marques de paragraphes, Tabulation, Points-virgules et Autre (saisissez manuellement le délimiteur souhaité). Le texte de chaque cellule du tableau est considéré comme un élément séparé et unique du texte résultant.

  • Afficher les paramètres avancés sert à ouvrir la fenêtre 'Tableau - Paramètres avancés'.

Configurer les paramètres avancés du tableau​

Pour modifier les paramètres avancés du tableau, cliquez sur le tableau avec le bouton droit de la souris et sélectionnez l'option Paramètres avancés du tableau dans le menu contextuel ou utilisez le lien Afficher les paramètres avancés sur la barre latérale droite. La fenêtre des paramètres du tableau s'affiche :

Tableau - Paramètres avancés

L'onglet Tableau permet de modifier les paramètres du tableau entier.

  • La section Taille du tableau contient les paramètres suivants :
    • Largeur - par défaut, la largeur du tableau est ajustée automatiquement à la largeur de la page, c.-à-d. le tableau occupe tout l'espace entre la marge gauche et la marge droite de la page. Vous pouvez cocher cette case et spécifier la largeur du tableau manuellement.

    • Mesure en permet de définir la largeur du tableau en unités absolues, c.-à-d. Centimètres/Points/Pouces (selon l'option choisie dans l'onglet Fichier -> Paramètres avancés...) ou en Pourcentage de la largeur totale de la page.

      remarque

      Vous pouvez aussi ajuster la taille du tableau manuellement en changeant la hauteur des lignes et la largeur des colonnes. Placez le pointeur de la souris sur la bordure d'une ligne/colonne jusqu'à ce qu'il se transforme en flèche bidirectionnelle et faites glisser la bordure. Vous pouvez aussi utiliser les marqueurs Marqueur de largeur de colonne sur la règle horizontale pour changer la largeur de la colonne et les marqueurs Marqueur de hauteur de ligne sur la règle verticale pour modifier la hauteur de la ligne.

    • Redimensionner automatiquement pour ajuster au contenu - permet de changer automatiquement la largeur de chaque colonne selon le texte dans ses cellules.

  • La section Marges des cellules par défaut permet de changer l'espace entre le texte dans les cellules et la bordure de la cellule utilisé par défaut.
  • La section Options permet de modifier le paramètre suivant :
    • Espacement entre les cellules - l'espacement des cellules qui sera rempli par la couleur de l'Arrière-plan de tableau.

Tableau - Paramètres avancés

L'onglet Cellule permet de modifier les propriétés de chaque cellule. Il vous faut d'abord sélectionner la cellule nécessaire ou sélectionner le tableau entier pour modifier les propriétés de toutes ses cellules.

  • La section Taille de la cellule contient les paramètres suivants :

    • Largeur préférée - permet de définir la largeur préférée de la cellule. C'est la taille à laquelle la cellule essaie de correspondre, mais dans certains cas il n'est pas possible de s'adapter à cette valeur exacte. Par exemple, si le texte dans une cellule dépasse la largeur spécifiée, il sera renvoyé à la ligne suivante de sorte que la largeur préférée de la cellule reste inchangée, mais si vous insérez une nouvelle colonne, la largeur préférée sera réduite.

    • Mesure en - permet de définir la largeur de la cellule en unités absolues, c.-à-d. Centimètres/Points/Pouces (selon l'option choisie dans l'onglet Fichier -> Paramètres avancés...) ou en Pourcentage de la largeur totale du tableau.

      remarque

      Vous pouvez aussi définir la largeur de la cellule manuellement. Pour rendre une cellule plus large ou plus étroite que la largeur globale de la colonne, sélectionnez la cellule nécessaire et placez le pointeur de la souris sur sa bordure droite jusqu'à ce qu'il se transforme en flèche bidirectionnelle, puis faites glisser la bordure. Pour modifier la largeur de toutes les cellules d'une colonne, utilisez les marqueurs Marqueur de largeur de colonne sur la règle horizontale pour modifier la largeur de la colonne.

  • La section Marges de la cellule permet d'ajuster l'espace entre le texte dans les cellules et la bordure de la cellule. Par défaut, les valeurs standard sont utilisées (les valeurs par défaut peuvent également être modifiées dans l'onglet Tableau), mais vous pouvez décocher la case Utiliser marges par défaut et saisir les valeurs nécessaires manuellement.

  • La section Options de la cellule permet de modifier le paramètre suivant :

    • L'option Envelopper le texte est activée par défaut. Elle permet de renvoyer à la ligne suivante le texte d'une cellule qui dépasse sa largeur, en agrandissant la hauteur de la ligne et en gardant la largeur de la colonne inchangée.

Tableau - Paramètres avancés

L'onglet Bordures et arrière-plan contient les paramètres suivants :

  • Les paramètres de la Bordure (taille, couleur, présence ou absence) - définissez la taille de la bordure, sélectionnez sa couleur et choisissez la façon dont elle s'affiche dans les cellules.

    remarque

    Si vous choisissez de ne pas afficher les bordures du tableau en cliquant sur le bouton Aucune bordure ou en désactivant toutes les bordures manuellement sur le diagramme, les bordures seront indiquées par une ligne pointillée dans le document. Pour les faire disparaître complètement, cliquez sur l'icône Caractères non imprimables Caractères non imprimables sous l'onglet Accueil de la barre d'outils supérieure et sélectionnez l'option Bordures de tableau masquées.

  • Arrière-plan de cellule - la couleur d'arrière-plan des cellules (disponible uniquement si une ou plusieurs cellules sont sélectionnées ou si l'option Espacement entre les cellules est sélectionnée dans l'onglet Tableau).

  • Arrière-plan de tableau - la couleur d'arrière-plan du tableau ou de l'espacement entre les cellules dans le cas où l'option Espacement entre les cellules est sélectionnée dans l'onglet Tableau.

Position du tableau​

Tableau - Paramètres avancés

L'onglet Position du tableau est disponible uniquement si l'option Tableau flottant sous l'onglet Habillage du texte est sélectionnée et contient les paramètres suivants :

  • Les paramètres Horizontal permettent de régler l'alignement du tableau (à gauche, au centre, à droite) par rapport à la marge, la page ou le texte ainsi que sa position à droite de la marge, la page ou le texte.
  • Les paramètres Vertical permettent de régler l'alignement du tableau (en haut, au centre, en bas) par rapport à la marge, la page ou le texte ainsi que sa position en dessous de la marge, la page ou le texte.
  • La section Options permet de modifier les paramètres suivants :
    • Déplacer l'objet avec le texte garantit que le tableau se déplace avec le texte.
    • Autoriser le chevauchement sert à déterminer si deux tableaux sont fusionnés en un seul grand tableau ou se chevauchent si vous les faites glisser l'un près de l'autre sur la page.

Tableau - Paramètres avancés

L'onglet Habillage du texte contient les paramètres suivants :

  • Style d'habillage du texte - Tableau aligné ou Tableau flottant. Utilisez l'option nécessaire pour changer la façon de positionner le tableau par rapport au texte : soit il fait partie du texte (si vous avez choisi le tableau aligné), soit il est entouré par le texte de tous les côtés (si vous avez choisi le tableau flottant).
  • Une fois le style d'habillage sélectionné, les paramètres d'habillage supplémentaires peuvent être définis pour les tableaux alignés et flottants :
    • Pour un tableau aligné, vous pouvez définir l'alignement du tableau et le retrait à gauche.
    • Pour un tableau flottant, vous pouvez définir la distance du texte et la position du tableau sous l'onglet Position du tableau.

Tableau - Paramètres avancés

L'onglet Texte de remplacement permet de spécifier un Titre et une Description qui seront lus aux personnes avec des déficiences cognitives ou visuelles pour les aider à mieux comprendre le contenu du tableau.

Autoriser le fractionnement des lignes sur plusieurs pages​

Lorsque vous travaillez avec des tableaux qui s'étendent sur plusieurs pages dans l'éditeur de documents, vous pouvez définir si les lignes du tableau peuvent être fractionnées au niveau d'un saut de page.

Pour configurer ce paramètre :

  1. Cliquez à l'intérieur du tableau ou sélectionnez les lignes à modifier.
  2. Dans la barre latérale droite, ouvrez le panneau des paramètres du tableau en cliquant sur l'icône Paramètres du tableau Tableau.
  3. Cochez ou décochez l'option Autoriser le fractionnement des lignes sur plusieurs pages.

Lorsque cette option est activée, une ligne qui dépasse le bas de la page en cours est fractionnée au niveau du saut de page. La première partie de la ligne reste au bas de la page en cours et le reste du contenu se poursuit en haut de la page suivante.

Lorsque cette option est désactivée, la ligne n'est pas fractionnée. La ligne entière est déplacée en haut de la page suivante, ce qui peut laisser un espace supplémentaire au bas de la page précédente.