Aller au contenu principal

Activer IA dans Docs

Activer l'IA dans Docs​

ONLYOFFICE vous permet de connecter des modèles d'IA et de les utiliser directement dans les éditeurs. L'onglet Outils IA donne accès à toutes les fonctionnalités IA, et vous pouvez associer des tâches spécifiques à différents modèles selon leurs capacités.

remarque

Les outils IA sont intégrés aux éditeurs, vous n'avez donc pas besoin d'installer de module complémentaire. Toutefois, pour des raisons de sécurité, aucun modèle d'IA n'est connecté par défaut. Pour commencer à utiliser les fonctionnalités IA, connectez un modèle de votre choix comme décrit ci-dessous.

Si l'onglet Outils IA n'est pas affiché dans la barre d'outils supérieure, accédez à l'onglet Modules complémentaires, cliquez sur Plugins en arrière-plan et assurez-vous que le commutateur Outils IA est activé.

Onglet Outils IA

Étape 1. Connecter un modèle d'IA​

Vous pouvez connecter un modèle d'un fournisseur d'IA à l'aide d'une clé API, ou un modèle hébergé localement. Il existe deux endroits où vous pouvez le faire : la fenêtre Paramètres IA et le panneau Chat IA.

Via la fenêtre Paramètres IA

  1. Accédez à l'onglet Outils IA et cliquez sur Paramètres. La fenêtre Paramètres IA s'ouvre sur l'onglet Modèles IA.
  2. Cliquez sur Ajouter un modèle.
  3. Sélectionnez un Fournisseur et saisissez votre clé API.
  4. Cliquez de nouveau sur Ajouter un modèle pour enregistrer le modèle.

Ajout d'un modèle d'IA dans la fenêtre Paramètres IA

Via le panneau Chat IA

  1. Accédez à l'onglet Outils IA et cliquez sur Chat IA. Le panneau Chat IA s'ouvre à droite.
  2. Si aucun modèle n'est encore connecté, le panneau vous invite à en connecter un. Sélectionnez un Fournisseur et saisissez votre clé API.
  3. Cliquez sur Ajouter un modèle.

Connexion d'un modèle d'IA dans le panneau Chat IA

Dans les deux cas, vous n'avez que deux champs à remplir : Fournisseur et Clé API. Les autres champs sont renseignés automatiquement.

  • Fournisseur — sélectionnez un fournisseur d'IA dans la liste. Pour utiliser un fournisseur qui ne figure pas dans la liste, cliquez sur Importer un fournisseur personnalisé.
  • Clé API — saisissez la clé API que vous avez reçue de votre fournisseur. Si vous n'en avez pas, cliquez sur le lien Obtenir une clé API pour ouvrir la page de création de clé du fournisseur sélectionné.
  • URL de base — renseignée automatiquement lorsque vous sélectionnez un fournisseur. Ne la modifiez que si vous utilisez un fournisseur personnalisé ou un modèle hébergé localement.
  • Modèle — cette liste n'est pas disponible tant que vous n'avez pas saisi une clé API valide. Une fois la clé acceptée, un modèle est sélectionné automatiquement. Vous pouvez en choisir un autre dans la liste.
  • Nom du profil — renseigné automatiquement. Vous pouvez le remplacer par le nom de votre choix.

Si la clé API n'est pas valide, un message d'erreur s'affiche sous le champ Clé API et le bouton Ajouter un modèle reste indisponible. Vérifiez la clé et saisissez-la de nouveau.

Étape 2. Associer des modèles aux tâches​

Une fois votre modèle connecté, associez-le à des tâches :

  1. Accédez à l'onglet Outils IA et cliquez sur Paramètres.
  2. Passez à l'onglet Attribution des modèles.
  3. Sélectionnez un modèle pour chaque tâche. Si vous avez connecté plusieurs modèles, vous pouvez utiliser un modèle différent pour chaque tâche.
remarque

Tous les modèles ne prennent pas en charge toutes les tâches. Si vous associez un modèle à une tâche qu'il ne prend pas en charge, des erreurs peuvent se produire.

Association de modèles d'IA aux tâches

La fenêtre Paramètres IA comporte également les onglets Serveurs MCP et Recherche web, où vous pouvez connecter des serveurs MCP et configurer la recherche web pour votre assistant IA.

Étape 3. Utiliser l'IA​

Vous pouvez maintenant utiliser les fonctionnalités IA en sélectionnant les options correspondantes dans l'onglet Outils IA :

  • Chat IA — posez des questions sur votre document, générez un nouveau texte ou améliorez le contenu existant.
  • Créer une action IA rapide — créez votre propre action avec une invite personnalisée et ajoutez-la à la barre d'outils.
  • Synthèse — résumez de longs passages de texte.
  • Traduction — traduisez le texte sélectionné dans la langue de votre choix.
  • Créer un assistant IA — configurez un assistant pour vos propres tâches.
  • Afficher tous les résultats — consultez les résultats générés par l'IA.
  • Grammaire et orthographe — vérifiez votre texte et passez en revue les corrections proposées.

Pour en savoir plus sur les fonctionnalités IA disponibles, reportez-vous à la section Guides d'utilisation de l'IA.

Utiliser l'IA pour travailler avec les macros​

Avertissement

Le code est traité par un service d'IA de votre choix. Des fuites de données ou des modifications inattendues du code peuvent se produire. ONLYOFFICE décline toute responsabilité quant aux complétions pouvant contenir des erreurs ou des omissions, ainsi qu'aux contenus offensants ou inappropriés. Les informations contenues dans les complétions sont générées par un service d'IA choisi par l'utilisateur et sont fournies « en l'état », sans filtrage supplémentaire de la part d'ONLYOFFICE.

L'IA peut vous aider à créer et à convertir des macros. Pour accéder à ces fonctionnalités :

  1. Accédez à l'onglet Affichage et cliquez sur le bouton Macros de la barre d'outils supérieure. La fenêtre Macros s'ouvre.

  2. Cliquez sur le bouton IA dans le coin supérieur gauche de la fenêtre et sélectionnez l'une des options :

    • Créer à partir d'une description — décrivez ce que la macro doit faire, et votre assistant IA la générera.
    • Convertir depuis VBA — collez votre code VBA dans la fenêtre Convertir les macros depuis VBA, et il sera converti en macro.
remarque

Si vous n'avez pas encore configuré votre assistant IA, vous serez invité à le faire. Suivez l'Étape 1 et l'Étape 2 de ce guide pour le configurer.

Pour en savoir plus sur les macros, veuillez consulter notre documentation de l'API.