Artículos con :
Cerrar
Changelog
Cerrar
Centro de ayuda
Desktop Editors

How to connect Desktop Editors to your Nextcloud or ownCloud server?

Desktop Editorsv.5.2 Desktop Editors changelog

Version 5.2.8

Release date: 01/18/2019

Fixes

All Editors

  • Major bugfix for interaction with Nextcloud and ownCloud portals.

Version 5.2.4

Release date: 12/21/2018

New features

All editors

  • Added Polish as a new interface language;
  • Added an option to change the user interface language;
  • Added an option to change the user name;
  • Improved HiDPI screens detection;
  • Extended the list of providers for collaboration portals (ownCloud, Nextcloud);
  • Added encryption options (developer preview version);
  • Added a warning when opening a file protected with password;
  • The resolved comments are now not shown by default in Document Editor and Spreadsheet Editor;
  • Added the possibility to customize availability of help in the editor;
  • Added the display of the File and Plugins tabs for viewers;
  • The username is now highlihgted by color in the comments, review changes, chat messages;
  • Prevented the duplication of online users in the left chat panel;
  • Added the possibility to sort comments in the popover by ascending creation time.

Document Editor

  • Added the possibility to work with bookmarks;
  • Added the possibility to add/change hyperlinks anchored to bookmarks/headings;
  • Added the possibility to change numbering value, start/continue numbering;
  • Added settings for content controls (highlighting and appearance);
  • Review changes and comments are now displayed in the combined window;
  • Added presets for А0, А1, А2, А6 page size (bug #36583);
  • Enabled closing the chart dialog while loading (bug #36870);
  • Changed the encoding format for the TXT files (bug #36998);
  • Added the mode for filling forms;
  • Enabled closing the window when saving to TXT format;
  • Enabled inserting shapes when a shape is selected;
  • The new revisions are now checked in the Fast co-editing mode.

Spreadsheet Editor

  • Added the cell settings in the right panel;
  • Added the Layout tab;
  • Added the hint for autofilters;
  • Added the possibility to change the encoding format for CSV files (bug #36998);
  • Enabled saving page options to a file before printing;
  • Added the possibility to view combo charts;
  • Enhanced the application due to the completely rewritten scroll;
  • Added support of R1C1 references style.

Presentation Editor

  • Added hints to presentation themes (bug #21362);
  • Added the presenter preview in the viewer (bug #37499);
  • Enabled closing the chart dialog while loading (bug #36870).

Fixes

All editors

  • Updated translations;
  • Fixed the position for the zoom buttons in the toolbar;
  • Fixed the File tab which had lost active state when the inner panels had been clicked;
  • Fixed the Replace image by URL context menu option (bug #37651);
  • Fixed the possibility to copy the comments from the comment balloon (bug #37666, #35896);
  • Fixed the footnote dialog layout (bug #37660);
  • Fixed the JavaScript error which occurred when the autoshape connector was changed (bug #37788);
  • Fixed the error which occurred when the default tab in a shape was changed (bug #38084);
  • Fixed the issues with opening a custom color for shapes (bug #37841);
  • Fixed the issue when comments from other users were missing (bug #37570);
  • Fixed the bug with CFF fonts (glyph loader);
  • Fixed the Cannot read property '$icon' of undefined error when using the Ctrl+S keyboard shortcut in chart editor (bug #39254);
  • Removed the Command+H keyboard shortcut used for Mac OS;
  • Fixed the issue with special paste icon when inserting ClipArt (bug #39462);
  • Added the display of conversion error in case a PDF had been renamed to DOCX;
  • Fixed the bug with a solid fill without a color;
  • Fixed the issue with opening the presenter view on ownCloud\Nextcloud (bug #39559);
  • Fixed the bug when a new font was applied (current font name and new name are empty);
  • Fixed a lot of bugs in the files in all supported formats received from the users.

Document Editor

  • Fixed getting the parent cell in blocklevelstd;
  • Fixed the chinese text justification (bug #37659, DocumentServer issue #293);
  • Fixed the setting for the Real-time collaboration changes option when View All is selected;
  • Fixed the window layout issue with a protected document (bug #37658);
  • Disabled bookmarks in the document headers (bug #38957);
  • Fixed the issue with opening a DOCX file with track changes and calculations created by Aspose;
  • Fixed the problem with reading the ID of a content control;
  • Fixed the crash in CNumberingLvlLegacy.ReadFromBinary;
  • Fixed the problem with table selection;
  • Fixed the problem with replacing a misspelled word with another;
  • Fixed the critical issue which occurred when the document had been locked on the undo in the Fast collaboration mode;
  • Fixed the missing Hide Degree menu entry for equations (bug #39135);
  • Fixed the problem which occurred when recalculations were made in co-editing;
  • Fixed the problem with processing the pageDown button in co-editing;
  • Fixed the Cannot read property 'eb' of nul error which occurred when a table column was deleted (bug #39252);
  • Fixed the problem with rendering which occurred when replacing the text (bug #39269);
  • Fixed the problem with saving/loading the table state on undo/redo;
  • Fixed the issue with displaying the chart added with macros (bug #39304);
  • Fixed the problem with calculating large tables separated by columns;
  • Fixed the error which occurred after the selection of the font name in combo box was discarded;
  • Fixed the inputs for Korean, Chinese and Japanese characters in content control (bug #39724);
  • Fixed the problem with recalculating large tables in a document;
  • Fixed the problem with accepting/rejecting uncalculated revision changes;
  • Fixed the bug with recalculating a document when a section was deleted;
  • Fixed the problem which occurred when complex fields in selection were checked;
  • Fixed the problem with updating cursor position in collaborative editing;
  • Fixed the bug with moving cursor through a table;
  • Fixed the problem with moving an image inside a large table;
  • Fixed the problem with updating the current position in table after accepting changes;
  • Fixed the bug with special paste of paragraph with numbering;
  • Fixed the issues with reading comments in RTF format files;
  • Fixed the bug with opening a file containing image in a shape (bug #37902).

Spreadsheet Editor

  • Fixed the issue with entering the functions with the arrow keys and scrolling;
  • Fixed the multiselect autofit column width, now autofit will affect existing columns only (bug #37555);
  • Fixed the function dependency and file generation after copying with drag and drop;
  • Fixed the Out of memory error when inserting rows to the file with many columns;
  • Fixed the error occurring for chart with an empty dataset (bug #37762);
  • Fixed the issues with comment deleting (bug #37772);
  • Fixed the issues with opening XLSX files received from users (bug #38113);
  • Fixed the hyphen position for Сhinese symbols with wrapping;
  • Fixed the missing translation for the functions into French and Spanish;
  • Fixed the missing region formats;
  • Disabled the table settings when the cell is edited;
  • Fixed the issue which occurred when the active cell in selection across merge was merged;
  • Fixed the issue with the selection which occurred when selecting a row/column/all;
  • The options for hiding headings, gridlines, freeze panes are hidden in the viewer (bug #38033);
  • Fixed the issue with the comments being lost after reopening an XLSX file (bug #37892) (DocumentServer issue #316);
  • Fixed the issue with opening a file with an unknown image format;
  • Fixed problems with files containing combo charts (bug #37945, #37946);
  • Fixed the crash which occurred when a file was built with comment changes;
  • Fixed the issue when an incorrect chart was added to the area with autofilter (bug #39168);
  • Fixed the issue with the incorrectly selected cells when a formula was changed using the keyboard (bug #39181);
  • Fixed the issue when the browser hung on some files with formulas (bug #39190);
  • Fixed the incorrect display of doughnut chart with autofilter (bug #39200);
  • Fixed the incorrect IF function values (bug #39233);
  • Fixed the problem with the number of replacements made (bug #39273);
  • Fixed the Cannot read property 'Zb' of null which occurred when trying to copy a shape deleted by another user (bug #39312);
  • Fixed the this.dPc is not a function which occurred during the data sorting (bug #39397);
  • Fixed the issues with undo applied to the filter in specific files (bug #39402);
  • Fixed the scroll to end of the table issue (bug #21946);
  • Fixed the issue with sorting of the first row in some files (bug #39397);
  • Fixed the issue with the sorting range if filtered data was present in it (bug #39410);
  • Fixed the double columns borders display issue (bug #39392);
  • Fixed the issue with rendering of the last rows in some files (bug #39394);
  • Disabled the cell settings when editor is disconnected;
  • Fixed the issues with printing and calculation; sped up cache preparation;
  • Fixed the issues with scrolling in some files (bug #39395);
  • Fixed the issue with data loss in the second table sheet (bug #39511);
  • Fixed the issue when the editor was freezing after consequent use of cut and paste for several columns (bug #37965);
  • Fixed the incorrect sum function for the copied sheet (bug #39548);
  • Fixed the JavaScript error which occurred when more data than cell width is entered (bug #39623);
  • Fixed the incorrect digit counting when using the Decrease Decimal option (bug #39661);
  • Fixed the issue with opening file with si and formula parameters used without ref;
  • Fixed the issue which occurred when some files with chart are opened (bug #39902);
  • Fixed the JavaScript error which occurred when specific sheet was copied to file during co-editing (bug #39921).

Presentation Editor

  • Fixed the issue with deleting the placholder text in strict co-editing mode (bug #37712);
  • Fixed the issue with the comment duplication in exported PPTX (bug #37698);
  • Fixed the JavaScript error occurring when opening an empty presentation in the comment mode (bug #37679);
  • Fixed the issue with copying and pasting the text into the 'Slide Title' placeholder in Fast co-editing mode (bug #37922);
  • Fixed the bug with copying and pasting a slide containing a picture (bug #37928);
  • Fixed the issue with placeholder titles in Chinese (bug #37927) (onlyoffice-owncloud issue #189);
  • Fixed the Cannot read property 'Ia' of null error which occurred when some PPTX files were opened (bug #39191);
  • Fixed the problem with negative spacing;
  • Fixed the Cannot read property 'W' of undefined error which occurred when copying a table (bug #39264);
  • Fixed the issue with opening some PPT files (bug #39901).

Backend

  • Updated the compatibilityMode setting now preventing opening the files in MS Word 2016 compatibility mode;
  • Fixed the issues which occurred when opening some DOC, RTF and XLS files received from users;
  • Fixed the export of the current list from XLSX to CSV (bug #37579);
  • Fixed the issues which occurred when opening specific PPTX files (bug #37589);
  • Fixed the issues which occurred when opening specific RTF files (bug #37500);
  • Fixed the issue with saving comments for presentation;
  • Fixed the issues with slide themes when exporting to ODT (bug #37740);
  • Fixed the issues with chart legend in ODS files (bug #37746);
  • Fixed the issue when an empty RTF file was opened (bug #39172);
  • Fixed the problems with opening of some ODS files (bug #39192);
  • Fixed the conversion to raster for graphiscs on linux without set fonts;
  • Fixed the binary conversion of mathType version over 3.0 with PptxFormat component;
  • Fixed the problems with the document structure for specific files (bug #39236);
  • Fixed the issue which occurred when opening in some resulting files in MS Word (bug #39216);
  • Fixed the problems with opening specific DOCX files (bug #39248);
  • Fixed the problems with opening of some RTF files (bug #39315);
  • Fixed the row selection issue in PDF files (bug #39214);
  • Fixed the loss of grouped autoshapes in ODT (bug #39467);
  • Fixed the issue with conversion of some WMF files (bug #39533);
  • Fixed the bug with metadata in UTF-16 format;
  • Fixed the issue with conversion of some XLS files (bug #39541);
  • Fixed the issue with conversion of some VML files with drawing_ml markup;
  • Refactoring of auto shapes for OdfFormat;
  • Fixed the bug with calculating an inverse matrix in PDF.

Version 5.1.27

Release date: 05/23/2018

New features

All editors

  • Added the new View Settings menu option at the top right corner of the editor window;
  • Added the possibility to replace the image via context menu (bug #11493);
  • Updated translations;
  • Added the new no-squares font engine, which finds the best replacement font for the characters;
  • Added the possibility to distribute the data in tables;
  • Completely rewritten the composite input for characters;
  • Added the new header and background color;
  • Added the support of shape side panel for images;
  • Added the support for changing the table size using drag'n'drop;
  • Added the new bullet list marker: ;
  • Increased the document supported size (without media content).

Document Editor

  • Implemented the East Asian script and line break in hieroglyphs support (sdkjs issue #300);
  • Added the Ctrl+Shift+Num8 hotkey to show/hide nonprinting characters;
  • Added the support of multiple comments display in the comment balloon (bug #37422);
  • Added the support for the Table of Contents;
  • Added the possibility to set the Tab leading symbols;
  • Added the new Navigation left sidebar item;
  • Added the new References tab;
  • Fixed the issue when version history could not be saved if the second user joined the co-editing in the Strict mode; now it is saved if the first user has autosaving disabled;
  • Renamed the Display Modes entries for Track Changes option;
  • Changed the behavior of the Go to documents option, it now opens a new tab;
  • Added the possibility to set negative values for the top and bottom page margins;
  • Copying the paragraph style will not overwrite the custom set style;
  • Added the special paste of tables.

Spreadsheet Editor

  • Added the translation of functions into French;
  • Added the translation of functions and their descriptions into Spanish;
  • Added the possibility to select the cell format via context menu (bug #16272);
  • Custom user cell styles are now placed before the default ones;
  • Added the new functions: F.TEST, FORECAST.ETS, FORECAST.ETS.CONFINT, FORECAST.ETS.SEASONALITY, FORECAST.ETS.STAT, FORMULATEXT, IFS, PDURATION, CONVERT, FTEST, HYPGEOM.DIST;
  • Added the new None table template;
  • Added the new regional presets: Deutsch (Schweiz), Español (México), Nederlands (Nederland), Slovenčina (Slovenská republika);
  • Added the new date formats: yy/m/d, yy/mm/dd, yyyy/m/d;
  • Added the preview for the CSV files before opening them;
  • Added the new selector for link type.

Presentation Editor

  • Added hints for presentation themes (bug #21362);
  • Added the special paste;
  • Added the presentation level comments;
  • Added the new selector for link type.

Backend

  • Updated the ICU dependency version from 5.5 to 6.0;
  • Added the support for a lot of features for XLS format (macros, controls, etc.);
  • 5-10% speedup of opening OOXML files;
  • Better compatibility with OpenFormat and RTF;
  • Fixed a lot of bugs in the files in all supported formats received from the users.

Documentation

  • New documentation articles describing the 5.1 version new features;
  • Added the translation of the documentation for Document Editor and Presentation Editor into French, Spanish, German, for Spreadsheet Editor into French;
  • Added search in the documentation pages.

Fixes

All editors

  • Fixed the crash on opening the files with empty pie charts (sdkjs issue #318);
  • Fixed the undo error occurring after copy/paste in co-editing (bug #37424);
  • Fix problems with some Thai symbols (bug #37446) (sdkjs issue #297);
  • The fonts with the zero width of the glyphs are now hidden from the font picker;
  • The changes for undo/redo are not saved in server build mode;
  • Changed the size of the images pasted from HTML;
  • Fixed the problem with the text selection when using the Shift key;
  • Fixed the redundant symbol appearing in cells after undo-redo operation (bug #37343);
  • Fixed the problems with the icons of some buttons;
  • Fixed the synchronization of the co-editing mode between the top toolbar button and the menu (bug #37377);
  • Fixed the toolbar icons problems.

Document Editor

  • Fixed the issue with the table display after HTML conversion (bug #37472);
  • Fixed the bug which occurred when a comment was added to the whole document (bug #37425, DocumentServer issue #287, sdkjs issue #319);
  • Fixed the issue with copying the Rich Text Content from a table (bug #37546) (sdkjs issue #320);
  • Replaced the content control GetTag method used with the GetLabel one (sdkjs issue #296);
  • Fixed the issue with searching the text in drawings (sdkjs issue #292);
  • Fixed the problem with loading a PDF file which has been renamed to DOCX (sdkjs issue #295);
  • Fixed the right-mouse button menu for the table of contents (#37241);
  • The images in Text Art objects are not clipped;
  • Added the vertical clip for drawing the inline objects;
  • Fixed the problems with drawing the inline objects;
  • Fixed the bug with wrong calculation of the text clip rectangle.

Spreadsheet Editor

  • Fixed the issues with the function dependencies and file assembly after adding a column or row (sdkjs issue #312);
  • Fixed the issues with opening some XSLX files (bug #37515) (sdkjs issue #316);
  • Fixed the issue with opening the pivot tables which contain VALUES (sdkjs issue #298);
  • Fixed the right mouse button error (bug #37330);
  • Fixed the issue occurring when hieroglyphs from the text editor were inserted (bug #37356);
  • Fixed the bug occurring when autocomplete did not work for functions if the point character is present in function name (bug #37300);
  • Fixed the bug occurring when autocomplete did not work for functions if the _ or \ character are used in the named range (bug #37354);
  • Fixed the bug occurring when autocomplete did not work for functions if Chinese numbers were used;
  • Fixed the issues with sheet context menu visibility (bug #37307);
  • Fixed the translations for functions;
  • Fixed the problems with inserting the function into the cell which is opened for editing (bug #37348).

Presentation Editor

  • Fixed the problem with hieroglyphs in chart title (bug #37293);
  • Fixed the chart title focusing problem during co-editing (bug #37295);
  • Fixed the object selection problem during co-editing (bug #37336);
  • Fixed the bug with clearing the cached canvas;
  • Fixed the bug with calculation of slide layout bounds.

Backend

  • Fixed the issues which occurred in some user files containing tables (core issue #71);
  • Fixed the issues with opening DOCX, PPTX, RTF, and ODF files received from users (core issue #75 and core issue #76);
  • Fixed the Mac OS related build problems;
  • Fixed the shape geometry occurring in PPT files from the latest MS Office versions;
  • Fixed the font generation;
  • Fixed the issue which occurred when reopening files containing macros (bug #37323);
  • Fixed the issues which occurred when opening some DOCX and XLS files received from users.

Version 4.8.7

Release date: 02/14/2018

New features

All editors

  • Added support for the two-factor authentication;
  • Added Brazilian Portuguese as a new interface language.

Spreadsheet Editor

  • Added strikeout, superscript and subscript options to the top toolbar (bug #26581).

Fixes

All editors

  • Updated translations.

Document Editor

  • Fixed the issue with opening DOCX file containing formula in MS Word (bug #36490);
  • Fixed the JavaScript error which occurred while inserting a spreadsheet cell with comment (bug #36506);
  • Fixed the bug with inserting the content control into a math equation;
  • Fixed the selection from object in header/footer not being reset after keyboard move.

Spreadsheet Editor

  • Fixed the wrong dependence in some functions with references to other sheets which occurred after a sheet was removed;
  • Fixed the issue with opening an ODT file containing a chart;
  • Fixed the issue with calculating a sparkline in some cases (bug #36603);
  • Fixed the issue with printing an image outside of the printing range (bug #36573).

Presentation Editor

  • Fixed the issue with blocking the shape for the users co-editing in different modes (bug #36435);
  • Fixed the issue with the Constant proportions chart button working only once (bug #36494);
  • Fixed the JavaScript error which occurred while inserting a page number from Document Editor (bug #36508);
  • Fixed the JavaScript error which occurred while undoing a table (bug #36515).

Conversion

  • Fixed the issues with some DOCX, DOC, RTF files from the users;
  • Fixed the issues with MathType equations in some DOCX files (bug #36524).

Version 4.8.0

Release date: 12/23/2017

New features

All editors

  • New preinstalled plugin set;
  • Added the support for SSO authorization at the portals;
  • Added Czech and Slovak as new interface languages;
  • Added the support for macros;
  • Added the support for FODS, FODT, FODP formats.

Fixes

All editors

  • Fixed the bug with image paths.

Document Editor

  • Fixed the JavaScript error which occurred when inserting an empty cell to the chart title (bug #36441);
  • Fixed the red cross issue with the images in some situations;
  • Fixed the bug with the synchronization of data from several dialog windows;
  • Fixed the line ending in thumbnails;
  • Fixed the issues with pasting the simple text to equations;
  • Fixed the cursor issues with object rotation (bug #36114);
  • Fixed issues with opening some DOCX files (bug #35307);
  • Fixed the issue with the chart legend being blocked during co-editing (bug #35492);
  • Fixed issues when the tab was set several times (bug #34923);
  • Fixed printing in Microsoft Edge (bug #35323);
  • Fixed the documentation on moving the shape by a pixel (bug #34983);
  • Fixed the special paste in fast co-editing mode (bug #35310);
  • Fixed issues with duplicates in strict co-editing mode after the special paste (bug #35312);
  • Fixed bug with moving the cursor to the beginning of the document after removing the content control;
  • Fixed minor problems with co-editing in real time (bugs #35398, #35399, #35400);
  • A lot of fixes in the existing translations.

Spreadsheet Editor

  • Fixed the a.Se is not a function error while opening some files (bug #36344);
  • Fixed the error with merged table colors;
  • Fixed the cell merging after a table template is applied (bug #36405);
  • Fixed the JavaScript error for some pivot table styles (bug #36290);
  • Checked the xfIndexNumber when merging styles to avoid the errors with column styles;
  • Fixed the conditional formatting while changing cell values (bug #36253);
  • Fixed the issue with the shape size not changing with the help of yellow markers (bug #35451);
  • Fixed the VLOOKUP and HLOOKUP functions being case sensitive (bug #35528, DocumentServer#140);
  • Fixed the Show empty cells as box in Russian (bug #35299);
  • Fixed the sparkline type in the settings window (bug #35296);
  • Fixed the JavaScript error in the conditional formatting with the function and offset (duplicate variable) (bug #35334);
  • Fixed the JavaScript error in SEARCH function (bug #35340);
  • Fixed the freeze pane shadow which had not been hiding (bug #35359);
  • Fixed showing the hidden objects;
  • Fixed the VLOOKUP cell format;
  • A lot of fixes in the existing translations.

Presentation Editor

  • Fixed the issue with the button layout in the reporter mode;
  • Disabled the scroll to target function in selectwheel (when the selection is empty);
  • Fixed applying the image as a background for several slides (bug #36399);
  • Fixed the mouse slide scroll without the zoom change (bug #28096);
  • Fixed disabling the Previous/Next buttons during the slide demonstration;
  • Fixed the presentation demonstration issue appearing when starting from the beginning;
  • Fixed the issue with scrolling the notes;
  • Fixed the text insert operation duration (bug #36208);
  • Fixed the browser zoom problem with the pointer;
  • Fixed the reporter mode resizing in Microsoft IE;
  • Fixed the bug with positioning the hyperlink and slide number tooltips;
  • Fixed the slide resizing bug;
  • Fixed the issue with the text search in a placeholder (bug #36133);
  • Fixed the layout problem in the reporter mode;
  • Fixed the JavaScript error in Tables_test.pptx file (bug #17147);
  • Fixed the comment bug (bug #35408);
  • Fixed the bug with drag-and-dropping the chart into a title;
  • Fixed changing the presentation language if no shape was selected (bug #35231);
  • Fixed the columns in the placeholder (bug #35074);
  • Fixed the connector losing shape when moving shapes in a group (bug #35317);
  • Fixed the hidden markers for the connector on a chart and an image (bug #35300);
  • Fixed the cell link reference issue after the copy-paste operation (bug #35362, DocumentServer#122);
  • A lot of fixes in the existing translations.

Plugins

  • Fixed crashes when resizing an unknown OLE object;
  • Fixed the problems with scrolling.

Conversion

  • Fixed the colors schemes for table cells (bug #36322);
  • Fixed the problem with the images in footnote (bug #36380);
  • Fixed saving some files to ODT (bug #35389);
  • Fixed the custom shape for the connectors in XLS;
  • Fixed the issue with margins in ODS;
  • Fixed the converted named range with the formulas in ODS;
  • Fixed the audio WAV files in PPTX;
  • Fixed the old OLE standard in PPTX.

Version 4.4.1

Release date: 07/12/2017

New features

Document Editor

  • Added the Special Paste feature;
  • Added the rich text content support;
  • Added translations for the paragraph styles;
  • Added the comments display in the view mode;
  • Added the option to hide the resolved comments;
  • Added the option to specify custom columns.

Spreadsheet Editor

  • Added the support for the functions with conditional formatting;
  • Added the possibility to specify a custom delimiter for the CSV file import/export;
  • Added support for the ACOT, ACOTH, ARABIC, BASE, BETA.DIST, BETA.INV, BETADIST, BINOM.DIST, BINOM.INV, CEILING.MATH, CEILING.PRECISE, CHIDIST, CHIINV, CHISQ.DIST, CHISQ.DIST.RT, CHISQ.INV, CHISQ.INV.RT, COMBINA, CONCAT, CONFIDENCE.NORM, CONFIDENCE.T, COT, COTH, CSC, CSCH, DECIMAL, EXPON.DIST, F.DIST, F.DIST.RT, F.INV, F.INV.RT, FDIST, FINV, FLOOR.MATH, FLOOR.PRECISE, GAMMA, GAMMA.DIST, GAMMA.INV, GAMMA.PRECISE, GAMMADIST, GAMMAINV, GAUSS, IFNA, IMCOSH, IMCOT, IMCSC, IMCSCH, IMSEC, IMSECH, IMSINH, IMTAN, ISO.CEILING, LOGNORM.DIST, LOGNORM.INV, NUMBERVALUE, PERCENTILE.EXC, PERCENTILE.INC, PERCENTRANK.EXC, PERCENTRANK.INC, RANK, RANK.AVG, RANK.EQ, SEC, SECH, T.DIST, T.DIST.2T, T.DIST.RT, T.INV, T.INV.2T, TDIST, TINV, XOR functions;
  • The hidden rows are now excluded from copying, autofilling, formatting etc.;
  • Updated the active cell color;
  • Changed the frozen pane display: now it has shadow;
  • Added translations for the cell styles;
  • Added the possibility to search and replace using the data from the selection;
  • Added the option to hide the resolved comments;
  • Added the possibitity to specify bullets and numbering for the text within a shape;
  • Added the possibility to specify columns for the text areas;
  • Added the possibility to add the connectors for the shapes;
  • Added the support for Shift+Delete, Ctrl+Insert and Shift+Insert keyboard shortcuts for cut/paste operations.

Presentation Editor

  • Added the possibility to connect shapes using the lines;
  • Added the possibility to specify columns for the text areas;
  • Added the possibitity to specify bullets and numbering for the text within a shape;
  • Added the spellchecker;
  • Added the possibitity to download the file as ODP.

Plugins

  • Added the new plugin window type (without borders, shadows, buttons).

x2t

  • Dramatically increased the speed for opening the OOXML files: 200% faster in Windows, 20% faster in Linux;
  • Enhanced the conversion from/to RTF format;
  • Enhanced support for password protected OOXML and binary Microsoft files (DOC, XLS);
  • Added support for password protected PPT files.

Fixes

Spreadsheet Editor

Version 4.3.2

Release date: 04/13/2017

New features

All editors

  • Added full support of high-DPI monitors;
  • Added the possibility to set alternative text for shapes.

Document Editor

  • Added the undo option for the Fast co-editing mode;
  • Added the All changes saved caption in the bottom toolbar;
  • Added an option to add and edit footnotes;
  • Added new languages for spellchecker (43 in total).

Spreadsheet Editor

  • Added support for the AVERAGEIFS, COUNTIFS, SUMIFS functions;
  • Refactoring and improvements for formulas;
  • Added a totally new Cell Format window with more options;
  • Added the possibility to use sort options window while sorting ranges;
  • Added the sorting direction for the filter buttons;
  • Added the filter condition at statistical information;
  • Added the special paste feature;
  • Added the support for the surface chart;
  • Added the new cell border styles (11 in total).

Presentation Editor

  • Added the undo option for the Fast co-editing mode.

Conversion

  • Optimization and speed-up;
  • Better support for all formats, including (but not limited to) the ones listed below:

    DOC

    • Support for the page backgrounds.

    XLS

    • Support for data validation;
    • Support for decryption.

    ODF

    • Support for global document settings;
    • SVG refactoring;
    • Support for the page backgrounds (image, pattern, gradient);
    • Support for the smart art conversion;
    • Support for sheet/workbook views;
    • Support OLE and other embedded objects conversion.

    RTF

    • Added hyperlink text replacement generation if it is absent;
    • Added support for office digital signatures;
    • Added extended drawings;
    • Added custom shapes;
    • Added support for the text when drawing shapes.

Fixes

Document Editor

  • Fixed the issue with drag'n'dropping a table inside a footnote (bug #33548);
  • Fixed the issue with cropping of shape group (bug #33110).

Spreadsheet Editor

  • Fixed the issue with the absolute reference when inserting a new row (ONLYOFFICE/DocumentServer#41);
  • Fixed the issue with the onDocumentStateChange event (ONLYOFFICE/DocumentServer#88);
  • Fixed the issue with the formula translations (ONLYOFFICE/DesktopEditors#23);
  • Fixed the issue with the password-protected XLSX (ONLYOFFICE/DesktopEditors#24);
  • Fixed the issue with a non-breaking space (ONLYOFFICE/DesktopEditors#26);
  • Fixed the issue with the AVERAGEA function which has text format;
  • Fixed the issue with the broken workbook after copying the list (bug #33588);
  • Fixed the issue with the formula recalculation by F4 hotkey (bug #32901);
  • Fixed the issue with SUMIFS function (bug #33602);
  • Fixed the issue with the image size when inserting (bug #33604);
  • Fixed the issue with the sparkline zero values (bug #33612);
  • Fixed the issue with changing the number format when changing the regional format (bug #31395);
  • Fixed the issue with replacing the formula delimiters (bug #33608);
  • Fixed the issue with cell size while drag'n'dropping (bug #33607);
  • Fixed the issue with the cursor size in @2x resolution (bug #33606);
  • Fixed the error when the files got broken if you tried to change the style of an unsupported chart (bug #34650);
  • Fixed the stack error while copying a big array of formula data;
  • Fixed the error of rendering a 3D diagram in a small area (bug #34632);
  • Fixed the error when chart range was changed while applying a preset.
  • Many other minor and major bugfixes.

Version 4.2.2

Release date: 02/16/2017

Fixes

All Editors

  • Prevent editors from performing the save operation if there are no changes to save.
  • Fixed a rare problem occurring when saving a file with a specific chart type.
  • Fixed the problems with copy-paste functions.

Document Editor

  • Fixed the problem with the changes missing when several users enter the text at the same time (bug #33726)
  • Fixed the bug with the cursor positioning after the InsertContent function is used.

Spreadsheet Editor

  • Fixed the wrong order of elements in equations (bug #34029).
  • Fixed entering the characters with diacritical symbols (bug #33908)
  • Fixed the horizontal scroll when using a trackpad (bug #27197)
  • Fixed error occurring when assembling files with Ranges in some rare cases.
  • Fixed errors occurring when converting from the XLSX to the CSV format.
  • Fixed the Match formula return value in some cases (bug #33735)

Presentation Editor

  • Fixed a problem occurring when saving a file with the notes copied from Document Editor;
  • Fixed a problem occurring when saving a file with a chart copied from Presentation Editor.

Version 4.2.1

Release date: 12/20/2016

New Features

All Editors

  • Added the possibility to set a dash type for shapes;
  • Better support of HiDPI systems.

Document Editor

  • Added the possibility to open and edit footnotes;
  • Ability to insert number of pages into the document;
  • Remade version history. Added the possibility to hide minor features.

Spreadsheet Editor

  • Added the possibility to insert equations in Spreadsheet Editor;
  • Added the possibility to open and edit sparklines;
  • Added a new SUMIFS function;
  • Added the possibility to select data from the drop-down menu in the context menu;
  • Added a multiselection support;
  • Added the rotation of 3D charts;
  • Updated and improved the visual styles for all chart types;
  • Brought back the Freeze Panes option in the View Settings menu;
  • Added the new algorithm for calculating a cell height.

Presentation Editor

  • Added the possibility to insert equations in Presentation Editor.

Fixes

Document Editor

  • Fixed the broken Insert number of pages button;
  • Fixed the problem with the last hieroglyph duplicate;
  • Fixed the problem with changing the chart type from 2D to 3D.

Spreadsheet Editor

  • Fixed the problem with an empty cell when changing sparklines.

x2t

  • Improved compatibility with the DOC format.

ONLYOFFICE suite allows you to edit the files stored in your Nextcloud/ownCloud account and collaborate on them using both online and desktop ONLYOFFICE editors. Thereby, you can use not only online collaboration tools, but also the features available in your desktop application only. To take full advantage of all these editing options you’ll need to install and configure several components:

  1. It's supposed that you already have a Nextcloud/ownClowd server instance installed and configured. If not, you can refer to the Nextcloud or ownCloud official installation instructions.
  2. Install ONLYOFFICE Document Server. Please note that Nextcloud/ownCloud server and ONLYOFFICE Document Server must be accessible to each other over the network.
  3. Enable our official integration app in the Nextcloud/ownCloud administrator account.
    One of the easiest ways to install and configure all the components at once (Document Server, Nextcloud/ownCloud server and the integration app) is to use our Docker installation. You can refer to the corresponding instructions for Nextcloud and for ownCloud.
  4. Connect your Nextcloud/ownCloud server to ONLYOFFICE Desktop Editors.

An Internet connection is required for connecting your Nextcloud/ownCloud server, as well as for real-time co-editing.

Step 1. Install Document Server

The easiest way to install Document Server is to use Docker. Execute the following command:

sudo docker run -i -t -d -p 80:80 --restart=always onlyoffice/documentserver

If you want to install Document Server on the same machine where your Nextcloud/ownCloud server is installed, you’ll need to change the default port used by Document Server (both Document Server and Nextcloud/ownCloud work on port 80 by default).

When installing Document Server using Docker, you can easily change the mapping port with the following command:

sudo docker run -i -t -d -p <PORT_NUMBER>:80 --restart=always onlyoffice/documentserver

Where <PORT_NUMBER> is the number of port you want Document Server to use.

To find more detailed instructions on how to install Document Server using Docker, you can refer to this article.

To make sure that Document Server is installed successfully, enter the IP address and, optionally, port (if it has been changed during the installation) in your browser address bar, e.g. http://192.168.3.202:81 - the Document Server welcome page should open.

Step 2. Install ONLYOFFICE integration connector

For Nextcloud

In your Nextcloud account, click your user name in the upper-right corner and choose the Apps option in the menu. In the Nextcloud app store, select the Office & text application category in the list on the left. Find the ONLYOFFICE connector and click the Enable button.

Click your user name in the upper-right corner and choose the Settings option in the menu. Click the ONLYOFFICE item in the left-side menu to open the ONLYOFFICE application settings page.

For ownCloud

In your ownCloud account, click the icon in the upper-left corner and choose the Market option in the menu. In the ownCloud app market, select the Tools application category in the list on the left. Find the ONLYOFFICE connector and click the Install button.

Click your user name in the upper-right corner and choose the Settings option in the menu. Click the Additional item in the Admin section of the left-side menu. The ONLYOFFICE application settings page should open.

Configuring the integration app for both Nextcloud and ownCloud

When the connector is installed, you need to configure it. On the ONLYOFFICE application settings page, specify the address of the machine where the Document Server is installed in the Document Editing Service address field. If you’ve changed the port during the installation, do not forget to specify it, e.g. http://192.168.3.202:81. Click the Save button to apply the settings.

To find out more details on configuring the integration app you can refer to corresponding articles for Nextcloud and for ownCloud.

Step 3. Connect to Nextcloud/ownCloud server

Launch ONLYOFFICE Desktop Editors. To connect Desktop Editors to your Nextcloud or ownCloud server, perform the following actions:

  1. Switch to the Connect to cloud section at the left side panel.
  2. Click the necessary cloud service button. The following three options are available: ONLYOFFICE, Nextcloud, ownCloud. Alternatively, you can use the Connect now link at the bottom.
    Connect to cloud tab Connect to cloud tab
  3. If you pressed the corresponding service button, the Connect to cloud office window opens with the Nextcloud/ownCloud selected. If you used the Connect now link, choose the necessary cloud storage from the drop-down list.
    • in the Cloud office URL field, enter your Nextcloud/ownCloud server domain name or IP address. When ready, click the Connect now button.
      Connect to cloud office window Connect to cloud office window
    • The Nextcloud/ownCloud sign in page will open in a new tab of the Desktop Editors interface.

      • Specify your Username or email and the Password you use to access your Nextcloud/ownCloud account,
      • Click the Log in button.
      Connect to cloud office window Connect to cloud office window

The Files section of your Nextcloud/ownCloud account will open. Now you can edit your existing files and create new ones, share your documents and collaborate on them with Nextcloud/ownCloud users using ONLYOFFICE editors.

Step 4. Manage your connected accounts

Click the logo in the upper left corner of the Desktop Editors interface to return to the main program window, then switch to the Connect to cloud section to view the Connected clouds list. Right-click on a connected cloud office and use one of the available contextual menu options:

  • Open - to switch to the corresponding cloud storage tab, if you are already logged in to this account, or to open the Connect to cloud office window, if you are not currently logged in (in such a case, you will need to enter your credentials),
  • Logout - to exit from your account,
    You can also click the Exit icon icon to the right of the account to exit from it.
  • Remove from list - to disconnect the selected account and remove it from the list.

If you have several accounts or clouds, use the Add cloud button to connect one more account.

Connected accounts list Connected accounts list
Download No more Microsoft All main platforms support:
Windows, Linux and Mac OS
También le podría gustar:
Cerrar