Skip to main content

Keyboard shortcuts

Keyboard shortcuts for key tips​

Use keyboard shortcuts for a faster and easier access to the features of the Spreadsheet Editor without using a mouse.

  1. Press Alt (Option for macOS) key to turn on all key tips for the editor header, the top toolbar, the right and left sidebars and the status bar.

  2. Press the letter that corresponds to the item you wish to use. The additional key tips may appear depending on the key you press. The first key tips hide when additional key tips appear.

    For example, to access the Insert tab, press Alt (Option for macOS) to see all primary key tips.

    Primary Key Tips

    Press letter I to access the Insert tab, and you will see all the available shortcuts for this tab.

    Secondary Key Tips

    Then press the letter that corresponds to the item you wish to configure.

  3. Press Alt (Option for macOS) to hide all key tips, or press Escape to go back to the previous group of key tips.

Find the most common keyboard shortcuts in the list below. If there is no shortcut for the action you require, please refer to the Using macros article to learn how to create a macro for that. Choose your operating system in any group: the choice applies to the whole page.

note

For macOS, some shortcuts contain the Home, End, Page Up and Page Down keys which are only available on the extended keyboard. If you don't have these keys, use the keyboard shortcuts specified above (i.e. use ^ Ctrl/⌘ Cmd+← or Fn+← instead of Home, ^ Ctrl/⌘ Cmd+→ or Fn+→ instead of End, Fn+↑ instead of Page Up, Fn+↓ instead of Page Down).

Working with Spreadsheet​

ActionShortcutDescription
Open 'File' panelAlt+FOpen the File panel to save, download, print the current spreadsheet, view its info, create a new spreadsheet or open an existing one, access the help menu of the Spreadsheet Editor or its advanced settings.
Open 'Find' dialog windowCtrl+FOpen the Find dialog window to start searching for a cell containing the required characters.
Open 'Find and Replace' menu (panel) with replacement fieldCtrl+HOpen the Find and Replace menu (panel) with the replacement field to replace one or more occurrences of the found characters.
Open 'Comments' panelCtrl+⇧ Shift+HOpen the Comments panel to add your own comment or reply to other users' comments.
Open comment fieldAlt+HOpen a data entry field where you can add the text of your comment.
Open 'Chat' panel (Online Editors)Alt+QOpen the Chat panel in the Online Editors and send a message.
Save spreadsheetCtrl+SSave all the changes to the spreadsheet currently edited with the Spreadsheet Editor. The active file will be saved with its current file name, location, and file format.
Print spreadsheetCtrl+PPrint your spreadsheet with one of the available printers or save it to a file.
Download as...Ctrl+⇧ Shift+SOpen the Download as... panel to save the currently edited spreadsheet to the computer hard disk drive in one of the supported formats: XLSX, XLTX, PDF, PDF/A, ODS, OTS, CSV, PNG, JPG.
Full screen (Online Editors)F11Switch to the full screen view in the Online Editors to fit the Spreadsheet Editor on the screen.
Help menuF1Open the Help menu of the Spreadsheet Editor.
Open existing fileCtrl+OOpen the standard dialog box that allows selecting an existing file. If you select the file in this dialog box and click Open, the file will be opened in a new tab or window of Desktop Editors.
Switch to the next tabCtrl+↹ TabSwitch to the next file tab in Desktop Editors or browser tab in Online Editors.
Switch to the previous tabCtrl+⇧ Shift+↹ TabSwitch to the previous file tab in Desktop Editors or browser tab in Online Editors.
Close fileCtrl+W, Ctrl+F4Close the current spreadsheet window.
Element contextual menu⇧ Shift+F10Open the contextual menu of the selected element.
Close menu or modal window, reset modes, etc.EscClose a menu or modal window. Suspend copying formats. Reset adding shapes mode. Clear clipboard when cutting/copying cells. Hide the Paste Special button.
Reset the ‘Zoom’ parameterCtrl+0Reset the ‘Zoom’ parameter of the current spreadsheet to a default 100%.
Duplicate a worksheetPress and hold down Ctrl + drag the sheet tabCopy an entire worksheet in a workbook and move it to the tab location you need.
Enable screen reader transmissionCtrl+Alt+ZEnables/disables the transmission of actions performed in the application for screen readers.
ActionShortcutDescription
Move one cell up, down, left, or right↑ ↓ ← →Outline a cell above/below the currently selected one, or to the left/to the right of it.
Move active cell down↵ EnterMove to the cell below.
Move active cell up⇧ Shift+↵ EnterMove to the cell above.
Move active cell to the right↹ TabMove to the cell on the right.
Move active cell to the left⇧ Shift+↹ TabMove to the cell on the left.
Jump to the edge of the visible data region or the next cell with dataCtrl+← → ↑ ↓Outline a cell at the edge of the visible data region or the next cell with data in a worksheet. If the region does not contain data, the last cell of the visible area will be selected. If the region contains data, the next cell with data will be selected.
Jump to the beginning of the rowHomeOutline a cell in the column A of the current row.
Jump to the beginning of the spreadsheetCtrl+HomeOutline the cell A1.
Jump to the end of the rowEnd, Ctrl+→Outline the last cell of the current row.
Jump to the end of the spreadsheetCtrl+EndOutline the lower right used cell in the worksheet situated in the bottommost row with data from the rightmost column with data. If the cursor is in the formula bar, it will be placed to the end of the text.
Move to the previous sheetAlt+Page UpMove to the previous sheet in your spreadsheet.
Move to the next sheetAlt+Page DownMove to the next sheet in your spreadsheet.
Move up one row↑, ⇧ Shift+↵ EnterOutline the cell above the current one in the same column.
Move down one row↓, ↵ EnterOutline the cell below the current one in the same column.
Move left one column←, ⇧ Shift+↹ TabOutline the previous cell of the current row.
Move right one column→, ↹ TabOutline the next cell of the current row.
Move down one screenPage DownMove one screen down in the worksheet.
Move up one screenPage UpMove one screen up in the worksheet.
Move vertical scrollbar Up/DownMouse scroll Up/DownMove vertical scrollbar up/down.
Move horizontal scrollbar Left/Right⇧ Shift+Mouse scroll Up/DownMove horizontal scrollbar left/right. To move the scrollbar to the right, scroll the mouse wheel down. To move the scrollbar to the left, scroll the mouse wheel up.
Zoom InCtrl++Zoom in the currently edited spreadsheet.
Zoom OutCtrl+-Zoom out the currently edited spreadsheet.
Navigate between controls in modal dialogues↹ Tab/⇧ Shift+↹ TabNavigate between controls to give focus to the next or previous control in modal dialogues.

Data Selection​

ActionShortcutDescription
Select the entire worksheetCtrl+A, Ctrl+⇧ Shift+␣ SpacebarSelect the entire worksheet (when the focus is on a cell).
Select columnCtrl+␣ SpacebarSelect an entire column in a worksheet.
Select row⇧ Shift+␣ SpacebarSelect an entire row in a worksheet.
Select one cell to the right⇧ Shift+→Select one cell to the right.
Select one cell to the left⇧ Shift+←Select one cell to the left.
Select one cell up⇧ Shift+↑Select one cell up.
Select one cell down⇧ Shift+↓Select one cell down.
Select from cursor to beginning of row⇧ Shift+HomeSelect a fragment from the cursor to the beginning of the current row.
Select from cursor to end of row⇧ Shift+EndSelect a fragment from the cursor to the end of the current row.
Select to the next nonblank cell to the rightCtrl+⇧ Shift+→Select cells to the next nonblank cell to the right of the active cell or to the edge of the visible area.
Select to the next nonblank cell to the leftCtrl+⇧ Shift+←Select cells to the next nonblank cell to the left of the active cell or to the edge of the visible area.
Select to the next nonblank cell upCtrl+⇧ Shift+↑Select cells to the next nonblank cell up from the active cell or to the edge of the visible area.
Select to the next nonblank cell downCtrl+⇧ Shift+↓Select cells to the next nonblank cell down from the active cell or to the edge of the visible area.
Extend the selection to beginning of worksheetCtrl+⇧ Shift+HomeSelect a fragment from the current selected cells to the beginning of the worksheet.
Extend the selection to the last used cellCtrl+⇧ Shift+EndSelect a fragment from the current selected cells to the last used cell in the worksheet (in the bottommost row with data of the rightmost column with data). If the cursor is in the formula bar, this will select all text in the formula bar from the cursor position to the end without affecting the height of the formula bar.
Extend the selection to the nearest nonblank cell to the right⇧ Shift+End, Ctrl+⇧ Shift+→Extend the selection to the nearest nonblank cell in the same row to the right of the active cell. If the next cell is blank, the selection will be extended to the next nonblank cell.
Extend the selection to the nonblank cell to the leftCtrl+⇧ Shift+←Extend the selection to the nonblank cell to the left.
Extend the selection to the first column⇧ Shift+HomeExtend the selection to the first column (A).
Extend the selection to the nearest nonblank cell up/down the columnCtrl+⇧ Shift+↑ ↓Extend the selection to the nearest nonblank cell in the same column up/down from the active cell. If the next cell is blank, the selection will be extended to the next nonblank cell.
Extend the selection down one screen⇧ Shift+Page DownExtend the selection to include all the cells one screen down from the active cell. All cells in the columns of the previously selected range will be selected.
Extend the selection up one screen⇧ Shift+Page UpExtend the selection to include all the cells one screen up from the active cell. All cells in the columns of the previously selected range will be selected.

Undo and Redo​

ActionShortcutDescription
UndoCtrl+ZReverse the latest performed action.
RedoCtrl+YRepeat the latest undone action.

Cut, Copy, and Paste​

ActionShortcutDescription
CutCtrl+X, ⇧ Shift+DeleteCut the selected data/graphics and send them to the computer clipboard memory. The cut data can be later inserted to another place in the same worksheet, into another spreadsheet, or into some other program.
CopyCtrl+C, Ctrl+InsertSend the selected data/graphics to the computer clipboard memory. The copied data can be later inserted to another place in the same worksheet, into another spreadsheet, or into some other program.
PasteCtrl+V, ⇧ Shift+InsertInsert the previously copied/cut data/graphics from the computer clipboard memory to the current cursor position. The data can be previously copied from the same worksheet, from another spreadsheet, or from some other program.

Paste Special options​

ActionShortcutDescription
Paste only formulaCtrl then FPaste formulas without pasting the data formatting.
Paste formula + number formatCtrl then OPaste formulas with the formatting applied to numbers.
Paste formula + all formattingCtrl then KPaste formulas with all the data formatting.
Paste formula without bordersCtrl then BPaste formulas with all the data formatting except the cell borders.
Paste formula + column widthCtrl then WPaste formulas with all the data formatting and set the source column's width for the cell range.
TransposeCtrl then TPaste data switching them from columns to rows, or vice versa. This option is available for regular data ranges, but not for formatted tables.
Paste only valueCtrl then VPaste the formula results without pasting the data formatting.
Paste value + number formatCtrl then APaste the formula results with the formatting applied to numbers.
Paste value + all formattingCtrl then EPaste the formula results with all the data formatting.
Paste only formattingCtrl then RPaste the cell formatting only without pasting the cell contents.
Paste linkCtrl then NPaste the external link to a cell or range of cells in another spreadsheet within the current portal (in the online editor) or in a local file (in the desktop editor).
note

Paste the copied data using Ctrl+V on Windows or Cmd+V on macOS. After pasting the copied data, use the Ctrl key to open the Paste Special menu, then press the letter key which corresponds to the necessary option.

ActionShortcutDescription
Insert hyperlinkCtrl+KInsert a hyperlink which can be used to go to a web address.
Visit hyperlink↵ EnterVisit a hyperlink (with the cursor in the hyperlink).

Data Formatting​

ActionShortcutDescription
BoldCtrl+BMake the font of the selected text fragment darker and heavier than normal, or remove the bold formatting.
ItalicCtrl+IMake the font of the selected text fragment italicized and slightly slanted, or remove italic formatting.
UnderlineCtrl+UMake the selected text fragment underlined with a line going under the letters, or remove underlining.
StrikeoutCtrl+5Make the selected text fragment struck out with a line going through the letters, or remove strikeout formatting.
Edit active cellF2Edit the active cell and position the insertion point at the end of the cell contents. If editing in a cell is turned off, the insertion point will be moved into the Formula Bar.

Data Filtering​

ActionShortcutDescription
Enable/Remove FilterCtrl+⇧ Shift+LEnable a filter for a selected cell range, or remove the filter.
Open filter windowAlt+↓In the header of a column with a filter, open the filter window.
Format as table templateCtrl+LApply a table template to a selected cell range.

Data Entry​

ActionShortcutDescription
Complete cell entry and move down↵ EnterComplete a cell entry in the selected cell or the formula bar, and move to the cell below.
Complete cell entry and move up⇧ Shift+↵ EnterComplete a cell entry in the selected cell, and move to the cell above.
Complete cell entry and move to the right↹ TabComplete a cell entry in the selected cell or the formula bar and move to the cell on the right.
Complete cell entry and move to the left⇧ Shift+↹ TabComplete a cell entry in the selected cell or the formula bar and move to the cell on the left.
Complete cell entry and stay in itCtrl+⇧ Shift+↵ Enter, Ctrl+↵ EnterComplete a cell entry in the selected cell or the formula bar and stay in it.
Fill the selected cell range with the current entryCtrl+↵ EnterFill the selected cell range with the current entry. Select a cell range, type data to the active cell, and press the specified keys to fill all the selected cells with entered data.
Start new lineAlt+↵ EnterStart a new line in the same cell.
Add new placeholder to equation argument↵ EnterAdd a new placeholder to the equation argument.
CancelEscCancel an entry in the selected cell or the formula bar.
Delete to the left← BackspaceDelete one character to the left in the formula bar or in the selected cell when the cell editing mode is activated. Remove the selection. Also removes the content of the active cell. It is also applicable to text in graphical objects.
Delete to the rightDeleteDelete one character to the right in the formula bar or in the selected cell when the cell editing mode is activated. Remove the selection. Also removes the cell contents (data and formulas) from selected cells without affecting cell formats or comments. It is also applicable to text in graphical objects.
Clear active cell contentDelete, ← BackspaceRemove the content (data and formulas) from the active cell without affecting the cell format or comments.
Clear content of all selected cellsDeleteRemove the content (data and formulas) from all selected cells without affecting the cell format or comments.
Insert cellsCtrl+⇧ Shift+=Open the dialog box for inserting new cells within the current spreadsheet with an added parameter of a shift to the right, a shift down, inserting an entire row or an entire column.
Delete cellsCtrl+⇧ Shift+-Open the dialog box for deleting cells within the current spreadsheet with an added parameter of a shift to the left, a shift up, deleting an entire row or an entire column.
Insert the current dateCtrl+;Insert the today date within an active cell.
Insert the current timeCtrl+⇧ Shift+;Insert the current time within an active cell.
Insert the current date and timeCtrl+; then ␣ Spacebar then Ctrl+⇧ Shift+;Insert the current date and time within an active cell.
Insert separatorNum.Insert a separator within an active cell.
Auto Fill (Open drop-down list)Alt+↓Use this shortcut in an empty cell below or above existing values in the column. A drop-down list with existing values will appear. Select one of the available text values to fill an empty cell.
Insert an en dashCtrl+⇧ Shift+-Insert an en dash ‘-’ within the currently edited shape and to the right of the cursor. Works with shapes only.

Working with text in cells and graphical objects​

ActionShortcutDescription
Remove word, selection to the leftCtrl+← BackspaceRemove a word, selection to the left of the cursor.
Remove word, selection to the rightCtrl+DeleteRemove a word, selection to the right of the cursor.
Select allCtrl+ASelect the entire shape content (when the cursor is within the shape content). Select the entire cell content (when the cursor is within the cell).
Move one character to the left/right or one line up/down← → ↑ ↓Move the cursor one character to the left/right or one line up/down.
Select one character to the right⇧ Shift+→Select one character to the right of the cursor position.
Select one character to the left⇧ Shift+←Select one character to the left of the cursor position.
Move the cursor one word to the leftCtrl+←Move the cursor one word to the left.
Move the cursor one word to the rightCtrl+→Move the cursor one word to the right.
Select one word to the leftCtrl+⇧ Shift+←Select one word to the left of the cursor.
Select one word to the rightCtrl+⇧ Shift+→Select one word to the right of the cursor.
Jump to the beginning of the textCtrl+HomePut the cursor to the very beginning of the text in a cell or shape.
Jump to the end of the textCtrl+EndPut the cursor to the very end of the text in a cell or shape.
Select from cursor to beginning of textCtrl+⇧ Shift+HomeSelect a text fragment from the cursor to the beginning of the text in a cell or shape.
Select from cursor to end of textCtrl+⇧ Shift+EndSelect a text fragment from the cursor to the end of the text in a cell or shape.
Jump to the beginning of the lineHomePut the cursor to the beginning of the currently edited line.
Jump to the end of the lineEndPut the cursor to the end of the currently edited line.
Select from cursor to beginning of line⇧ Shift+HomeSelect a text fragment from the cursor to the beginning of the current line.
Select from cursor to end of line⇧ Shift+EndSelect a text fragment from the cursor to the end of the current line.
Select one line up⇧ Shift+↑Move the cursor one line up, selecting all symbols between the previous and current cursor position.
Select one line down⇧ Shift+↓Move the cursor one line down, selecting all symbols between the previous and current cursor position.

Pivot tables​

ActionShortcutDescription
Update pivot tableAlt+F5Update the previously selected pivot table.
Update all pivot tablesCtrl+Alt+F5 *Update all pivot tables.
note

* This keyboard shortcut does not work on Linux.

Slicers​

ActionShortcutDescription
Clear selected valuesAlt+CClear selected values for a slicer.
Switch multi-selectAlt+SEnable/disable multi-select for a slicer.

Formatted tables​

ActionShortcutDescription
Add summary rowCtrl+⇧ Shift+RAdd the Summary row for a formatted table.

Functions​

ActionShortcutDescription
Insert function⇧ Shift+F3Open the dialog box for inserting a new function by choosing from the provided list.
SUM functionAlt+=Insert the SUM function into the selected cell.
Recalculate functionsF9Recalculate the entire workbook.
Recalculate functions⇧ Shift+F9Recalculate the current worksheet.
Display functions on sheetCtrl+`Display functions (not their values) on a sheet for printing them.
Switch the type of referenceF4Switch the type of a reference to a cell in the formula bar (absolute, relative).

Data Formats​

ActionShortcutDescription
Open the 'Number Format' dialog boxCtrl+1Open the Number Format dialog box.
Apply the General formatCtrl+⇧ Shift+~Apply the General number format.
Apply the Currency formatCtrl+⇧ Shift+$Apply the Currency format with two decimal places.
Apply the Percentage formatCtrl+⇧ Shift+%Apply the Percentage format with no decimal places.
Apply the Exponential formatCtrl+⇧ Shift+^Apply the Exponential number format with two decimal places.
Apply the Date formatCtrl+⇧ Shift+#Apply the Date format with the day, month, and year.
Apply the Time formatCtrl+⇧ Shift+@Apply the Time format with the hour and minute, and AM or PM.
Apply the Number formatCtrl+⇧ Shift+!Apply the Number format with two decimal places, thousands separator, and minus sign (-) for negative values.

Modifying Objects​

ActionShortcutDescription
Working with shapes↵ EnterWhen the shape is selected, if it does not contain content, create content and move the cursor to the beginning of the line. If the content is empty, move the cursor to it, otherwise select the entire content.
Working with charts↵ EnterWhen the chart title is selected, select the text.
Create a copy when draggingCtrlSelect an object and hold down the specified key when dragging the object to create the copy of the object in the location where it was moved.
Constrain movement⇧ Shift + dragConstrain the movement of the selected object horizontally or vertically.
Set 15-degree rotation⇧ Shift + drag (when rotating)Constrain the rotation angle to 15-degree increments.
Maintain proportions⇧ Shift + drag (when resizing)Maintain the proportions of the selected object when resizing.
Change angle of line/arrow when drawing⇧ Shift + drag (when drawing lines/arrows)Hold down the Shift key while drawing the line/arrow and rotate the spout of the arrow/end of the line to change the angle of the line/arrow when drawing it. The line/arrow will be rotated exactly 45 degrees.
Movement by one-pixel incrementsCtrl+← → ↑ ↓Hold down the specified key and use the keyboard arrows to move the selected object to the left, right, up, or down by one pixel at a time.
Move shape by a big step← → ↑ ↓Use the keyboard arrows to move the selected object by a big step to the left, right, up, or down.
Move focus to the next object↹ TabMove focus to the next object after the currently selected one.
Move focus to the previous object⇧ Shift+↹ TabMove focus to the previous object before the currently selected one.
Select allCtrl+ASelect all shapes (when the focus is on a shape).
Add tab character to the object content↹ TabAdd the tab character to the object content.
SubscriptCtrl+.Make the selected text fragment smaller and place it to the lower part of the text line, e.g. as in chemical formulas. Works only with text within a graphical object.
SuperscriptCtrl+,Make the selected text fragment smaller and place it to the upper part of the text line, e.g. as in fractions. Works only with text within a graphical object.
Increase fontCtrl+]Increase the size of the font for the selected text fragment 1 point. Works only with text within a graphical object.
Decrease fontCtrl+[Decrease the size of the font for the selected text fragment 1 point. Works only with text within a graphical object.
Align centerCtrl+ESwitch a paragraph between centered and left-aligned. Works only with text within a graphical object.
Align justifiedCtrl+JSwitch a paragraph between justified and left-aligned. Works only with text within a graphical object.
Align rightCtrl+RSwitch a paragraph between right-aligned and left-aligned. Works only with text within a graphical object.
Align leftCtrl+LAlign a paragraph left. Works only with text within a graphical object.
End paragraph and start a new one↵ EnterEnd the current paragraph and start a new one when entering text within a graphical object.
Add line break⇧ Shift+↵ EnterAdd a line break without starting a new paragraph when entering text within a graphical object.
Remove graphical objectDelete, Ctrl+Delete, ← Backspace, Ctrl+← BackspaceRemove graphical object.
Exit from adding shapes mode, remove selection step by stepEscExit from adding shapes mode. Remove selection step by step (e.g., if the content of a shape within a group is selected, the cursor will be removed from the content first, then from the shape, then from the group).